aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2024-04-15 11:48:27 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2024-04-15 12:19:15 +0000
commitb044ac8585ed4ee92281285006a6abb5edcb63bf (patch)
treec4af9bd20701a66472e7498c95c779ece2c2c451
parent35fb0b0ea25d64c6e09590be827edc78289669d0 (diff)
downloadports-b044ac8585ed4ee92281285006a6abb5edcb63bf.tar.gz
ports-b044ac8585ed4ee92281285006a6abb5edcb63bf.zip
textproc/yelp-tools: fix dependencies
this tool does not depend on gettext runtime. It does not depend on libxml2 nor libxsltproc, it does depends on the tools xmlling and xsltproc
-rw-r--r--textproc/yelp-tools/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/textproc/yelp-tools/Makefile b/textproc/yelp-tools/Makefile
index 65a09e6ec0f4..d57cb831dadc 100644
--- a/textproc/yelp-tools/Makefile
+++ b/textproc/yelp-tools/Makefile
@@ -1,5 +1,6 @@
PORTNAME= yelp-tools
PORTVERSION= 42.0
+PORTREVISION= 1
CATEGORIES= textproc gnome
MASTER_SITES= GNOME/sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+)\..*/\1/}
DIST_SUBDIR= gnome
@@ -13,11 +14,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING.GPL
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
itstool:textproc/itstool \
+ xmllint:textproc/libxml2 \
+ xsltproc:textproc/libxslt \
yelp-xsl>=0:textproc/yelp-xsl
+RUN_DEPENDS= xmllint:textproc/libxml2 \
+ xsltproc:textproc/libxslt
-USES= gettext gnome localbase meson pathfix pkgconfig python \
+USES= localbase meson pkgconfig python \
shebangfix tar:xz
-USE_GNOME= libxml2 libxslt
SHEBANG_FILES= tools/yelp-build.in tools/yelp-check.in tools/yelp-new.in
BINARY_ALIAS= python3=${PYTHON_CMD}