aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-03-30 12:01:33 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-03-30 15:56:52 +0000
commitb108b2ccc2a60e3f6fef1bea81e9ba20432014eb (patch)
tree31f5d4500068674f87e32d4b4c2b026b7fd0726d
parentda31b5baca2270183e83c3a13798161e42160b6f (diff)
downloadports-b108b2ccc2a60e3f6fef1bea81e9ba20432014eb.tar.gz
ports-b108b2ccc2a60e3f6fef1bea81e9ba20432014eb.zip
devel/py-fabric: Update version 2.7.1=>3.0.0
- Change minimum python version to 3.7 Changelog: https://www.fabfile.org/changelog.html
-rw-r--r--devel/py-fabric/Makefile5
-rw-r--r--devel/py-fabric/distinfo6
-rw-r--r--devel/py-fabric/files/patch-setup.py11
3 files changed, 5 insertions, 17 deletions
diff --git a/devel/py-fabric/Makefile b/devel/py-fabric/Makefile
index df360560d241..576d4ac3de42 100644
--- a/devel/py-fabric/Makefile
+++ b/devel/py-fabric/Makefile
@@ -1,6 +1,5 @@
PORTNAME= fabric
-PORTVERSION= 2.7.1
-PORTREVISION= 1
+PORTVERSION= 3.0.0
PORTEPOCH= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
@@ -18,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}invoke>=1.3:devel/py-invoke@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pathlib2>0:devel/py-pathlib2@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=2.0.0:devel/py-mock@${PY_FLAVOR}
-USES= cpe python:3.6+
+USES= cpe python:3.7+
CPE_VENDOR= fabfile
USE_PYTHON= autoplist concurrent distutils pytest
diff --git a/devel/py-fabric/distinfo b/devel/py-fabric/distinfo
index c2207dc0d31d..6909e4d8163b 100644
--- a/devel/py-fabric/distinfo
+++ b/devel/py-fabric/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1658255812
-SHA256 (fabric-2.7.1.tar.gz) = 76f8fef59cf2061dbd849bbce4fe49bdd820884385004b0ca59136ac3db129e4
-SIZE (fabric-2.7.1.tar.gz) = 167922
+TIMESTAMP = 1680177359
+SHA256 (fabric-3.0.0.tar.gz) = bfe960c1ae904e7624af9d40ad5b9b99581ed9c4fd09349c0d02b7486e1d0f89
+SIZE (fabric-3.0.0.tar.gz) = 175654
diff --git a/devel/py-fabric/files/patch-setup.py b/devel/py-fabric/files/patch-setup.py
deleted file mode 100644
index 9b328a3a6d2a..000000000000
--- a/devel/py-fabric/files/patch-setup.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py.orig 2022-07-14 22:37:01 UTC
-+++ setup.py
-@@ -65,7 +65,7 @@ setuptools.setup(
- "CI": "https://app.circleci.com/pipelines/github/fabric/fabric",
- "Twitter": "https://twitter.com/pyfabric",
- },
-- install_requires=["invoke>=1.3,<2.0", "paramiko>=2.4", "pathlib2"],
-+ install_requires=["invoke>=1.3", "paramiko>=2.4", "pathlib2"],
- extras_require={
- "testing": testing_deps,
- "pytest": testing_deps + pytest_deps,