aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-06-07 20:52:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-06-07 20:53:25 +0000
commitb1795cf0ef0eba61ed713038340b3fb251aed36f (patch)
tree7f1f286d8506a1b6914f14875491c92a34059191
parent0667142fba5471b560d07ba96dd95dd9ff350b79 (diff)
devel/git-tui: Terminal interface for some git commands
-rw-r--r--devel/Makefile1
-rw-r--r--devel/git-tui/Makefile24
-rw-r--r--devel/git-tui/distinfo3
-rw-r--r--devel/git-tui/files/patch-CMakeLists.txt17
-rw-r--r--devel/git-tui/pkg-descr1
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0fdb539d9d00..51df50a521c1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -827,6 +827,7 @@
SUBDIR += git-subrepo
SUBDIR += git-svn
SUBDIR += git-town
+ SUBDIR += git-tui
SUBDIR += git-workspace
SUBDIR += gitaly
SUBDIR += gitflow
diff --git a/devel/git-tui/Makefile b/devel/git-tui/Makefile
new file mode 100644
index 000000000000..73d2c189b318
--- /dev/null
+++ b/devel/git-tui/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= git-tui
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2.0
+CATEGORIES= devel science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Terminal interface for some git commands
+WWW= https://github.com/ArthurSonzogni/git-tui
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libftxui-screen.so:devel/ftxui \
+ libsubprocess.so:devel/subprocess
+
+USES= cmake:testing compiler:c++17-lang localbase:ldflags
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= ArthurSonzogni
+
+PLIST_FILES= bin/git-tui
+
+.include <bsd.port.mk>
diff --git a/devel/git-tui/distinfo b/devel/git-tui/distinfo
new file mode 100644
index 000000000000..d669067cf49b
--- /dev/null
+++ b/devel/git-tui/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1717720380
+SHA256 (ArthurSonzogni-git-tui-v1.2.0_GH0.tar.gz) = 51fc9f55846fddb544f247e4154970c75d794a8523b240a914018eb59143bb91
+SIZE (ArthurSonzogni-git-tui-v1.2.0_GH0.tar.gz) = 2516163
diff --git a/devel/git-tui/files/patch-CMakeLists.txt b/devel/git-tui/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..f239e5f3b9f2
--- /dev/null
+++ b/devel/git-tui/files/patch-CMakeLists.txt
@@ -0,0 +1,17 @@
+--- CMakeLists.txt.orig 2024-06-07 20:27:03 UTC
++++ CMakeLists.txt
+@@ -12,10 +12,10 @@ find_or_fetch_package(ftxui v5.0.0
+ cdf28903a7781f97ba94d30b79c3a4b0c97ccce7
+ )
+
+-find_or_fetch_package(subprocess v0.4.0
+- https://github.com/benman64/subprocess
+- e1cae5e86e5d089e65e906f7c13917b7bbb75d04
+-)
++#find_or_fetch_package(subprocess v0.4.0
++# https://github.com/benman64/subprocess
++# e1cae5e86e5d089e65e906f7c13917b7bbb75d04
++#)
+
+ # ------------------------------------------------------------------------------
+
diff --git a/devel/git-tui/pkg-descr b/devel/git-tui/pkg-descr
new file mode 100644
index 000000000000..8cb574ecc498
--- /dev/null
+++ b/devel/git-tui/pkg-descr
@@ -0,0 +1 @@
+git-tui is a collection of human friendly terminal interface for git.