aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2024-04-01 08:30:02 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2024-04-01 08:32:09 +0000
commitb1db33efdd0132b085f5971ec8af326b7c349fe4 (patch)
tree71c12ecd29b0cc811efe7cb9c41c519f4b393e2d
parent375f546fde87e713d213cd6d8c8067416ff13639 (diff)
downloadports-b1db33efdd0132b085f5971ec8af326b7c349fe4.tar.gz
ports-b1db33efdd0132b085f5971ec8af326b7c349fe4.zip
devel/cdk: Update to 5.0-20240331
- Allow multiple jobs - Pet portlint, porclippy and portfmt - Take maintainership ChangeLog: https://invisible-island.net/cdk/CHANGES.html
-rw-r--r--devel/cdk/Makefile17
-rw-r--r--devel/cdk/distinfo6
-rw-r--r--devel/cdk/pkg-plist91
3 files changed, 16 insertions, 98 deletions
diff --git a/devel/cdk/Makefile b/devel/cdk/Makefile
index 2ca597032e2f..b8be6f09a5fd 100644
--- a/devel/cdk/Makefile
+++ b/devel/cdk/Makefile
@@ -1,12 +1,11 @@
PORTNAME= cdk
-DISTVERSION= 5.0-20230201
-PORTREVISION= 1
+DISTVERSION= 5.0-20240331
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= https://invisible-island.net/archives/${PORTNAME}/\
https://invisible-mirror.net/archives/${PORTNAME}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= eduardo@FreeBSD.org
COMMENT= Curses Development Kit for speedy development of full screen programs
WWW= https://invisible-island.net/cdk/
@@ -14,15 +13,17 @@ LICENSE= BSD4CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake ncurses tar:tgz
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
-PORTDOCS= README
-MAKE_JOBS_UNSAFE= yes
-
CONFIGURE_ARGS+=--with-ncurses
+
ALL_TARGET= default cdkshlib
INSTALL_TARGET= install installCDKSHLibrary
-USE_LDCONFIG= yes
+
+PORTDOCS= README
+PORTEXAMPLES= cli demos examples
OPTIONS_DEFINE= DOCS EXAMPLES
@@ -36,7 +37,7 @@ post-install:
post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC} && \
- ${COPYTREE_SHARE} "cli demos examples" \
+ ${COPYTREE_SHARE} "${PORTEXAMPLES}" \
${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/devel/cdk/distinfo b/devel/cdk/distinfo
index 78469cfccb10..d16eb2daee5a 100644
--- a/devel/cdk/distinfo
+++ b/devel/cdk/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1706228170
-SHA256 (cdk-5.0-20230201.tgz) = a3127b59fe505f5e898daa3dd15b0cf724a1274ce68165b779be2f29d4c4f2f6
-SIZE (cdk-5.0-20230201.tgz) = 533972
+TIMESTAMP = 1711958963
+SHA256 (cdk-5.0-20240331.tgz) = 8c5d7c6138ae3d76cf149027e1b10a6727c52fd0a7177fca934436890bb0f2de
+SIZE (cdk-5.0-20240331.tgz) = 538287
diff --git a/devel/cdk/pkg-plist b/devel/cdk/pkg-plist
index 37789f48a346..381462d5f477 100644
--- a/devel/cdk/pkg-plist
+++ b/devel/cdk/pkg-plist
@@ -5,6 +5,7 @@ include/cdk/binding.h
include/cdk/button.h
include/cdk/buttonbox.h
include/cdk/calendar.h
+include/cdk/cdk.h
include/cdk/cdk_compat.h
include/cdk/cdk_config.h
include/cdk/cdk_objs.h
@@ -48,10 +49,12 @@ lib/libcdk.so.5.0
share/man/man1/cdk5-config.1.gz
share/man/man3/Beep.3.gz
share/man/man3/CDKallocStrings.3.gz
+share/man/man3/CDKchdir.3.gz
share/man/man3/CDKcountStrings.3.gz
share/man/man3/CDKfreeChtypes.3.gz
share/man/man3/CDKfreeStrings.3.gz
share/man/man3/CDKgetDirectoryContents.3.gz
+share/man/man3/CDKopenFile.3.gz
share/man/man3/CDKparamNumber.3.gz
share/man/man3/CDKparamNumber2.3.gz
share/man/man3/CDKparamString.3.gz
@@ -395,7 +398,6 @@ share/man/man3/getCDKSwindowContents.3.gz
share/man/man3/getCDKTemplateBox.3.gz
share/man/man3/getCDKTemplateMin.3.gz
share/man/man3/getCDKTemplateValue.3.gz
-share/man/man3/getCdkTitle.3.gz
share/man/man3/getCDKUScaleBox.3.gz
share/man/man3/getCDKUScaleHighValue.3.gz
share/man/man3/getCDKUScaleLowValue.3.gz
@@ -409,6 +411,7 @@ share/man/man3/getCDKViewerHighlight.3.gz
share/man/man3/getCDKViewerInfo.3.gz
share/man/man3/getCDKViewerInfoLine.3.gz
share/man/man3/getCDKViewerTitle.3.gz
+share/man/man3/getCdkTitle.3.gz
share/man/man3/getDirectoryContents.3.gz
share/man/man3/getListIndex.3.gz
share/man/man3/getString.3.gz
@@ -1016,89 +1019,3 @@ share/man/man3/validCDKObject.3.gz
share/man/man3/viewFile.3.gz
share/man/man3/viewInfo.3.gz
share/man/man3/waitCDKLabel.3.gz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/Makefile
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/Makefile.in
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdkalphalist.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdkcalendar.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdkdialog.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdkentry.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdkfselect.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdkitemlist.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdklabel.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdkmatrix.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdkmentry.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdkradio.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdkscale.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdkscroll.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdkselection.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdkslider.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdktemplate.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/cdkviewer.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/alphalist.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/calendar.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/dialog.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/entry.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/fselect.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/itemlist.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/label.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/matrix.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/mentry.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/radio.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/scale.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/scroll.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/selection.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/slider.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/template.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cli/samples/viewer.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demos/Makefile
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demos/Makefile.in
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demos/appointment.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demos/clock.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demos/command.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demos/fileview.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demos/rolodex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demos/rolodex.h
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demos/serial.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demos/stopSign.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demos/syb.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demos/vinstall.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/Makefile
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/Makefile.in
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/alphalist_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/bind_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/buttonbox_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/calendar_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/cdkscreen_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/dialog_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/entry_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/fscale_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/fselect_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/fslider_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/graph_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/hello_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/histogram_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/itemlist_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/label_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/lowerCDKObject_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/marquee_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/matrix_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/mentry_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/menu_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/position_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/preprocess_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/radio1_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/radio_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/raiseCDKObject_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/scale_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/scroll_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/selection_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/slider_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/subwindow_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/swindow_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/template_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/traverse_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/uslider_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/viewer_ex.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/viewer_ex2.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/mentry_ex2.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/scroll_ex2.c