aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-04 15:32:47 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-04 18:54:27 +0000
commitb1f84cefd9c83da15053a994e6dbfa582374cf8e (patch)
treed91282ab481a15c231e2b703358194af844956de
parent4c1092a652947a8e1067468238e720daaabd5fe8 (diff)
downloadports-b1f84cefd9c83da15053a994e6dbfa582374cf8e.tar.gz
ports-b1f84cefd9c83da15053a994e6dbfa582374cf8e.zip
UPDATING: Trim upto stable/9 release
Approved by: portmgr
-rw-r--r--UPDATING3175
1 files changed, 0 insertions, 3175 deletions
diff --git a/UPDATING b/UPDATING
index cec23f11a5e9..425cfbebcc6e 100644
--- a/UPDATING
+++ b/UPDATING
@@ -15458,3178 +15458,3 @@ leave you without networking.
If you want to switch to lang/perl5.14 from lang/perl5.{8,10,12} please
follow instructions in the entry 20110517 in this file.
-
-20111205:
- AFFECTS: users of ruby-gnome ports
- AUTHOR: swills@FreeBSD.org
-
- ruby-gnome has been updated to 1.0.3. Some of them have been removed
- since they are no longer included upstream. The meta port is
- now x11/ruby-gnome2. To update run the following command:
-
- # portmaster -o x11/ruby-gnome2 x11/ruby-gnome2-all
-
- You may also wish to remove the old ports using:
-
- # portmaster -s
-
-20111130:
- AFFECTS: users of dns/nsd
- AUTHOR: zi@FreeBSD.org
-
- The database format of nsd.db has changed as of version 3.2.9.
- Before you run nsd, you must convert the existing database:
-
- # nsdc rebuild
-
-20111123:
- AFFECTS: users of net-im/kopete or net-im/libjingle
- AUTHOR: kde@FreeBSD.org
-
- kopete and libjingle are now depending on a newer oRTP from
- linphone-base. To correctly switch to the new port, you need to deinstall
- ortp prior to the update:
-
- # pkg_delete -f ortp-\*
-
-20111123:
- AFFECTS: users of databases/redis
- AUTHOR: osa@FreeBSD.org
-
- The redis configuration file, redis.conf, have been changed, some options
- removed in newer versions (>=2.4). In some cases, redis-server with
- older configuration might does not run at startup.
-
- If you run into startup problems, re-edit configuration file.
-
-20111101:
- AFFECTS: users of x11/kde4-workspace
- AUTHOR: kde@FreeBSD.org
-
- If your KDM fails with the message
- 'X server "/usr/bin/X" cannot be executed'
- you need to delete its configuration file and restart it:
-
- # rm /usr/local/kde4/share/config/kdm/kdmrc
- # service kdm4 restart
-
-20111101:
- AFFECTS: users of graphics/poppler-gtk
- AUTHOR: Koop Mast <kwm@FreeBSD.org>
-
- Poppler was update to 0.18.0, and the gtk slave port was renamed to
- match the library it installs. Please run the following command to migrate.
-
- # portmaster -o graphics/poppler-glib poppler-gtk-0.16.7
-
-20111031:
- AFFECTS: users of textproc/py-creole
- AUTHOR: Stanislav Svirid <count@211.ru>
-
- Some API is changed: replace 'parser_kwargs' and 'emitter_kwargs'
- with separate arguments. More information on new API:
- http://code.google.com/p/python-creole/wiki/API
-
-20111025:
- AFFECTS: users of print/flpsed or www/dillo2
- AUTHOR: bf@FreeBSD.org
-
- The new versions of flpsed and dillo have switched from
- x11-toolkits/fltk2 to the new fltk 1.3.0 from x11-toolkits/fltk.
- Users who have customizations specific to fltk2 may need to consult
- the fltk 1.3 documents in order to adjust their local settings. For
- dillo, some commonly-used key bindings have changed, and new
- configuration options are available: consult dillorc.dist and
- keysrc.dist for details.
-
-20111019:
- AFFECTS: users of mail/thunderbird or www/seamonkey with lightning
- plugin installed.
- AUTHOR: gecko@FreeBSD.org
-
- To get an up to date version of lightning you should use the new
- LIGHTNING option in mail/thunderbird or www/seamonkey. This option
- is not enabled by default so you have to run "make config" prior
- to the build. The old deskutils/lightning-thunderbird and
- deskutils/lightning ports should no longer be used and will be
- removed very soon.
-
- Like other XPIs ports, lightning now registers itself as a global
- extension and doesn't create the XPI to be installed manually.
- Upgrading users should remove lightning from their profile before
- installing Thunderbird or SeaMonkey the first time with the new
- LIGHTNING option enabled.
-
-20111018:
- AFFECTS: users of mail/postfix-current
- AUTHOR: Sahil Tandon <sahil@FreeBSD.org>
-
- The default smtp_address_preference value is now "any" instead
- of "ipv6", meaning choose randomly between IPv6 and IPv4. With
- this the Postfix SMTP client will have more success delivering
- mail to sites that have problematic IPv6 configurations.
-
-20111016:
- AFFECTS: users of devel/p5-subversion-freebsd
- AUTHOR: wxs@FreeBSD.org
-
- devel/p5-subversion-freebsd has been removed as it is no longer necessary.
- If you have it installed please run the following to switch to
- devel/p5-subversion:
-
- portmaster -o devel/p5-subversion p5-subversion-freebsd
-
- Please also see the second entry below (20111016) if haven't upgraded
- subversion yet.
-
-20111016:
- AFFECTS: users of KDE SC 4
- AUTHOR: kde@FreeBSD.org
-
- KDE SC has been updated to 4.7.2. A number of files were moved between
- packages and several ports were split, thus manual intervention into
- update procedure is required:
-
- # pkg_delete -f raptor-1\* kdelibs-4\* kdebase-\*4\* \
- kdeaccessibility-4\* kdeedu-4\* kdegames-4\* kdegraphics-4\* \
- kdesdk-4\* kdeutils-4\* konq-plugins-4\* ktts\* nepomukcontroller\* \
- ruby\*-kdebindings\* kdebindings-smoke\*
- # pkg_delete -f kdehier4\*
- # mv /usr/local/kde4/etc/pam.d/* \
- /usr/local/etc/pam.d/
- # mv /usr/local/kde4/etc/rc.d/* \
- /usr/local/etc/rc.d/
- # mv /usr/local/kde4/share/dbus-1/services/* \
- /usr/local/share/dbus-1/services/
- # mv /usr/local/kde4/share/dbus-1/system-services/* \
- /usr/local/share/dbus-1/system-services/
- # rmdir /usr/local/kde4/etc/pam.d /usr/local/kde4/etc/rc.d \
- /usr/local/kde4/share/dbus-1/*services
- # rm -r /var/tmp/kdecache-*
- # portmaster misc/kdehier4
-
- If you have - or plan to install - net/kdenetwork4, also run:
-
- # portmaster -o net/linphone-base ortp
-
- Finally:
-
- # portmaster -a
-
- Also, remove /usr/local/kde4/etc/rc.d from local_startup in rc.conf(5).
- Failure to do this will cause all enabled scripts in /usr/local/etc/rc.d
- to be started twice.
-
- Remember to check for missing ports, bearing in mind that x11/kdebase4*
- ports were replaced by x11/kde4-* ones, ktts was replaced by jovie, while
- konq-plugins-kde4 and nepomukcontroller were removed. Then:
-
- # portmaster --check-depends
-
- You're also encouraged to run `pkg_cutleaves` or similar to check for
- orphaned ports.
-
- Please, note that `pkg_add -r kde4` will not install Plasma scriptengines
- and printer utilities by default anymore, and `pkg_add -r kdegames4` will
- not install Kajongg. This was made to avoid depending by default on
- kdebindings.
-
-20111016:
- AFFECTS: users of devel/subversion, devel/subversion-freebsd,
- devel/p5-subversion, devel/py-subversion,
- devel/ruby-subversion and java/subversion-java and
- all dependand ports.
- AUTHOR: Lev Serebryakov <lev@FreeBSD.org>
-
- Subversion was updated to version 1.7.0 and port was reworked.
-
- Now there is no "devel/subversion-freebsd" port. All FreeBSD-specific patches
- are incorporated into main subversion port as options, which are turned ON by
- default.
-
- These options are:
-
- P4_STYLE_MARKERS -- change conflict markers to P4 style,
- established for FreeBSD projects.
- This is not mandatory for working with
- FreeBSD sources.
-
- ENHANCED_KEYWORD -- Support for custom keywords, like
- $ FreeBSD $ in sources.
- This is MANDATORY for working with
- FreeBSD sources.
-
- FREEBSD_TEMPLATE -- Standard FreeBSD commit template.
- It is RECOMMENDED for working with
- FreeBSD sources.
-
- Also, subversion 1.7.0 changes the working copy format,
- and a working copy cannot be shared between
- subversion 1.7.0 and 1.6.x. Please, think twice before
- upgrading.
-
- Additional the port "devel/subversion16" was created to
- support subversion 1.6.x. Subversion 1.7.x and 1.6.x
- cannot be installed simultaneously!
-
- Binding ports can be built with Subversion 1.7.0 (Default)
- or with Subversion 1.6.x. To build bindings with subversion 1.6.x
- you should set variable WITH_SUBVERSION_VER to "16".
-
- There are several ways to upgrade, depending on what you used
- before and what you want to get after upgrade.
-
- (a) You use devel/subversion without FreeBSD patches and, maybe,
- some bindings. You want fresh'n'new subversion 1.7.0.
- Please, run:
-
- # cd /usr/ports/devel/subversion && make config
- <deselect first three options described above, if you want it>
- # portupgrade -r devel/subversion
- or
- # portmaster -R -r subversion-1.6
-
- (b) You use devel/subversion-freebsd and, maybe, some
- bindings. You want fresh'n'new subversion 1.7.0, again
- with FreeBSD patches.
- Please, run:
-
- # cd /usr/ports/devel/subversion && make config
- <make sure that first three options are selected>
- # portupgrade -o devel/subversion devel/subversion-freebsd
- # portupgrade -r devel/subversion
- or
- # portmaster -o devel/subversion devel/subversion-freebsd
- # portmaster -R -r subversion-1.7
-
- (c) You use devel/subversion without FreeBSD patches and, maybe,
- some bindings. You want good old subversion 1.6.x, again
- without again.
- Please, run:
-
- # cd /usr/ports/devel/subversion16 && make config
- <deselect first three options described above, if you want it>
- # portupgrade -o devel/subversion16 devel/subversion
- # portupgrade -m "WITH_SUBVERSION_VER=16" -r devel/subversion16
- or
- # portmaster -o devel/subversion16 devel/subversion
- # portmaster -m "WITH_SUBVERSION_VER=16" -R -r subversion-1.6
-
- (d) You use devel/subversion-freebsd and, maybe, some bindings.
- You want good old subversion 1.6.x, with FreeBSD patches.
- Please, run:
-
- # cd /usr/ports/devel/subversion16 && make config
- <make sure, that first three options are selected>
- # portupgrade -o devel/subversion16 devel/subversion-freebsd
- # portupgrade -m "WITH_SUBVERSION_VER=16" -r devel/subversion16
- or
- # portmaster -o devel/subversion16 devel/subversion-freebsd
- # portmaster -m "WITH_SUBVERSION_VER=16" -R -r subversion-1.6
-
-20111005:
- AFFECTS: users of lang/erlang
- AUTHOR: Jimmy Olgeni <olgeni@FreeBSD.org>
-
- Following the R14B04 upgrade the JAVA, X11, WX and ODBC port
- options have been set to OFF by default; this will allow to replace
- lang/erlang-lite with lang/erlang for headless operation in the
- near future.
-
- If you need any of these options, run "make config" in lang/erlang
- before upgrading, or set your make.conf accordingly.
-
-20111003:
- AFFECTS: users of math/qhull
- AUTHOR: Stephen Montgomery-Smith <stephen@FreeBSD.org>
-
- The port math/qhull has been moved to math/qhull5, and math/qhull has been
- updated to a version that is incompatible with all ports previously using
- math/qhull. If you are upgrading a port that has math/qhull as a dependency,
- please delete the port math/qhull first, so that math/qhull5 is properly
- made as a dependency.
-
-20110929:
- AFFECTS: users of net/py-zope.proxy, devel/py-zope.testing and
- devel/py-zope.interface
- AUTHOR: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
-
- Several Zope ports have been renamed for consistency with their
- upstream distributions. Please run the following commands to update
- your local installations:
-
- If you use portmaster run:
- # portmaster -o devel/py-zope.interface devel/py-zopeInterface
- # portmaster -o net/py-zope.proxy net/py-zopeproxy
- # portmaster -o devel/py-zope.testing devel/py-zopetesting
-
- If you use portupgrade run:
- # portupgrade -o devel/py-zope.interface devel/py-zopeInterface
- # portupgrade -o net/py-zope.proxy net/py-zopeproxy
- # portupgrade -o devel/py-zope.testing devel/py-zopetesting
-
-20110928:
- AFFECTS: users of 10-current
- AUTHOR: eadler@FreeBSD.org
-
- There are known issues installing ports on FreeBSD 10+ due to
- bogus assumptions by various build scripts. This will not be fixed
- until 9-RELEASE is released.
-
- There are two workarounds:
-
- 1) Set UNAME_r=9.9-CURRENT in your environment
- 2) Set REVISION="9.9" in ${SRCDIR}/sys/conf/newvers.sh
-
-20110928:
- AFFECTS: users of www/nginx-devel
- AUTHOR: osa@FreeBSD.org
-
- Note: 1.1.4 release introduces several API changes which may affect
- third-party modules.
-
-20110925:
- AFFECTS: users of lang/python*
- AUTHOR: lwhsu@FreeBSD.org
-
- The HUGE_STACK_SIZE option has been removed, now Python will use default
- thread stack size of the system. If you want to change it, specify it
- with -DTHREAD_STACK_SIZE=<size> in CFLAGS.
-
-20110925:
- AFFECTS: users of net/openldap*
- AUTHOR: ume@FreeBSD.org
-
- The security/cyrus-sasl2 was updated to 2.1.25. If the SASL option
- is enabled (disabled by default), net/openldap* must be recompiled
- after upgrading cyrus-sasl2.
-
-20110921:
- AFFECTS: users of devel/maven2 and devel/maven3
- AUTHOR: hq@FreeBSD.org
-
- The devel/maven2 and devel/maven3 now rely on a wrapper port:
- devel/maven-wrapper. If you plan to upgrade the devel/maven[23] ports, you
- will have to uninstall all of them before reinstalling them.
-
-20110917:
- AFFECTS: users of misc/tvbrowser
- AUTHOR: lme@FreeBSD.org
-
- From version 3.0.2 on TV-Browser doesn't include any plugins any longer. You
- are supposed to download the plugins manually, this also means that you need
- to download the appropriate channel sources plugin for your country. After
- installing it your previously configured channels are visible again. To do so,
- select "Tools -> Install / Update Plugins..." and choose the plugins you need.
-
-20110915:
- AFFECTS: users of dns/unbound
- AUTHOR: sem@FreeBSD.org
-
- unbound supports GOST from version 1.4.12 but only if dns/ldns was build
- with GOST support too. There is no way to check the option when unbound
- builds, so you should make sure the option is on in both unbound and lds.
-
-20110914:
- AFFECTS: users of www/asterisk-stat
- AUTHOR: flo@FreeBSD.org
-
- asterisk-stat depends on asterisk16 now, you will need to update asterisk
- and asterisk-addons to 1.6. Instructions on upgrading your configuration
- files are here:
-
- http://svnview.digium.com/svn/asterisk/branches/1.6.2/UPGRADE-1.6.txt
-
- If you use portmaster run:
- # portmaster -o net/asterisk16 net/asterisk14
- # portmaster -o net/asterisk16-addons net/asterisk14-addons
-
- If you use portupgrade run:
- # portupgrade -o net/asterisk16 net/asterisk14
- # portupgrade -o net/asterisk16-addons net/asterisk14-addons
-
-20110909:
- AFFECTS: users of net/p5-SOAP-Lite
- AUTHOR: az@FreeBSD.org
-
- SOAP::Transport::TCP is not a part of net/p5-SOAP-Lite
- distribution since version 0.714. If you need SOAP::Transport::TCP
- you should install net/p5-SOAP-Transport-TCP manually.
-
-20110901:
- AFFECTS: users of databases/db51
- AUTHOR: mandree@FreeBSD.org
-
- The databases/db51 port (Oracle Berkeley DB version 5.1) has been
- removed. Version 5.2 of the package is available in databases/db5.
- Users of ports that depend on the removed 5.1 versions are advised
- to rebuild the affected ports.
-
-20110830:
- AFFECTS: users of lang/racket
- AUTHOR: olgeni@FreeBSD.org
-
- Racket has been upgraded to version 5.1.3. Due to the recent rewrite of
- the Racket graphics handling code, it is no longer possible to build
- this port without X11.
-
- The WITHOUT_X11 switch now controls if X11 is brought in as
- USE_GNOME/LIB_DEPENDS or BUILD_DEPENDS.
-
- In the latter case you will be able to build a Racket package that can
- then be deployed on a headless server.
-
-20110829:
- AFFECTS: users of security/maia
- AUTHOR: Janky Jay, III <ek@purplehat.org>
-
- There have been many changes to the maia port, including renaming the rc
- script and variables from maia to maiad. You will need to replace any
- instances of maia with maiad in /etc/rc.conf, as well as renaming /var/amavisd
- to /var/maiad. The 'vscan' user's home directory also needs to be changed to
- /var/maiad.
-
- These can be done by:
-
- # mv /var/amavisd /var/maiad
- # sed -i.bak -e "s/^maia_/maiad_/" /etc/rc.conf
- # pw usermod vscan -d /var/maiad
-
-20110828:
- AFFECTS: users of print/cups-{base,client,image}
- AUTHOR: sahil@FreeBSD.org
-
- During the update to 1.4.8, the GNUTLS option was changed from ON to
- OFF by default. Because old configuration options are saved, users
- should re-run 'make config' and explicitly deselect the GNUTLS option
- before upgrading.
-
-20110823:
- AFFECTS: users of lang/ruby
- AUTHOR: swills@FreeBSD.org
-
- The default ruby version has been reverted from 1.9 to 1.8. If you followed
- the procedure in the 20110822 entry, you may need to follow these steps:
-
- If you use portmaster:
- # portmaster -o lang/ruby18 lang/ruby19
- # portmaster -R -r ruby-1.8
-
- If you use portupgrade:
- # portupgrade -f lang/ruby19
- # portupgrade -f lang/ruby18 # if you have it installed
- # portupgrade -f ports-mgmt/portupgrade
- # portupgrade -x ruby-1.9.\* -fr lang/ruby19
-
- If you wish to keep the 1.9 version as default, add the following lines
- to your /etc/make.conf file:
-
- #
- # Keep ruby 1.9 as default version.
- #
- RUBY_DEFAULT_VER=1.9
-
-20110823:
- AFFECTS: users of devel/libnotify and net/libproxy
- AUTHOR: gnome@FreeBSD.org
-
- libnotify and libproxy are updated with shared library bumps.
- This requires dependancies to be rebuild.
-
- # portmaster -r libnotify-0
- # portmaster -r libproxy-0
- # portmaster -a
-or
- # portupgrade -rf libnotify-0.\* libproxy-0.\*
- # portupgrade -aR
-
-20110822:
- AFFECTS: users of lang/ruby
- AUTHOR: stas@FreeBSD.org
-
- The default ruby version has been updated to 1.9. Please rebuild all ports that
- depends on it.
-
- If you use portmaster:
- # portmaster -o lang/ruby19 lang/ruby18
- # portmaster -R -r ruby-1.9
-
- If you use portupgrade:
- # portupgrade -f lang/ruby18
- # portupgrade -f lang/ruby19 # if you have it installed
- # portupgrade -f ports-mgmt/portupgrade
- # portupgrade -x ruby-1.8.\* -fr lang/ruby18
-
- After these steps are complete, you can pkg_delete ruby 1.8 if you
- no longer need it.
-
- If you wish to keep the 1.8 version as default, add the following lines
- to your /etc/make.conf file, and rebuild lang/ruby18 after that.
-
- #
- # Keep ruby 1.8 as default version.
- #
- RUBY_DEFAULT_VER=1.8
-
-20110822:
- AFFECTS: users of graphics/opencv
- AUTHOR: mm@FreeBSD.org
-
- OpenCV python module was moved to own port: graphics/py-opencv
-
-20110820:
- AFFECTS: users of www/apache* and depending ports
- AUTHOR: ohauer@FreeBSD.org
-
- The default apache version changed from www/apache13 to www/apache22.
- Users who will continue with apache13 should create the following entry
- in /etc/make.conf
-
- APACHE_PORT= www/apache13
-
-20110818:
- AFFECTS: users of mail/enigmail-* ports
- AUTHOR: ale@FreeBSD.org
-
- Like other XPIs ports, enigmail now registers itself as a global
- extension and doesn't create the XPI to be installed manually.
- Upgrading users should remove enigmail from their profile before
- installing the new port.
-
-20110815:
- AFFECTS: users of sysutils/swapexd
- AUTHOR: crees@FreeBSD.org
-
- swapexd used to clobber its config file on deinstall, unfortunately this will
- not be fixed in installed packages. Back up your config before updating, or
- you will lose it!
-
- # cp /usr/local/etc/swapexd/swapexd.conf ~/swapexd.conf.bak
-
-20110808:
- AFFECTS: users of net-mgmt/zenoss
- AUTHOR: pphillips@experts-exchange.com
-
- Some functionality of zenoss requires a valid shell. The FreeBSD port until
- now was installing a user account without a shell. To fix your existing
- installation, please run the following command as root:
-
- # pw usermod zenoss -s /bin/sh -d /usr/local/zenoss
-
-20110808:
- AFFECTS: users of dns/powerdns
- AUTHOR: tremere@cainites.net
-
- The port has been updated to PowerDNS 3.0, which includes support for DNSSEC.
-
- Before upgrading please read the following:
- http://doc.powerdns.com/upgrades.html#from2.9to3.0
-
- Make sure to read the documentation and wiki on http://powerdnssec.org/ on
- how to enable DNSSEC mode in the configuration-file and for the necessary
- database changes.
-
- Take note that not all backends support DNSSEC. The ones that do are BIND,
- SQLite3 and Generic MySQL and PgSQL.
-
-20110808:
- AFFECTS: users of security/amavisd-new
- AUTHOR: sahil@FreeBSD.org
-
- Along with new features and bug fixes, amavisd-new 2.7.0 introduces some
- incompatibilities with previous releases. Several variable defaults, SQL
- schemas, and other changes warrant a careful review of the RELEASE_NOTES.
- Also note that helper programs amavis.c and amavis-milter.c are no longer
- distributed with this package; for milter functionality, please shift to
- the dedicated security/amavisd-milter port.
-
-20110731:
- AFFECTS: users of lang/guile
- AUTHOR: jlaffaye@FreeBSD.org
-
- guile has been updated to version 1.8.8. Please rebuild all ports that
- depends on it.
-
- If you use portmaster:
- # portmaster -r guile
-
- If you use portupgrade:
- # portupgrade -fr lang/guile
-
-20110731:
- AFFECTS: users of www/typo3
- AUTHOR: Helmut Schneider <jumper99@gmx.de>
-
- www/typo3 has been repocopied to www/typo345. If you need to continue with
- the old stable version please run
-
- # portmaster -o www/typo345 www/typo3
- or
- # portupgrade -o www/typo345 www/typo3
-
- Please remember to change the path of your config files too.
-
-20110730:
- AFFECTS: users of x11-toolkits/gtk20
- AUTHOR: gnome@FreeBSD.org
-
- The gtk-update-icon-cache utility has been split out of the gtk20 port.
- Use the following instructions to update your system.
-
- # pkg_delete -f gtk-2.\*
- # portmaster x11-toolkits/gtk20
- # portmaster -a
-
-20110726:
- AFFECTS: users of devel/msp430-gcc
- AUTHOR: lev@FreeBSD.org
-
- msp430-gcc was updated to lates gcc-4.5.3 version.
- If you want to use old gcc-3.4.4, run command:
-
- # portmaster -o devel/msp430-gcc3 devel/msp430-gcc
- or
- # portupgrade -o devel/msp430-gcc3 devel/msp430-gcc
-
- before updating devel/msp430-libc port.
-
-20110721:
- AFFECTS: users of games/megaglest
- AUTHOR: smoeller@nichthelfer.de
-
- If you upgraded from version 3.4.0, your personal settings are stored in
- ~/.megaglest3.4.0. If you copy glestuser.ini and glestuserkeys.ini to
- ~/.megaglest, you will have your old settings again.
-
-20110721:
- AFFECTS: users of security/gpgme
- AUTHOR: jlaffaye@FreeBSD.org
-
- gpgme has been updated to version 1.3.1. Please rebuild all ports that depends
- on it.
-
- If you use portmaster:
- # portmaster -r gpgme
-
- If you use portupgrade:
- # portupgrade -fr security/gpgme
-
-20110718:
- AFFECTS: users of hungarian/hunspell
- AUTHOR: jlaffaye@FreeBSD.org
-
- The hunspell port has been moved to textproc/hunspell.
- To update the installed port run the command
-
- # portmaster -o textproc/hunspell hungarian/hunspell
- or
- # portupgrade -o textproc/hunspell hungarian/hunspell
-
-20110711:
- AFFECTS: users of java/openjdk6
- AUTHOR: jkim@FreeBSD.org
-
- java/openjdk6 has been updated to b23 and "WEB" option (for web browser
- plug-in and Java Web Start) has been deprecated. If you need the same
- functionality, rebuild the port with "ICEDTEA" option first, then install
- a new port java/icedtea-web with "PLUGIN" option (default). Also, if you
- have a symlink to the previous IcedTeaPlugin.so in ~/.mozilla/plugins,
- for example, you need to remove it. Note system-wide symlinks are now
- automatically created by java/icedtea-web for your convenience.
-
-20110711:
- AFFECTS: users of www/p5-libwww
- AUTHOR: mandree@FreeBSD.org
-
- portmaster cannot process the upgrade of www/p5-libwww from version
- 5 to version 6. To upgrade p5-libwww, use portupgrade instead, or
- deinstall p5-libwww before reinstalling:
-
- If you use portmaster:
- # pkg_delete -f 'p5-libwww-5*' ; portmaster www/p5-libwww
-
- If you use portupgrade, no special treatment is necessary.
-
-20110711:
- AFFECTS: users of devel/icu
- AUTHOR: bapt@FreeBSD.org
-
- icu has been updated to version 4.8. Please rebuild all ports that depends
- on it.
-
- If you use portmaster:
- # portmaster -r icu
-
- If you use portupgrade:
- # portupgrade -fr devel/icu
-
-20110706:
- AFFECTS: users of multimedia/zoneminder
- AUTHOR: bsam@FreeBSD.org
-
- RC script was renamed from zm to zoneminder. So do variables at
- /etc/rc.conf[.local]. One should fix the latter file.
-
-20110705:
- AFFECTS: users of security/libgcrypt and any port that depends on it
- AUTHOR: swills@FreeBSD.org
-
- The libgcrypt port has been updated to 1.5.0 and all shared libraries
- versions have been bumped. So you need to rebuild all applications that
- depend on libgcrypt. Do something like:
-
- # portmaster -r libgcrypt
- or
- # portupgrade -rf libgcrypt
-
-20110703:
- AFFECTS: users of print/lyx and print/lyx-devel
- AUTHOR: makc@FreeBSD.org
-
- print/lyx has been updated to 2.0. print/lyx16 has been added to ports tree
- for those who prefers to stick with the last stable in lyx-1.6.x series.
-
-20110630:
- AFFECTS: users of math/octave-forge* and benchmarks/octave-forge-benchmark
- AUTHOR: stephen@FreeBSD.org
-
- The octave-forge* port structure has been completely redesigned. This was
- to make them compatible with portmaster and other port installation tools.
-
- Before using the new octave-forge* ports, the old octave-forge* ports must
- be completely removed with, for example, the command:
-
- # pkg_delete "octave-forge*"
-
-20110630:
- AFFECTS: users of mail/thunderbird
- AUTHOR: gecko@FreeBSD.org
-
- The mail/thunderbird port has been updated to 5.0. If you want to stay with
- Thunderbird 3.1 please run:
-
- # portupgrade -o mail/thunderbird3 mail/thunderbird
- # portupgrade -o mail/thunderbird3-i18n mail/thunderbird-i18n (if installed)
- or
- # portmaster -o mail/thunderbird3 mail/thunderbird
- # portmaster -o mail/thunderbird3-i18n mail/thunderbird-i18n (if installed)
-
- Do not select the OPTIMIZED_CFLAGS option on a system with less then
- 2 GB of RAM otherwise you will run out of memory during the build.
-
- Please make sure all your addons are compatible with Thunderbird 5.0 and
- backup your ~/.thunderbird directory prior to the first launch of Thunderbird
- 5.0.
-
-20110630:
- AFFECTS: users of x11/wbar
- AUTHOR: nivit@FreeBSD.org
-
- x11/wbar has been updated to 2.2.2. Before launching the program, please
- backup your configuration file (~/.wbar), and then use the command wbar-config
- to set your preferences and change the path of the old icons (in particular
- the Bar image).
-
-20110629:
- AFFECTS: users of graphics/opencv
- AUTHOR: mm@FreeBSD.org
-
- OpenCV was updated to version 2.3.0rc and to avoid circular dependencies
- split into two ports: graphics/opencv-core and graphics/opencv
-
- Before updating please uninstall the graphics/opencv port first because
- the new dependency graphics/opencv-core contains conflicting files with
- the old port graphics/opencv.
-
-20110626:
- AFFECTS: users of mail/p5-Mail-SpamAssassin
- AUTHOR: wxs@FreeBSD.org
-
- mail/p5-Mail-SpamAssassin has been updated to version 3.3.2. Prior to
- starting spamd you must run sa-update, or spamd will fail to start.
-
-20110624:
- AFFECTS: users of deskutils/opengoo
- AUTHOR: acm@FreeBSD.org
-
- desktutils/opengoo has been renamed to deskutils/fengoffice, because
- The OpenGoo name was changed to Feng Office Community Edition.
-
- If you want migrate from opengoo to fengoffice, please see upgrading
- section at:
-
- http://fengoffice.com/web/wiki/doku.php/installation
-
-20110623:
- AFFECTS: users of databases/py-sqlalchemy
- AUTHOR: nivit@FreeBSD.org
-
- The version 0.6 of SQLAlchemy has been moved to databases/py-sqlalchemy06,
- while the port databases/py-sqlalchemy now holds the series 0.7.X.
- To update the installed port run the command
-
- # portmaster -o databases/py-sqlalchemy06 databases/py-sqlalchemy
- or
- # portupgrade -o databases/py-sqlalchemy06 databases/py-sqlalchemy
-
-20110622:
- AFFECTS: users of lang/perl5.12
- AUTHOR: skv@FreeBSD.org
-
- lang/perl5.12 has been updated to 5.12.4. You should update everything
- that depends on perl. The easiest way to do that is to use
- "perl-after-upgrade" script supplied with lang/perl5.12.
- Please see its manual page for details.
-
- If you want to switch to lang/perl5.12 from lang/perl5.{8,10} please
- follow instructions in the entry 20100715 in this file.
-
-20110620:
- AFFECTS: users of net/samba35
- AUTHOR: timur@FreeBSD.org
-
- A bug, introduced by local patch to pam_winbind.so, that made it coredump
- was spotted by Martin Minkus. It is fixed in the 3.5.9 version of the port.
- So, if pam_winbind.so started to work for you - send him kudos.
-
-20110619:
- AFFECTS: users of irc/ezbounce and irc/ezbounce-devel
- AUTHOR: flo@FreeBSD.org
-
- irc/ezbounce-devel was moved to irc/ezbounce as the version previously in
- irc/ezbounce has been broken for some time and the distfile is not available
- anymore.
-
- If you are upgrading from a 1.0X version make sure to verify that your config
- still works. There is basic compatibility for old config files but a lot has
- changed, see http://linuxftw.com/ezbounce/files/CHANGES
-
- If you run irc/ezbounce-devel you need to run one of the following commands:
-
- # portmaster -o irc/ezbounce irc/ezbounce-devel
- or
- # portupgrade -o irc/ezbounce irc/ezbounce-devel
-
-20110619:
- AFFECTS: users of lang/perl5.14
- AUTHOR: skv@FreeBSD.org
-
- lang/perl5.14 has been updated to 5.14.1. You should update everything
- that depends on perl. The easiest way to do that is to use
- "perl-after-upgrade" script supplied with lang/perl5.14.
- Please see its manual page for details.
-
- If you want to switch to lang/perl5.14 from lang/perl5.{8,10,12} please
- follow instructions in the entry 20110517 in this file.
-
-20110618:
- AFFECTS: users of mail/mailscanner
- AUTHOR: crees@FreeBSD.org
-
- mail/mailscanner no longer requires running of any renew-* targets to
- update the config files / wrapper scripts; it is now automatically
- performed as the port is installed -- these targets have been removed.
-
- As an added bonus, the binary package now performs these steps as well,
- in case you don't have a portstree handy.
-
- Before upgrading, please backup your PREFIX/etc/MailScanner,
- PREFIX/share/MailScanner and PREFIX/libexec/MailScanner if you
- have customised any of these directories, just in case.
-
-20110608:
- AFFECTS: users of security/amavisd-milter
- AUTHOR: delphij@FreeBSD.org
-
- A change have been made to rc.d script for amavisd-milter makes it to
- specify -s explicitly. If you used to override the location of listening
- socket by specifying -s, please migrate to the new way (specify
- amavisd_milter_socket in /etc/rc.conf).
-
-20110607:
- AFFECTS: users of devel/p5-Moose and devel/p5-Class-MOP
- AUTHOR: az@FreeBSD.org
-
- p5-Moose has been updated to 2.0007. Now p5-Class-MOP is a part of the
- p5-Moose distribution. Manual intervention of the update procedure is
- required:
-
- # portmaster -o devel/p5-Moose devel/p5-Class-MOP
- # portmaster -R -r p5-Moose-\*
-
- or do the same things with portupgrade.
-
- To check everything went fine you can run:
- # perl -Moose\ 999
- and
- # perl -MClass::MOP\ 999
- in both cases you should see output:
- version 999 required--this is only version 2.0007
-
-20110606:
- AFFECTS: users of mail/sympa
- AUTHOR: crees@FreeBSD.org
-
- Sympa previously used to install to ${PREFIX}/sympa, which goes against
- the general rules for hierarchy. Most files which were previously found
- in ${PREFIX}/sympa should now be found in ${PREFIX}/libexec/sympa.
-
- Any configuration in httpd.conf files etc will need to be updated to the
- new directory.
-
- Before upgrade, it is advisable to back up configuration files
- ${PREFIX}/etc/sympa.conf and wwsympa.conf since previous versions wipe these
- out on deinstall.
-
-20110606:
- AFFECTS: users of databases/mariadb
- AUTHOR: dougb@FreeBSD.org
-
- The mariadb port has been split into -client, -scripts, and -server ports
- ala mysql. You can now install only the parts that you need.
-
- If you have devel/libevent installed along with mariadb you should do
- something like:
-
- pkg_delete mariadb\*
- portmaster devel/libevent
-
-20110605:
- AFFECTS: users of security/gnutls and any port that depends on it
- AUTHOR: novel@FreeBSD.org
-
- gnutls has been updated to 2.12.6.1 and all shared libraries versions have
- been bumped. So you need to rebuild all applications that depend on
- gnutls. Do something like:
-
- portupgrade -rf gnutls
- portmaster -r gnutls
-
-20110605:
- AFFECTS: users of sysutils/zfsnap
- AUTHOR: Aldis Berjoza <aldis@bsdroot.lv>
-
- There is an issue with zpool v28 (currently only on 9-CURRENT, or
- 8-STABLE systems that have been manually patched) that affects
- zfSnap. If you are using v28 make sure to use the -zpool28fix flag
- with zfsnap to work around the problem.
-
- For more information please see:
-
- http://wiki.bsdroot.lv/zfsnap#zpool_v28_zfs_destroy_-r_bug
-
-20110602:
- AFFECTS: users of net/freeradius
- AUTHOR: Sevan Janiyan <venture37@geeklan.co.uk>
-
- Freeradius no longer runs as nobody. It now runs as the freeradius
- user. Please ensure that the following paths are owned by freeradius:
-
- /var/run/radiusd
- /var/log/radacct
- /var/log/radius.log
-
-20110529:
- AFFECTS: users of textproc/*kmfl*
- AUTHOR: nikola.lecic@anthesphoria.net
-
- KMFL keyboard ports are now shared between IBus and SCIM KMFL IMEngines
- (textproc/ibus-kmfl and textproc/scim-kmfl-imengine). Thus, the prefix
- 'scim-' is dropped from keyboard ports names.
-
- Similar to m17n, both engines now search engine-neutral locations,
- ${LOCALBASE}/share/kmfl/ and ~/.kmfl/. Users have to move their local
- keyboard files from ~/.scim/kmfl/ to ~/.kmfl/.
-
-20110523:
- AFFECTS: users of www/mod_perl2
- AUTHOR: ohauer@FreeBSD.org
-
- mod_perl2 was updated to version 2.0.5, this version includes
- p5-Apache-Reload again. The ports p5-Apache-Reload is now marked as
- conflict for mod_perl2.
-
- To update your mod_perl2 with portmaster use the commands
-
- # portmaster -o www/mod_perl2 www/p5-Apache-Reload
- # portmaster -R -r mod_perl2
-
-20110522:
- AFFECTS: users of emulators/virtualbox-ose
- AUTHOR: vbox@FreeBSD.org
-
- The emulators/virtualbox-ose port has been updated to 4.0.8. If you
- want to stay with VirtualBox 3.2.x please run:
-
- # portmaster -o emulators/virtualbox-ose-kmod-legacy emulators/virtualbox-ose-kmod
- # portmaster -o emulators/virtualbox-ose-legacy emulators/virtualbox-ose
- or
- # portupgrade -o emulators/virtualbox-ose-kmod-legacy emulators/virtualbox-ose-kmod
- # portupgrade -o emulators/virtualbox-ose-legacy emulators/virtualbox-ose
-
- The emulators/virtualbox-ose-legacy port will always include the
- latest legacy version as a fallback if you hit a serious regression
- in the latest version.
-
-20110517:
- AFFECTS: users of lang/perl*
- AUTHOR: skv@FreeBSD.org
-
- lang/perl5.14 is out. If you want to switch to it from, for example
- lang/perl5.12, that is:
-
- Portupgrade users:
- 0) Fix pkgdb.db (for safety):
- pkgdb -Ff
-
- 1) Reinstall new version of Perl (5.14):
- env DISABLE_CONFLICTS=1 portupgrade -o lang/perl5.14 -f perl-5.12.\*
-
- 2) Reinstall everything that depends on Perl:
- portupgrade -fr perl
-
- Portmaster users:
- portmaster -o lang/perl5.14 lang/perl5.12
-
- Conservative:
- portmaster p5-
-
- Comprehensive (but perhaps overkill):
- portmaster -r perl-
-
- Note: If the "perl-" glob matches more than one port you will need to
- specify the name of the Perl directory in /var/db/pkg explicitly.
-
-20110516:
- AFFECTS: users of net/skype, net/skype-devel, net-im/skype, net-im/skype-devel
- AUTHOR: Ion-Mihai Tetcu <itetcu@FreeBSD.org>
-
- All skype ports were moved to net-im/:
- - skype12: unchanged, very old version (for FreeBSD 6)
- - skype20: last version with OSS support, that used to live in net/skype; the
- DISTFILE is gone from the vendor but if you happen to have it, it would be a
- way of having sound w/o needing to upgrade your base OS
- - [RECOMMENDED] skype: currently at 2.1.0.81 and the best supported
- - skype-devel: currently at 2.2.0.25, sounds is OK, video doesn't work
-
- To run either skype or skype-devel with fully working sound you need:
- - to run fc10 (most probably, please report what you can do with fc4):
- (OVERRIDE_LINUX_BASE_PORT=f10,OVERRIDE_LINUX_NONBASE_PORTS=f10
- in /etc/make.conf for systems that doesn't have it as default)
- - In order for Skype to work OK, you need your kernel and modules to be:
- - post 2011-05-03 in on HEAD
- - post 2011-05-08 in on 7,8-STABLE
- The port tries to catch if your system version is too old, but there's a
- ~3months window where because of a lack of OSVERSION bump, this is not
- possible. So please check; and PLEASE READ THE PKGMESSAGE for setup details.
- For how to update your kernel/world, see:
- http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/kernelconfig.html
-
- IF YOUR OSVERSION IS NOT NEW ENOUGH, SOUND (ESPECIALLY MIC) WON'T WORK.
-
- If you run into problems, at very least we need to know the output of:
- $ uname -a; sysctl compat.linux | head -2; \
- grep OVERRIDE_LINUX_ /etc/make.conf; \
- cat /compat/linux/etc/alsa/pcm/pcm-oss.conf
- the skype version you are using and hardware details (eg. webcam, if related)
- I most probably will ignore any mail not containing this info since without
- it it's impossible to help.
- Please test your sound /video setup outside skype before blaming skype /
- mailing me.
-
-20110516:
- AFFECTS: users of audio/musicpd
- AUTHOR: Chris Rees <utisoft@gmail.com>
-
- Musicpd now installs the binary for the server as bin/musicpd, rather than
- mpd, to remove a conflict with net/mpich2; before upgrade you should run:
-
- # /usr/local/etc/rc.d/musicpd stop
-
- Likewise, mpd.conf has been renamed musicpd.conf-- if you want to keep it
- as mpd.conf then place MPDCONF="mpd.conf" into /etc/make.conf, otherwise
- after upgrade run:
-
- # mv /usr/local/etc/mpd.conf /usr/local/etc/musicpd.conf
-
-20110514:
- AFFECTS: users of sysutils/gksu, sysutils/libgksu, sysutils/libgksuui
- AUTHOR: bsam@FreeBSD.org
-
- sysutils/gksu has been updated to 2.0.2. sysutils/libgksuui has been
- deprecated since it has become a part of sysutils/libgksu.
-
- Before upgrading remove sysutils/libgksuui.
-
-20110511:
- AFFECTS: users of editors/emacs
- AUTHOR: ashish@FreeBSD.org
-
- Due to a bug when upgrading from 23.2 or later versions, everything
- installed by other ports in "${PREFIX}/share/emacs" gets removed.
-
- Before upgrading:
-
- * Please backup custom configurations in "${PREFIX}/share/emacs".
- * After upgrading reinstall any ports that may have had files in the
- "${PREFIX}/share/emacs" directory.
-
-20110509:
- AFFECTS: users of lang/ghc and */hs-*
- AUTHOR: ashish@FreeBSD.org
-
- GHC has been updated to version 7.0.3 and other Haskell ports are also
- updated to their Haskell Platform versions or latest versions.
-
- To update all affected ports:
-
- # portmaster -r lang/ghc
- or
- # portupgrade -r lang/ghc
-
-20110506:
- AFFECTS: users of lang/perl*
- AUTHOR: skv@FreeBSD.org
-
- Default version of Perl was bumped to 5.12.
-
- If you already have lang/perl5.10 or lang/perl5.8 installed, and want to
- switch to lang/perl5.12 please follow instructions in the entry 20100715
- in this file.
-
-20110503:
- AFFECTS: users of www/codeigniter and www/codeigniter-devel
- AUTHOR: glarkin@FreeBSD.org
-
- www/codeigniter has been renamed to www/codeigniter17 to track the
- legacy 1.7.* branch of Codeigniter development. www/codeigniter-devel
- has been renamed to www/codeigniter to track the recommended 2.0.*
- branch of Codeigniter development.
-
- If you have Codeigniter 1.7.x installed and would like to continue using
- it, please run one of the following commands to update its origin:
-
- # portmaster -o www/codeigniter17 www/codeigniter
- or
- # portupgrade -o www/codeigniter17 www/codeigniter
-
- If you have Codeigniter 2.0.x installed, please run one of the following
- commands to update its origin:
-
- # portmaster -o www/codeigniter www/codeigniter-devel
- or
- # portupgrade -o www/codeigniter www/codeigniter-devel
-
-20110427:
- AFFECTS: users of mail/ezmlm-idx
- AUTHOR: glarkin@FreeBSD.org
-
- 1) Please consult the instructions for upgrading to version 7.1.1 from
- the earlier 0.444 version in the ports tree:
-
- Online: https://github.com/bruceg/ezmlm-idx/blob/master/UPGRADE
- Local: /usr/local/share/doc/ezmlm-idx/UPGRADE
-
- 2) SQLite3 has been added as a supported database plugin. Note that the
- MySQL, PgSQL and SQLite options are mutually exclusive, and the first
- selected option takes precedence if multiple options are selected.
-
-20110421:
- AFFECTS: users of multimedia/webcamd
- AUTHOR: kwm@FreeBSD.org
-
- Webcamd now creates device nodes with 0660 permission and webcamd:webcamd
- ownership. To get access to the webcamd devices just add yourself to the
- webcamd group.
-
-20110409:
- AFFECTS: users of japanese/asterisk-sounds
- AUTHOR: tota@FreeBSD.org
-
- The japanese/asterisk-sounds has been updated to 1.8.
- If you want to stay with ja-asterisk14-sounds, please run:
-
- # portmaster -o japanese/asterisk14-sounds japanese/asterisk-sounds
- or
- # portupgrade -o japanese/asterisk14-sounds japanese/asterisk-sounds
-
- See also 20101128 net/asterisk entry.
-
-20110406:
- AFFECTS: users of lang/ocaml and related libraries/applications
- AUTHOR: stas@FreeBSD.org
-
- Ocaml compiler and libraries suite has been updated to 3.12.
- There appears to be an ABI incompatibility with .cmi files
- generated by previous compiler versions. Though these should
- only affect the linking process, if some application you're
- using start to misbehave after the lang/ocaml updated you're
- advised to rebuild this applications using the new ocaml version.
-
-20110402:
- AFFECTS: users of net-mgmt/xymon-client and net-mgmt/xymon-server
- AUTHOR: dinoex@FreeBSD.org
-
- Loginname, path, scripts and config files have been renamed in 4.3.0
- Steps to update:
- 1. Stop and deinstall the old version.
- 2. Copy the remaining config files to the new location.
- 3. Read the instructions
- 4. merge your old config with the upgrade430.sh script
- 5. fix the hobbit_*_enable lines in /etc/rc.conf
-
- # /usr/local/etc/rc.d/hobbit-server stop
- # /usr/local/etc/rc.d/hobbit-client stop
- # pkg_delete /var/db/pkg/xymon-*
- # pkg_add xymon-client-4.3.0.tbz
- # pkg_add xymon-server-4.3.0.tbz
- # cp /usr/local/www/hobbit/server/etc/* /usr/local/www/xymon/server/etc/
- # less /usr/local/www/xymon/server/www/help/upgrade-to-430.txt
- # /usr/local/www/xymon/server/bin/bbcmd /usr/local/www/xymon/server/bin/upgrade430.sh
- # sed -i '' -e 's|hobbit|xymon' /etc/rc.conf
- # /usr/local/etc/rc.d/xymon-client start
- # /usr/local/etc/rc.d/xymon-server start
-
-20110328:
- AFFECTS: users of net/openldap24-client
- AUTHOR: delphij@FreeBSD.org
-
- OpenLDAP has been upgraded to 2.4.25. In this version, certain library
- routines were moved from liblutil to libldap. If you previously built
- the library with "FETCH" support, this would cause libldap to depend on
- FreeBSD's libfetch.so library.
-
- As of 20110402, a local change have been introduced so OpenLDAP libraries
- link against libfetch.so when FETCH is enabled. Normally, no further user
- interaction would be required.
-
- For new installations, the FETCH option have been turned off by default.
-
-20110324:
- AFFECTS: users of KDE SC 4
- AUTHOR: kde@FreeBSD.org
-
- KDE SC ports have been updated to 4.6.1. As usual a number of files were
- moved between packages, manual intervention into update procedure is
- required:
-
- # pkg_delete -f kdehier4\* kdebase-runtime-4\* kdebase-workspace-4\*
- # pkg_delete -f kdeedu-4\* kdeutils-4\*
- # portmaster -a
-
-20110322:
- AFFECTS: users of www/firefox
- AUTHOR: gecko@FreeBSD.org
-
- The www/firefox port has been updated to 4.0. If you want to stay with
- Firefox 3.6 please run:
-
- # portupgrade -o www/firefox36 www/firefox
- # portupgrade -o www/firefox36-i18n www/firefox-i18n (if installed)
- or
- # portmaster -o www/firefox36 www/firefox
- # portmaster -o www/firefox36-i18n www/firefox-i18n (if installed)
-
- Do not select the OPTIMIZED_CFLAGS option on a system with less then
- 2 GB of RAM otherwise you will run out of memory during the build.
-
- Please make sure all your addons are compatible with Firefox 4.0 and
- backup your ~/.mozilla directory prior to the first launch of Firefox
- 4.0.
-
- The startup script has been renamed from firefox3 to firefox.
-
-20110319:
- AFFECTS: users of databases/mysql55-client
- AUTHOR: ale@FreeBSD.org
-
- The shared library version of the client library was increased to reflect
- ABI changes, and avoid compatibility problems with the client library
- in MySQL 5.1, so client programs that use the 5.5 client library should
- be recompiled against the 5.5.10 client library.
- This can be achieved with:
-
- # portmaster -r mysql-client-5.5
- or
- # portupgrade -fr mysql-client-5.5
-
-20110318:
- AFFECTS: users of www/node and www/node-devel
- AUTHOR: araujo@FreeBSD.org
-
- The port www/node was merged with www/node-devel since there is no longer a
- development version. Also www/node has not followed the stable upstream
- prior to this update.
-
- To keep www/node updated in your applications, from now on you must use
- www/node instead of www/node-devel. If you have been using the www/node-devel,
- you must run one of the following commands to upgrade:
-
- # portmaster -o www/node www/node-devel
- or
- # portupgrade -o www/node www/node-devel
-
-20110317:
- AFFECTS: users of www/uzbl
- AUTHOR: Klaus Aehlig <aehlig@linta.de>
-
- The port has been updated to version as of 2011/02/15. This introduces
- the following incompatabilities.
-
- - $UZBL_FIFO, $UZBL_TITLE are available to scripts as environment variables,
- but not as command-line arguments.
- - environment variables are no longer expanded by the config parser
- - download handling has changed
- - cookie daemons are no longer supported
-
- Users are advised to change their personal configuration files/scripts accordingly.
-
-20110316:
- AFFECTS: users of sysutils/duplicity
- AUTHOR: peter.schuller@infidyne.com
-
- sysutils/duplicity has been upgraded to 0.6.11. The old version
- (0.5.20) is retained as sysutils/duplicity05. Duplicity 0.6 should
- be generally compatible, but pay special attention to the new meaning
- of the --archive-dir command. In particular, the archive dir is now
- mandatory and defaults to ~/.cache/duplicity. You may have to
- --exclude accordingly. In addition, it is recommended you consult
- the CHANGELOG, specifically the "New in v0.6.00 (2009/06/08)" section
- which details the checkpoint/restore feature (enabled by default) and
- its implications.
-
-20110313:
- AFFECTS: users of astro/boinc-setiathome-enhanced
- AUTHOR: rene@FreeBSD.org
-
- The setiathome client has been updated to version 6.12. Before you
- update, finish and report your current workunits to avoid losing them.
-
-20110304:
- AFFECTS: users of lang/python* and py-*
- AUTHOR: miwi@FreeBSD.org
-
- The default version of Python has been changed from 2.6.x to 2.7.x.
- If you have 2.6.x installed, perform an upgrade of lang/python26 to
- lang/python27 with one of the following commands:
-
- If using portupgrade:
- # portupgrade -o lang/python27 lang/python26
-
- If using portmaster:
- # portmaster -o lang/python27 lang/python26
-
- If you want to retain 2.6.x as default Python version, set the
- PYTHON_DEFAULT_VERSION variable to 'python2.6' (without quotes) in
- /etc/make.conf, then go to lang/python and perform the following
- command:
-
- # portupgrade -R python
-
- Once the installed Python has been updated to 2.7, by using the
- method above, it is required to run the upgrade-site-packages target in
- lang/python to assure that site-packages are made available to the new
- Python version.
-
- If using portupgrade:
- # cd /usr/ports/lang/python && make upgrade-site-packages
-
- If using portmaster:
- # cd /usr/ports/lang/python && make upgrade-site-packages -DUSE_PORTMASTER
-
- The portmaster case can take quite some time to complete due to the lack of
- cached information that the portupgrade suite uses (specifically pkg_which).
- This is not the fault of portmaster.
-
-20110301:
- AFFECTS: users of databases/jasperserver
- AUTHOR: jhelfman@experts-exchange.com
-
- (taken from release notes of 4.0 from vendor)
- If you are upgrading from an older JasperServer version such as 3.5 then
- you must first upgrade to JasperServer 3.7 before upgrading to 4.0.
- Upgrading directly from JasperServer 3.5 to 4.0 is not a "certified"
- (i.e. fully QA tested) procedure.
-
- The steps to carry out this operation are fully documented in the
- JasperReports Server Installation Guide for the 3.7 release. You will
- need to download the JasperServer 3.7 release package to get the relevant
- files and documentation. To download the JasperServer 3.7 WAR file
- distribution zip package, go to the JasperForge.org website and to the
- JasperServer project.
-
- http://jasperforge.org/projects/jasperserver
-
-20110228:
- AFFECTS: users of devel/ccache
- AUTHOR: Emanuel Haupt <ehaupt@FreeBSD.org>
-
- ccache now allows the use of non-default compilers such as clang. This
- requires adjustments of the ccache make glue.
-
- Please (re)read the following document after updating ccache to
- ccache-3.1.4_1:
-
- /usr/local/share/doc/ccache/ccache-howto-freebsd.txt
-
-20110227:
- AFFECTS: users of net/unison and net/unison-devel
- AUTHOR: mandree@FreeBSD.org
-
- Unison has been upgraded to version 2.40, which uses a different wire
- protocol than 2.32 did. In order to support synchronization with
- other computers where Unison is still at version 2.32, a new port
- net/unison232 has been created. It provides unison232 and if that is
- GTK2-enabled, also unison232-text. This unison232 port can be
- installed in parallel with the existing net/unison port.
-
-20110224:
- AFFECTS: users of x11-drivers/xf86-video-ati
- AUTHOR: miwi@FreeBSD.org
-
- X.Org has been updated to 7.5.1. For all ATI users the driver
- was updated to 6.14.0 but the old one is still available in
- x11-drivers/xf86-video-ati613. See radeon(5) for options
- available.
-
-20110224:
- AFFECTS: users of net/openldap24-{client,server}
- AUTHOR: delphij@FreeBSD.org
-
- OpenLDAP has been upgraded to 2.4.24, which requires a shared library
- version bump. Therefore, you need to reinstall all ports that depend on
- it. Please do something like:
-
- # portupgrade -fr net/openldap24-client
- or
- # portmaster -r net/openldap24-client
-
-20110224:
- AFFECTS: Nobody
- AUTHOR: wxs@FreeBSD.org
-
- FreeBSD 8.2 and 7.4 released.
-
-20110209:
- AFFECTS: users of www/testlink
- AUTHOR: tota@FreeBSD.org
-
- Testlink 1.9.1 was released. Before updating, you should read carefully
- the included README file because this release requires a manual update
- of the database scheme.
-
-20110125:
- AFFECTS: users of lang/perl5.12
- AUTHOR: skv@FreeBSD.org
-
- lang/perl5.12 has been updated to 5.12.3. You should update everything
- that depends on perl. The easiest way to do that is to use
- "perl-after-upgrade" script supplied with lang/perl5.12.
- Please see its manual page for details.
-
- If you want to switch to lang/perl5.12 from lang/perl5.{8,10} please
- follow instructions in the entry 20100715 in this file.
-
-20110124:
- AFFECTS: users of mail/postfix
- AUTHOR: sahil@FreeBSD.org
-
- Postfix 2.8 introduces minor incompatibilities with previous versions.
- Alias expansion, dns lookups, TLS support, milters and other features
- are affected. To avoid surprises, carefully review the RELEASE_NOTES.
-
- If you upgrade from Postfix 2.6 or earlier, you must execute "postfix
- stop" and "postfix start" before you can use the postscreen(8) daemon.
- This is needed because the Postfix 2.6 "pass" master service type did
- not work reliably on some systems. If you upgrade from Postfix 2.7, or
- from Postfix 2.8 before July 25, 2010, you must "postfix reload" (or
- "postfix stop" followed by "postfix start"). This is needed because
- the queue manager to delivery agent protocol has changed.
-
- Also note that the optional SPF and VDA patches have not been updated
- for Postfix 2.8; as a result, they are currently disabled.
-
-20110111:
- AFFECTS: users of www/redmine
- AUTHOR: decke@FreeBSD.org
-
- If you use 3rd party plugins that are incompatible with i18n >= 0.5.0
- (eg. variables in yml files as {{variable}}) then you need to
- install an older i18n version manually.
-
- # gem install -v=0.4.2 i18n
-
- Then upgrade the database as usual:
-
- # rake db:migrate RAILS_ENV=production
-
-20110107:
- AFFECTS: users of mail/exim
- AUTHOR: rea@FreeBSD.org
-
- [POSSIBLE CONFIG BREAKAGE] The default value for system_filter_user
- is now the Exim run-time user, instead of root.
-
- [POSSIBLE CONFIG BREAKAGE] ALT_CONFIG_ROOT_ONLY is no longer
- optional and is forced on. This is mitigated by the new build
- option TRUSTED_CONFIG_LIST which defines a list of configuration
- files which are trusted; one per line. If a config file is owned
- by root and matches a pathname in the list, then it may be invoked
- by the Exim build-time user without Exim relinquishing root
- privileges.
-
- [POSSIBLE CONFIG BREAKAGE] The Exim user is no longer automatically
- trusted to supply -D<Macro[=Value]> overrides on the command-line.
- Going forward, we recommend using TRUSTED_CONFIG_LIST with shim
- configs that include the main config. As a transition mechanism,
- we are temporarily providing a work-around: the new build option
- WHITELIST_D_MACROS provides a colon-separated list of macro names
- which may be overriden by the Exim run-time user. The values of
- these macros are constrained to the regex ^[A-Za-z0-9_/.-]*$
- (which explicitly does allow for empty values).
-
- Upgrading users are encouraged to fully study
- ftp://exim.inode.at/exim/ChangeLogs/NewStuff-4.73
- and
- ftp://exim.inode.at/exim/ChangeLogs/ChangeLog-4.73
-
-20110103:
- AFFECTS: users of textproc/libwpd and graphics/libwpg
- AUTHOR: fluffy@FreeBSD.org
-
- LibWPD and LibWPG is now using new API, partially incompatible with
- previous versions.
- For correct upgrade procedure please upgrade LibWPD and LibWPG first
- as described, than follow usual upgrade procedure
-
- # portmaster -o textproc/libwpd08 libwpd
- # portmaster -o graphics/libwpg01 libwpg
-
- substitute 'portupgrade' for 'portmaster' accordingly if that's your
- your upgrade tool of choice.
-
-20101230:
- AFFECTS: users of databases/postgresql??-(server|client)
- AUTHOR: ohauer@FreeBSD.org
-
- PostgreSQL version 8.4 is now the default. To upgrade from a version
- lower than 8.4, follow the instructions on the PostgreSQL.org website.
- http://www.postgresql.org/docs/8.4/interactive/install-upgrading.html
-
-20101230:
- AFFECTS: users of net-mgmt/pnp
- AUTHOR: rea@FreeBSD.org
-
- Starting from 0.6.10_1 config.php is no longer preserved across
- upgrades; PNP way is to put all modifications into config_local.php.
-
- Existing config.php will be saved as config.php.orig and you should
- review your deviations from defaults and place them into
- config_local.php.
-
-20101227:
- AFFECTS: users of databases/mysql55-server
- AUTHOR: ale@FreeBSD.org
-
- MySQL 5.5 has been updated to 5.5.8 GA release. Since layout is
- changed you should remove mysql55-{client/server/scripts} ports
- before upgrading. The build system is changed too, so expect
- failures.
-
-20101227:
- AFFECTS: users of security/opensc
- AUTHOR: ale@FreeBSD.org
-
- opensc has been updated to 0.12.0 release. Only one backend can be
- choosen at compile-time: PC/SC is now the default one.
- opensc doesn't export anymore its internal library, PKCS#11 is the
- recommended interface.
-
-20101220:
- AFFECTS: users of net-mgmt/flowd
- AUTHOR: ohauer@FreeBSD.org
-
- flowd use now a fix UID/GID (id 542) instead the next free UID.
- Before updating the port use the command "pw userdel _flowd"
-
-20101216:
- AFFECTS: users of security/libksba
- AUTHOR: glarkin@FreeBSD.org
-
- libksba has been updated to 1.1.0, and the shared library version has
- increased from .17 to .18.
-
- Directly- and indirectly-dependent ports have had their PORTREVISION
- bumped to facilitate rebuilding. Please rebuild the dependent ports
- with your preferred upgrading tool:
-
- # portupgrade -rf security/libksba
- -or-
- # portmaster -w -r security/libksba
-
- If there are still ports on your system that require ksba.so.17 (either
- in ${LOCALBASE}/lib/compat/pkg, or non-existent), _please_ file a PR so
- that a correct direct dependency can be added.
-
- Once you are satisfied that no ports still depend on the old shared
- library version (libksba.so.17), you can safely delete it from the
- ${LOCALBASE}/lib/compat/pkg directory if it is present there.
-
-20101216:
- AFFECTS: users of databases/akonadi
- AUTHOR: avilla@FreeBSD.org
-
- With SQLite 3 installed, Akonadi used to build its plugin and
- install it in a wrong place, without it being listed in plist. To
- remove the orphaned file, run the following commands PRIOR TO the
- Akonadi upgrade:
-
- # cd /usr/ports/databases/akonadi
- # rm `make -V KDE4_PREFIX`/`make -V QT_PLUGINDIR_REL`/sqldrivers/libqsqlite3.so
- # rmdir `make -V KDE4_PREFIX`/`make -V QT_PLUGINDIR_REL`/sqldrivers \
- `make -V KDE4_PREFIX`/`make -V QT_PLUGINDIR_REL` \
- `make -V KDE4_PREFIX`/`make -V QT_LIBDIR_REL`
-
-20101214:
- AFFECTS: users of devel/icu
- AUTHOR: bapt@FreeBSD.org
-
- icu has been updated to version 4.6. Please rebuild all ports that depends
- on it.
-
- If you use portmaster:
- # portmaster -r icu
-
- If you use portupgrade:
- # portupgrade -fr devel/icu
-
- Note that devel/icu4 is now deprecated consider replacing it by devel/icu
- # portmaster -o devel/icu devel/icu4
- or
- # env DISABLE_CONFLICTS=1 portupgrade -o devel/icu -f icu-4\*
-
-20101211:
- AFFECTS: users of devel/bugzilla, japanese/bugzilla and russian/bugzilla-ru
- AUTHOR: tota@FreeBSD.org
-
- Bugzilla and its language packs are installed to
- WWWDIR (defaults to PREFIX/www/bugzilla).
- BUGZILLADIR (that defaulted to PREFIX/www/data/bugzilla) is deprecated.
-
-20101211:
- AFFECTS: users of databases/mysql-proxy
- AUTHOR: Florian Smeets <flo@smeets.im>
-
- The parameters --admin-username and --admin-password are mandatory now.
- Add something like the following to rc.conf
-
- mysql_proxy_args="--admin-username admin --admin-password somepassword"
-
-20101210:
- AFFECTS: users of multimedia/avidemux2
- AUTHOR: nox@FreeBSD.org
-
- The port has been updated to 2.5.4 which now installs plugins separately
- and I had to make a slave port for them, multimedia/avidemux2-plugins.
- So you'll now have to install that port too for the app to become useful.
-
-20101208:
- AFFECTS: autotools
- AUTHOR: autotools@FreeBSD.org
-
- Another stage in the autotools cleanup that reduces tree churn whilst
- updating components, a number of ports have now moved to non-versioned
- locations since there is now only the concept of legacy and current
- versions.
-
- # portmaster -o devel/autoconf devel/autoconf268
- # portmaster -o devel/automake devel/automake111
- # portmaster -o devel/libtool devel/libtool22
- # portmaster -o devel/libltdl devel/libltdl22
-
- substitute 'portupgrade' for 'portmaster' accordingly if that's your
- your upgrade tool of choice.
-
-20101205:
- AFFECTS: users of www/py-flexget
- AUTHOR: lioux@FreeBSD.org
-
- Database schema changes. Please run:
-
- $ sqlite3 db-config.sqlite "ALTER TABLE thetvdb_favorites ADD series_id VARCHAR;"
- $ sqlite3 db-config.sqlite "ALTER TABLE imdb_movies ADD updated DateTime;"
- $ sqlite3 db-config.sqlite "ALTER TABLE imdb_movies ADD mpaa_rating VARCHAR;"
-
- inside flexget configuration directory (~/.flexget) for each
- sqlite database you might have.
-
- Replace "db-config.sqlite" with the appropriate name for your
- sqlite database file.
-
-20101204:
- AFFECTS: users of audio/libmpcdec
- AUTHOR: lioux@FreeBSD.org
-
- audio/libmpcdec has been removed in favor of audio/musepack; which
- has a higher shared library version. You will have to rebuild all
- ports that depend on audio/libmpcdec. Do this:
-
- Portmaster users:
- # portmaster -o audio/musepack audio/libmpcdec
- # portmaster -r musepack-
-
- Portupgrade users:
- # env DISABLE_CONFLICTS=1 portupgrade -o audio/musepack -f libmpcdec-\*
- # pkgdb -Ff
- # portupgrade -rf musepack-\*
-
-20101204:
- AFFECTS: autotools
- AUTHOR: autotools@FreeBSD.org
-
- The next stage in the ongoing cleanup of autotools-using ports is
- a refactoring of bsd.autotools.mk so that version numbers are no longer
- needed within the USE_AUTOTOOLS stanza. There is either
- autoconf213/autoconf or automake14/automake (for the legacy versions,
- and the currently available versions). This will considerably reduce
- the amount of tree-wide patching in future on an update.
-
- IMPORTANT: if you have either devel/autoconf-wrapper or
- devel/automake-wrapper installed on your system (and you most likely do)
- PLEASE update these ports to their new versions before updating anything
- else -- Bad Things[tm] are likely to happen otherwise.
-
-20101202:
- AFFECTS: users of multimedia/gstreamer-plugins
- AUTHOR: multimedia@FreeBSD.org
-
- If during the upgrade of gstreamer-plugins the following error happens:
- GstAudio-0.10.gir: Incompatible version 1.0 (supported: 1.2)
- Use the following command to upgrade:
-
- cd ports/multimedia/gstreamer-plugins && make deinstall clean install
-
-20101202:
- AFFECTS: users of www/wordpress
- AUTHOR: sunpoet@FreeBSD.org
-
- WordPress is now installed to WWWDIR (defaults to PREFIX/wordpress)
- instead of WORDPRESS (defaults to PREFIX/www/data/wordpress).
-
-20101129:
- AFFECTS: users of sysutils/radmind
- AUTHOR: ohauer@FreeBSD.org
-
- The radmind user and group is created automatically during installation.
- The owner of $RADMIND_BASE_DIR changes from root to radmind.
-
-20101128:
- AFFECTS: users of net/asterisk, net/asterisk-addons
- AUTHOR: Florian Smeets <flo@smeets.im>
-
- If you want to upgrade to 1.8.0 first remove asterisk-addons by running
-
- # pkg_delete -f asterisk-addons\*
-
- after that you can run one of the following
-
- # portmaster asterisk
- or
- # portupgrade asterisk
-
- You need to update your config files as the step from 1.4.x to 1.8.x is
- quite big. First you need to look at what changed between 1.4 and 1.6
-
- http://svnview.digium.com/svn/asterisk/branches/1.8/UPGRADE-1.6.txt
-
- After that you also need to take into account what chagne between
- 1.6 and 1.8
-
- http://svnview.digium.com/svn/asterisk/branches/1.8/UPGRADE.txt
-
- If you want to stay with asterisk 1.4.x please run
-
- # portmaster -o net/asterisk14 net/asterisk
- # portmaster -o net/asterisk14-addons net/asterisk-addons
- or
- # portupgrade -o net/asterisk14 net/asterisk
- # portupgrade -o net/asterisk14-addons net/asterisk-addons
-
-20101127:
- AFFECTS: users of mail/postfix, mail/postfix2[56]
- AUTHOR: sahil@FreeBSD.org
-
- As of Postfix 2.7.2, 2.6.8, 2.5.11:
-
- Postfix no longer automatically appends the system default CA
- (certificate authority) certificates, when it reads the CA
- certificates specified with {smtp, lmtp, smtpd}_tls_CAfile or
- with {smtp, lmtp, smtpd}_tls_CApath. This prevents third-party
- certificates from getting mail relay permission with the
- permit_tls_all_clientcerts feature. Unfortunately, this change
- may cause compatibility problems with configurations that rely
- on certificate verification for other purposes. To get the old
- behavior, specify "tls_append_default_CA = yes".
-
-20101124:
- AFFECTS: users of www/py-flexget
- AUTHOR: lioux@FreeBSD.org
-
- metainfo_series is no longer a builtin. This should only affect
- you if you aren't using one of the series plugins (series,
- all_series, thetvdb_favorites, or series_premiere.) If you need
- to enable metainfo_series manually for a feed it can be done like
- so:
-
- metainfo_series: yes
-
-20101120:
- AFFECTS: users of x11-toolkits/gtk20 and x11-toolkits/gtkmm24
- AUTHOR: FreeBSD GNOME Team <gnome@FreeBSD.org>
-
- In the GNOME 2.32 release. gdk-pixbuf2 has been split off from gtk20,
- and atkmm has been split off from gtkmm24. To upgrade please use the
- following instructions:
-
- Portmaster users:
-
- # pkg_delete -f gtkmm-2.20\* gtk-2.20\*
- # portmaster -a
-
- Portupgrade users:
-
- # pkgdb -fF
- # pkg_deinstall -fO gtkmm-2.20\* gtk-2.20\*
- # portupgrade -aOW
-
-20101118:
- AFFECTS: users of editors/emacs-devel
- AUTHOR: Ashish SHUKLA <ashish@FreeBSD.org>
-
- Due to a bug when upgrading from 24.0.50.101606, everything
- installed by other ports in "${PREFIX}/share/emacs" gets removed.
-
- Before upgrading:
-
- * Please backup custom configurations in "${PREFIX}/share/emacs".
- * After upgrading reinstall any ports that may have had files in the
- "${PREFIX}/share/emacs" directory.
-
- Apologies for this inconvenience.
-
-20101117:
- AFFECTS: users of net-p2p/transmission-cli and net-p2p/transmission-gtk
- AUTHOR: Mezz <mezz@FreeBSD.org>
-
- Transmission has been updated to 2.12. The following name of binaries and
- manpages have been renamed:
-
- transmissioncli -> transmission-cli
- transmission -> transmission-gtk
-
-20101117:
- AFFECTS: users of devel/ccache
- AUTHOR: Emanuel Haupt <ehaupt@FreeBSD.org>
-
- Updated instructions on how to workaround a buildworld failure have been
- committed. Please (re)read the following document after updating ccache to
- 3.1.1_1:
-
- /usr/local/share/doc/ccache/ccache-howto-freebsd.txt
-
-20101110:
- AFFECTS: users of databases/mysql55-server
- AUTHOR: Alex Dupre <ale@FreeBSD.org>
-
- If you are upgrading from a previous MySQL release, the server will exit
- during startup after finding that the proxies_priv table is missing.
- To create the table, start the server with the --skip-grant-tables
- option to cause it to skip the normal grant table checks, then run
- mysql_upgrade. Then stop the server and restart it normally.
- You can do this by temporarly setting the following line in rc.conf:
-
- mysql_args="--skip-grant-tables --skip-networking"
-
-20101108:
- AFFECTS: users of databases/py-bsddb3
- AUTHOR: wen@FreeBSD.org
-
- py-bsddb3 update to 5.1.0. This release drops support for Berkeley
- DB 4.1, and adds support for Berkeley DB version 5.1, brand new. If
- you need Berkeley DB 4.1 support, keep using pybsddb 5.0.0. If you
- want support for Berkeley DB 5.1, remember to install the BDB library
- before installing these bindings.
-
-20101030:
- AFFECTS: users of www/xshttpd-devel
- AUTHOR: johans@FreeBSD.org
-
- The default XS-httpd configuration file locations have changed:
- The main configuration file is now $PREFIX/etc/xshttpd/httpd.conf
- and other configuration file are stored in that same directory.
- Existing configurations should be moved over manually.
- Log files now appear in /var/log/xshttpd/ by default.
-
-20101029:
- AFFECTS: users of ports-mgmt/portmaster
- AUTHOR: Doug Barton <dougb@FreeBSD.org>
-
- The changes to bsd.port.mk in 1.652 require all portmaster users to
- upgrade to version 3.1 or later. The best method to do this will be
- to use the port, rather than portmaster itself:
-
- # pkg_delete -f portmaster\*
- # cd /usr/ports/ports-mgmt/portmaster && make clean && make install clean
-
-20101026:
- AFFECTS: users of net/samba35
- AUTHOR: Timur Bakeyev <timur@FreeBSD.org>
-
- This is the latest stable release of the Samba3 distribution. It has
- been extended with the experimental support of the NFS4-like ACLs on
- ZFS partitions, thanks to the sysutils/libsunacl library by Edward
- Tomasz Napierala(trasz). This support haven't been tested thoroughly,
- so try it on your own risk.
-
- This port reverted back to the pre- net/samba34 layout of the
- directories and now they are again $PREFIX/etc/samba, /var/run/samba,
- /var/log/samba, /var/db/samba and /var/spool/samba respectively.
-
- In case, you are upgrading from net/samba34, please rename
- corresponding samba34/ subdirectories into samba/ ones. Upgrades from
- older versions of Samba and fresh installations should be seamless.
-
-20101015:
- AFFECTS: users of devel/llvm-devel who use clang
- AUTHOR: Brooks Davis <brooks@FreeBSD.org>
-
- The clang portion of devel/llvm-devel has been split out and now
- resides in lang/clang-devel. If you have devel/llvm-devel installed
- in order to use clang, you will need to install the clang-devel port
- when upgrading.
-
-20101003:
- AFFECTS: users of www/typo3
- AUTHOR: Helmut Schneider <jumper99@gmx.de>
-
- www/typo3 has been repocopied to www/typo343. If you need to continue with
- the old stable version please run
-
- # portmaster -o www/typo343 www/typo3
- or
- # portupgrade -o www/typo343 www/typo3
-
- Please remember to change the path of your config files too.
-
-20101003:
- AFFECTS: users of net-mgmt/kismet
- AUTHOR: bf@FreeBSD.org
-
- This update includes major changes in how Kismet works and is configured.
- Clients, servers, drones, and configuration files must be updated to work
- with the new version. Map support has not yet been added.
-
- See the kismet README for details.
-
-20100929:
- AFFECTS: users of sysutils/zfsnap
- AUTHOR: Aldis Berjoza <aldis@bsdroot.lv>
-
- Since timestamp format changed you need to use -o option with -d
- option in order to be able to delete old snapshots. Note however that
- you don't need -o when creating new snapshots, unless you want to keep
- using the old timestamp format.
-
- See http://wiki.bsdroot.lv/zfsnap for more info.
-
-20100927:
- AFFECTS: users of mail/postfix-current
- AUTHOR: ohauer@FreeBSD.org
-
- Incompatibility with snapshot 20100912
- ======================================
- - If your DNSBL queries have a "secret" in the domain name, you must
- now censor this information from the postscreen(8) SMTP replies.
- - The postscreen "continue" action is now called "ignore". The old
- name is still supported but no longer documented.
- - The postscreen_hangup_action parameter was removed. Postscreen
- now always behaves as if "postscreen_hangup_action = drop".
- - The postscreen_cache_retention_time default was increased from
- 1d to 7d, to avoid deleting results from expensive deep SMTP
- protocol tests too quickly.
-
- Incompatibility with snapshot 20100827
- ======================================
- - The Postfix SMTP client no longer appends the local domain when
- looking up a DNS name without ".".
- Specify "smtp_dns_resolver_options = res_defnames" to get the old
- behavior, which may produce unexpected results.
-
-20100924:
- AFFECTS: users of x11/nvidia-driver
- AUTHOR: makc@FreeBSD.org
-
- nvidia-driver does not install vdpau library and headers anymore, they
- are now provided by multimedia/libvdpau port. To avoid conflict, please
- rebuild nvidia-driver port before upgrading your ports and before
- installing multimedia/libvdpau.
-
-20100921:
- AFFECTS: users of p5-Compress-Zlib, p5-IO-Compress-*
- AUTHOR: mm@FreeBSD.org
-
- The p5-Compress-Zlib, p5-IO-Compress-Base, p5-IO-Compress-Zlib and
- p5-IO-Compress-Bzip2 ports have been replaced by p5-IO-Compress.
- Users of Perl 5.10 and higher do not need to install this module
- because it is already included in the standard perl distribution.
-
-20100920:
- AFFECTS: users of security/stunnel
- AUTHOR: roam@FreeBSD.org
-
- In stunnel-4.34, the DH support is no longer configurable by the user,
- but always enabled when OpenSSL supports it instead. This means that
- it will now most probably be enabled on the supported versions of FreeBSD.
- If this leads to problems with old SSL clients, I will look into making
- it configurable at build time again.
-
-20100917:
- AFFECTS: users of sysutils/cdrtools-cjk
- AUTHOR: marius@FreeBSD.org
-
- sysutils/cdrtools-cjk port has been removed, as the required functionality is
- now available in cdrtools 3.0.0 in the standard sysutils/cdrtools port.
-
-20100915:
- AFFECTS: autoconf, automake
- AUTHOR: autotools@FreeBSD.org
-
- autoconf has been updated from 2.62 to 2.67 -- all ports depending on
- autoconf-2.62 have had their PORTREVISIONs update, so a standard
- port updating method will suffice.
-
- USE_GETTEXT has been extended to also accept 'build' and 'run' for
- ports which need devel/gettext as a BUILD- or RUN-time dependency only.
- No port should now be directly depending on devel/gettext in Makefiles.
-
-20100915:
- AFFECTS: users of sysutils/cdrtools-cjk
- AUTHOR: marius@FreeBSD.org
-
- Version 3.00 of sysutils/cdrtools breaks but at the same time also
- obsoletes sysutils/cdrtools-cjk as mkisofs now employs iconv for
- character conversion. Consequently sysutils/cdrtools-cjk is marked
- BROKEN and the use of USE_CDRTOOLS=cjk as well as USE_CDRTOOLS together
- with the WITH_CJK knob left in a broken state until bsd.port.mk is
- updated by portmgr@ accordingly. Once USE_CDRTOOLS is updated to no
- longer refer to sysutils/cdrtools-cjk the latter will be removed.
- Previous users of sysutils/cdrtools-cjk should switch to using
- sysutils/cdrtools instead, which might require not using the WITH_CJK
- knob until said update of bsd.port.mk has happened.
-
-20100915:
- AFFECTS: users of lang/perl5.12
- AUTHOR: skv@FreeBSD.org
-
- lang/perl5.12 has been updated to 5.12.2. You should update everything
- that depends on perl. The easiest way to do that is to use
- "perl-after-upgrade" script supplied with lang/perl5.12.
- Please see its manual page for details.
-
- If you want to switch to lang/perl5.12 from lang/perl5.{8,10} please
- follow instructions in the entry 20100715 in this file.
-
-20100912:
- AFFECTS: ftp/curl
- AUTHOR: roam@FreeBSD.org
-
- With version 7.21.1, the cURL port is built with stricter compiler
- checking by default (the -Werror flag is passed to the C compiler,
- making it treat any warnings as fatal errors). If you experience
- problems building cURL, re-run "make config" in the ftp/curl
- directory and disable the WERROR knob.
-
-20100912:
- AFFECTS: www/tdiary-devel, japanese/tdiary-devel
- AUTHOR: tota@FreeBSD.org
-
- The stable tDiary ports, www/tdiary and japanese/tdiary, have been
- updated to 3.0.0. The development versions of tDiary have been merged
- from www/tdiary-devel to www/tdiary and from japanese/tdiary-devel to
- japanese/tdiary, respectively.
-
- If you have been using the www/tdiary-devel or japanese/tdiary-devel,
- you run one of the following commands to upgrade:
-
- - www/tdiary-devel
- # portmaster -o www/tdiary www/tdiary-devel
- or
- # portupgrade -o www/tdiary www/tdiary-devel
-
- - japanese/tdiary-devel
- # portmaster -o japanese/tdiary japanese/tdiary-devel
- or
- # portupgrade -o japanese/tdiary japanese/tdiary-devel
-
- Before upgrading, please read the following for more details:
-
- http://www.tdiary.org/20100828.html (written in Japanese)
-
-20100907:
- AFFECTS: sysutils/pecl-fileinfo
- AUTHOR: ale@FreeBSD.org
-
- If you are using php 5.3 (lang/php5) and fileinfo extension, you
- should switch to sysutils/php5-fileinfo port:
-
- portmaster -o sysutils/php5-fileinfo sysutils/pecl-fileinfo
-
-20100904:
- AFFECTS: net/netcat
- AUTHOR: pgollucci@FreeBSD.org
-
- Rename nc to netcat to prevent /usr/bin/nc shadowing /usr/local/bin/nc
-
-20100902:
- AFFECTS: users of KDE 4
- AUTHOR: kde@FreeBSD.org
-
- KDE SC ports has been updated to 4.5.1. A number of files were moved
- between packages, manual intervention into update procedure is required:
-
- # pkg_delete -f kdehier4\* kdelibs-4\* kdebase-4\* kdebase-runtime-4\* kdebase-workspace-4\*
- # rm -rf /usr/local/kde4/share/PolicyKit/policy
- # cd /usr/ports/misc/kdehier4 && make install clean
- # portmaster -a
-
-20100901:
- AFFECTS: users of www/rubygem-rails
- AUTHOR: pgollucci@FreeBSD.org
-
- Rails has been updated to 3.0.0. As always, make sure you check the
- changes at http://weblog.rubyonrails.org/.
-
-20100817:
- AFFECTS: users of www/lighttpd
- AUTHOR: mm@FreeBSD.org
-
- The modules mod_geoip and mod_h264_streaming have been moved into slave
- ports: www/lighttpd-mod_geoip and www/lighttpd-mod_h264_streaming
-
-20100818:
- AFFECTS: users of www/lighttpd
- AUTHOR: mm@FreeBSD.org
-
- The default lighttpd configuration file locations have changed.
- The main configuration file is now: $PREFIX/etc/lighttpd/lighttpd.conf
- and includes other configuration files from $PREFIX/etc/lighttpd/
-
- For compatibility with old-style configurations, if the lighttpd_conf
- variable is not set in /etc/rc.conf, $PREFIX/etc/lighttpd.conf takes
- precedence over $PREFIX/etc/lighttpd/lighttpd.conf
-
-20100815:
- AFFECTS: users of databases/redis and databases/redis-devel
- AUTHOR: osa@FreeBSD.org
-
- The redis configuration file, redis.conf, have been changed, some options
- removed in newer versions (>=2.0). In some cases, redis-server with
- older configuration might does not run at startup.
-
- If you run into startup problems, re-edit configuration file.
-
-20100813:
- AFFECTS: www/opera
- AUTHOR: dinoex@FreeBSD.org
-
- If you run opera without gtk or kde4, the browser might crash on shutdown.
- In this case go to about:config and change "Dialog Toolkit" from 0 to 4.
-
-20100811:
- AFFECTS: multimedia/mpeg4ip-libmp4v2
- AUTHOR: makc@FreeBSD.org
-
- multimedia/mpeg4ip-libmp4v2, which is not maintained upstream, has been
- replaced with new port, multimedia/mp4v2. The shared library version
- has been changed with this update, thus all ports that depends on
- mp4v2 library must be rebuilt:
-
- portmaster -o multimedia/mp4v2 multimedia/mpeg4ip-libmp4v2
- portmaster -a
-
-20100731:
- AFFECTS: users of devel/ccache
- AUTHOR: ehaupt@FreeBSD.org
-
- Users upgrading from 2.4 release should clear the old cache directory with:
-
- # ccache --clear
-
-20100730:
- AFFECTS: users of www/neon28 and www/neon29
- AUTHOR: mezz@FreeBSD.org
-
- Makes neon29 our default neon library in the ports tree. The www/neon28
- has been removed and www/neon29's shared library version has been changed.
- You will have to rebuild all ports that depend on www/neon29. Do this:
-
- Portmaster users:
- portmaster -o www/neon29 www/neon28
- portmaster -r neon29-
-
- Portupgrade users:
- env DISABLE_CONFLICTS=1 portupgrade -o www/neon29 -f neon28-\*
- pkgdb -Ff
- portupgrade -rf neon29-\*
-
-20100728:
- AFFECTS: users of textproc/nltk
- AUTHOR: clsung@FreeBSD.org
-
- Nltk has been upgraded to 2.0b8 which depends on devel/py-yaml now.
- You need to deinstall nltk before upgrading, since the previous port
- will delete files installed from py-yaml during its deinstall phase.
-
- Use, for example:
-
- # pkg_delete nltk-2.0b7,1
- # portsnap fetch update
- # cd /usr/ports/textproc/nltk/
- # make install clean
-
-20100727:
- AFFECTS: users of security/libgcrypt
- AUTHOR: wxs@FreeBSD.org
-
- libgcrypt has been upgraded to 1.4.6 which has a shared library version
- bump. You need to reinstall all ports that depend on it. Use something
- like this:
-
- portupgrade -rf libgcrypt
- portmaster -r libgcrypt
-
-20100722:
- AFFECTS: users of net/rabbitmq
- AUTHOR: Phillip <pneumann@gmail.com>
-
- The database schema and the format in which persistent messages are
- stored have both changed since the last release (1.7.2). When
- starting, the RabbitMQ server will detect the existence of an old
- database and will move it to a backup location, before creating a
- fresh, empty database, and will log a warning.
-
-20100715:
- AFFECTS: users of lang/perl*
- AUTHOR: skv@FreeBSD.org
-
- lang/perl5.12 is out. If you want to switch to it from, for example
- lang/perl5.10, that is:
-
- Portupgrade users:
- 0) Fix pkgdb.db (for safety):
- pkgdb -Ff
-
- 1) Reinstall new version of Perl (5.12):
- env DISABLE_CONFLICTS=1 portupgrade -o lang/perl5.12 -f perl-5.10.\*
-
- 2) Reinstall everything that depends on Perl:
- portupgrade -fr perl
-
- Portmaster users:
- portmaster -o lang/perl5.12 lang/perl5.10
-
- Conservative:
- portmaster p5-
-
- Comprehensive (but perhaps overkill):
- portmaster -r perl-
-
- Note: If the "perl-" glob matches more than one port you will need to
- specify the name of the Perl directory in /var/db/pkg explicitly.
-
-20100626:
- AFFECTS: users of japanese/ibus-mozc
- AUTHOR: daichi@FreeBSD.org
-
- The japanese/ibus-mozc port has been updated to version 0.11.383.102,
- and separated into 5 ports to cope with upcoming new port
- japanese/scim-mozc.
-
- o japanese/mozc-server
- o japanese/mozc-tool
- o japanese/mozc-additions
- o japanese/ibus-mozc
- o devel/py-gyp-devel
-
- You cannot upgrade with portupgrade or portmaster. To upgrade, you
- must deinstall japanese/ibus-mozc first and then install the new
- japanese/ibus-mozc.
-
- For example:
-
- # pkg_delete ja-ibus-mozc-0.11.365.102_1
- # portsnap fetch update
- # cd /usr/ports/japanese/ibus-mozc/
- # make install clean
-
-20100617:
- AFFECTS: users of security/{dirmngr|gnupg}
- AUTHOR: dougb@FreeBSD.org
-
- The security/libassuan port has been updated to version 2.0.0, and
- the applications listed above have been updated to use it as of versions
- 1.1.0 and 2.0.15 respectively. If you HAVE NOT updated your libassuan
- port as described in the 20100613 entry, you can simply update all 3
- ports together (libassuan, dirmngr if installed, and gnupg) using your
- normal upgrade path. If you HAVE updated to libassuan-1, then you need
- to do the following before upgrading dirmngr and gnupg.
-
- If you use portupgrade:
-
- portupgrade -f -o security/libassuan security/libassuan-1
-
- If you use portmaster:
-
- portmaster -o security/libassuan libassuan-1
-
- If you use neither:
-
- pkg_delete -f libassuan*
-
- Please note, libassuan version 2.0.0 is now a shared library, so unlike
- the previous version it is now a runtime dependency and cannot be deleted
- after you are done building dirmngr and/or gnupg.
-
-20100613:
- AFFECTS: users of deskutils/kdepim4, and security/{gpa|opensc}
- AUTHOR: dougb@FreeBSD.org
-
- The security/libassuan port has been updated to version 2.0.0, however,
- the applications listed above are not yet compatible with it. Therefore
- security/libassuan-1 has been created until they can be updated, and the
- ports listed above have been updated to depend on it. You must first
- replace your existing libassuan with version 1 in the new location, then
- you can update the ports listed above normally.
-
- If you use portupgrade:
-
- portupgrade -f -o security/libassuan-1 security/libassuan
-
- If you use portmaster:
-
- portmaster -o security/libassuan-1 libassuan
-
- If you use neither:
-
- pkg_delete -f libassuan*
-
-20100609:
- AFFECTS: users of audio/libogg and audio/libao
- AUTHOR: naddy@FreeBSD.org
-
- There are new versions of libogg (1.2.0) and libao (1.0.0) and the
- shared library versions have been bumped (ogg.6 to ogg.7, ao.3 to ao.4).
-
- All ports that have an identifiable direct dependency on these libraries
- have had their PORTREVISIONs bumped. However, some ports that pull in
- the libraries indirectly may continue to look for the old versions. To
- ensure that all are updated, perform this step:
-
- If you use portupgrade:
-
- portupgrade -rf libogg libao
-
- If you use portmaster:
-
- portmaster -r libogg libao
-
-20100605:
- AFFECTS: users of multimedia/gstreamer-plugins-good and
- multimedia/gstreamer-plugins-bad
- AUTHOR: kwm@FreeBSD.org
-
- Certain plugins were moved from the -bad port to the -good port. Please
- follow instructions below before proceeding with normal update steps:
-
- If you use portmaster:
-
- portmaster gstreamer-plugins-bad
-
- If you use portupgrade:
-
- portupgrade -R multimedia/gstreamer-plugins-bad
-
-20100602:
- AFFECTS: users of lang/mono
- AUTHOR: romain@FreeBSD.org
-
- Starting with Mono 2.6, the Moonlight compiler and assemblies are not
- installed by the lang/mono port anymore. They are however provided by
- the multimedia/moonlight port.
-
- If you are doing some Silverlight development, install multimedia/moonlight
- after updating lang/mono.
-
-20100530:
- AFFECTS: users of devel/gettext (i.e.: YOU)
- AUTHOR: ade@FreeBSD.org
-
- Another version of gettext (0.18), and another shared library version
- bump (from intl.8 to intl.9), so:
-
- All ports that have an identifiable known direct dependency on gettext
- have had their PORTREVISIONs bumped. If after upgrading:
-
- # portupgrade -rf gettext
- # portmaster -w -r gettext
-
- The upgrade of devel/gobject-introspection may fail because it is looking
- for libintl.so.8. In this case, do the following:
-
- # cd /usr/ports/devel/gobject-introspection
- # make clean
- # make deinstall
- # make install clean
-
- Then continue your upgrade procedure normally.
-
- If there are still ports on your system that are looking for libintl.so.8
- (either in ${LOCALBASE}/lib/compat/pkg, or non-existent), _please_ file
- a PR so that a correct direct dependency can be added.
-
- Once you are satisfied that no ports still depend on the old versions (such
- as libgettextpo.so.4 and libintl.so.8) you can safely delete them from the
- ${LOCALBASE}/lib/compat/pkg directory if they are present there.
-
-20100524:
- AFFECTS: users of devel/darcs, ports-mgmt/porte, textproc/pandoc,
- x11/xmobar, x11-wm/xmonad, x11-wm/xmonad-contrib
- AUTHOR: pgj@FreeBSD.org
-
- The following ports have been renamed to improve consistency among Haskell
- Cabal ports:
-
- - devel/darcs -> devel/hs-darcs
- - ports-mgmt/porte -> ports-mgmt/hs-porte
- - textproc/pandoc -> textproc/hs-pandoc
- - x11/xmobar -> x11/hs-xmobar
- - x11-wm/xmonad -> x11-wm/hs-xmonad
- - x11-wm/xmonad-contrib -> x11-wm/hs-xmonad-contrib
-
- Please follow these steps below to update Haskell ports that you have
- installed:
-
- 1) Reinstall the renamed Haskell port dependencies (see previous entry).
- Note that this will possibly require that you remove the affected leaf
- (aforementioned) ports as well;
-
- 2) Reinstall the renamed application(s) you use.
-
-20100524:
- AFFECTS: users of hs-* ports
- AUTHOR: pgj@FreeBSD.org
-
- The following Haskell ports have been renamed in order to bring them in
- sync with the naming scheme used at HackageDB. Please follow these steps
- below to update your installation:
-
- 1) Delete the following ports (if you have any of them installed):
-
- - hs-zip-archive-ghc
- - hs-binary-ghc
- - hs-language-c-ghc
- - hs-lazysmallcheck-c-ghc
- - hs-pcre-light-ghc
- - hs-utf8-string-ghc
- - hs-HGL-ghc
- - hs-digest-ghc
- - hs-haxml
- - hs-highlighting-kate-ghc
- - hs-polyparse-ghc
- - hs-x11-ghc
- - hs-x11-xft-ghc
- - hs-opengl-ghc
- - hs-OpenGLRaw-ghc
- - hs-OpenGLURaw-ghc
- - hs-glut-ghc
-
- 2) Rebuild the renamed ports and all ports that depend on them.
-
-20100518:
- AFFECTS: users of devel/pylint
- AUTHOR: mva@FreeBSD.org
-
- The pylint user configuration files have been changed slightly in newer
- versions (>=0.20.0). In some cases, older configurations might crash
- pylint at startup.
-
- If you run into startup problems, make sure you remove the .pylintrc
- configuration settings and the .pylint.d directory from your home
- directory:
-
- $ rm ~/.pylintrc
- $ rm -rf ~/.pylint.d
-
-20100518:
- AFFECTS: users of devel/apr0, devel/apr1, www/apache20, www/apache22
- AUTHOR: pgollucci@FreeBSD.org
-
- devel/apr port has been renamed to devel/apr1.
-
- WITH_APR_FROM_PORTS=yes for www/apache22 has been dissolved and may be
- removed from your configuration files; devel/apr1 is always used now.
-
- Please manually delete apache-2.\* if installed _before_ updating using
- either portmaster or portupgrade:
-
- pkg_delete -f apache-2.\*
-
- Then, if you use portmaster:
-
- portmaster -o devel/apr1 devel/apr
-
- If you use portupgrade:
-
- portupgrade -f -o devel/apr1 devel/apr
-
- Finally, reinstall Apache port if you deleted it earlier and update ports as
- usual (`XX' below is either 20 or 22):
-
- portinstall www/apacheXX
-
-20100512:
- AFFECTS: users of www/apache20
- AUTHOR: pgollucci@FreeBSD.org
-
- The rc.d script has been renamed:
-
- apache2.sh -> apache2
-
- You'll need to update any crons wrappers, etc. for the new paths.
-
-20100511:
- AFFECTS: users of KDE SC 4
- AUTHOR: kde@FreeBSD.org
-
- KDE SC ports have been updated from 4.3.5 to 4.4.3. A number of libraries
- was moved between packages. The recommended update procedure is to delete
- kdelibs-experimental*, kdebase-4*, kdebase-workspace-4*,
- kdebase-runtime-4*, kdepim-4*, kdepim-runtime-4*, and then update ports as
- usual and install desired KDE 4 ports:
-
- # pkg_delete -f kdebase-\*4\* kdepim-\*4\* kdelibs-experimental-\*4\*
- # portmaster -a (or portupgrade -aR)
-
- In order to enabled Nepomuk semantic desktop search you have to install
- databases/virtuoso (you don't need to manually configure or run virtuoso
- server).
-
-20100511:
- AFFECTS: users of textproc/redland RDF engine
- AUTHOR: kde@FreeBSD.org
-
- Redland RDF engine has been split into redland itself and rasqal engine.
- The recommended update procedure is to delete redland, then update ports
- as usual and install desired RDF ports:
-
- # pkg_delete -f redland-\*
- # portmaster raptor (or portupgrade -r raptor)
-
-20100511:
- AFFECTS: users of multimedia/qt4-phonon, multimedia/qt4-phonon-gst,
- multimedia/phonon, and multimedia/phonon-gstreamer
- AUTHOR: kde@FreeBSD.org
-
- WITH_QT_PHONON global knob has been introduced to allow selection between
- multimedia/qt4-phonon* ports (a bit outdated Phonon, which is shipped with
- Qt 4) and multimedia/phonon* ports. Since KDE SC 4.4 now requires fresh
- Phonon, multimedia/phonon* ports are installed by default.
-
- If you don't use KDE, you may set WITH_QT_PHONON=yes in /etc/make.conf
- and continue to use Qt 4 Phonon implementation ports.
-
- If you want to use KDE SC 4.4 (or if you want the latest Phonon), do not
- define WITH_QT_PHONON, delete multimedia/qt4-phonon* ports, and install
- multimedia/phonon*:
-
- If you use portmaster:
-
- portmaster -o multimedia/phonon multimedia/qt4-phonon
- portmaster -o multimedia/phonon-gstreamer multimedia/qt4-phonon-gst
-
- If you use portupgrade:
-
- portupgrade -f -o multimedia/phonon multimedia/qt4-phonon
- portupgrade -f -o multimedia/phonon-gstreamer multimedia/qt4-phonon-gst
-
-20100510:
- AFFECTS: users of security/gnome-keyring
- AUTHOR: kwm@FreeBSD.org
-
- libgnome-keyring was split out of the gnome-keyring package. Perform the
- following before doing your normal upgrade steps:
-
- pkg_delete -f "gnome-keyring-*"
- portmaster security/gnome-keyring
- or
- pkgdb -Ff
- portupgrade -R -x gnome-keyring -x libgnome-keyring gnome-keyring
- pkg_deinstall -fO gnome-keyring
- portinstall security/gnome-keyring
-
-20100506:
- AFFECTS: users of mail/nullmailer on FreeBSD 6.X
- AUTHOR: glarkin@FreeBSD.org
-
- The nullmailer port was recently updated with an rc.d script to correctly
- daemonize nullmailer-send with daemon(8). On FreeBSD 6.X, daemon(8) does
- not support "[-u user]" command-line switch, causing the nullmailer rc.d
- script failure to start nullmailer-send.
-
- Support for "[-u user]" command-line switch was recently MFC'd to 6-STABLE
- (http://www.freebsd.org/cgi/query-pr.cgi?pr=bin/146266). FreeBSD 6.X users
- should patch and install daemon(8) by one of the methods described below.
-
- If /usr/src is not yet populated, csup the 6-STABLE sources and run these
- commands:
-
- cd /usr/src/usr.sbin/daemon
- make install
- /usr/local/etc/rc.d/nullmailer start
-
- If /usr/src is already populated with sources from a previous 6.X release,
- use these commands:
-
- cd /usr/src/usr.sbin/daemon
- fetch 'http://people.freebsd.org/~glarkin/pr-links/daemon/patch-daemon.c'
- fetch 'http://people.freebsd.org/~glarkin/pr-links/daemon/patch-daemon.8'
- patch -p0 daemon.c < patch-daemon.c
- patch -p0 daemon.8 < patch-daemon.8
- make install
- /usr/local/etc/rc.d/nullmailer start
-
-20100502:
- AFFECTS: users of www/squid*
- AUTHOR: miwi@FreeBSD.org
-
- Starting with squid* the directory containing the default cache and log
- directory was changed from $PREFIX/squid/ to /var/squid/.
-
- The default values for the following Squid configuration parameters have
- changed as shown below:
-
- cache_log from $PREFIX/squid/logs/cache.log to /var/squid/logs/cache.log
- cache_store_log from $PREFIX/squid/logs/store.log to /var/squid/logs/store.log
- pid_filename from $PREFIX/squid/logs/squid.pid to /var/squid/logs/squid.pid
- coredump_dir from $PREFIX/squid/cache to /var/squid/cache
-
- Please check whether you need to define any of these variables in your
- squid.conf to the old defaults explicitly before updating, especially if
- you have set up automated log processing or automated log rotation. If you
- define pid_filename in your squid.conf, you should also set squid_pidfile
- to the same value in /etc/rc.conf, cf. $PREFIX/etc/rc.d/squid.
-
-20100419:
- AFFECTS: users of math/libgmp4
- AUTHOR: ale@FreeBSD.org
-
- The default gmp version in FreeBSD is now 5.0.x. The port directory
- changed from math/libgmp4 to math/gmp. An entry has been added to MOVED
- and all depending ports revisions have been bumped, so the update should
- be handled correctly by usual port management tools such as portupgrade.
-
- Portmaster users, please do the following before upgrading ports that
- depend on gmp:
-
- portmaster -o math/gmp math/libgmp4
-
-20100409:
- AFFECTS: users of lang/php5
- AUTHOR: ale@FreeBSD.org
-
- As of PHP 5.3, a few extensions were removed from or included into the core
- PHP5 package. Follow the steps below to update your installation.
-
- 1) Delete the following packages (if installed):
-
- - php5-dbase
- - php5-ncurses
- - php5-pcre
- - php5-spl
- - php5-ming
- - php5-mhash
-
- 2) Rebuild lang/php5 and all ports that depend on it.
-
-20100403:
- AFFECTS: users of net/dgd
- AUTHOR: glewis@FreeBSD.org
-
- The kernel library has been separated from the main net/dgd port into its
- own net/dgd-kernel port so that all libraries are on an equal footing.
- This also reflects the split of the kernel library out from the main DGD
- distribution.
-
- If you wish to continue to use the kernel library you'll need to install
- net/dgd-kernel after updating to dgd-1.4.1_2.
-
-20100330:
- AFFECTS: users of gstreamer-plugins-bad and gstreamer-plugins-good
- AUTHOR: kwm@FreeBSD.org
-
- Plugin moved from the -bad port to the -good port. Please follow the
- instructions below before proceeding with normal update steps.
-
- If you use portmaster:
-
- portmaster gstreamer-plugins-bad
-
- If you use portupgrade:
-
- portupgrade -R multimedia/gstreamer-plugins-bad
-
-20100328:
- AFFECTS: users of graphics/png
- AUTHOR: dinoex@FreeBSD.org
-
- The PNG library has been updated to version 1.4.1. Please rebuild all
- ports that depend on it.
-
- If you use portmaster: make sure you update to portmaster version 2.20 or
- newer, then do:
-
- portmaster -r png-
-
- If you use portupgrade:
-
- portupgrade -fr graphics/png
-
-20100221:
- AFFECTS: users of rblibtorrent-devel
- AUTHOR: dougb@FreeBSD.org
-
- The port name has changed to libtorrent-rasterbar-14.
-
- If you use portmaster:
-
- portmaster -o net-p2p/libtorrent-rasterbar-14 net-p2p/rblibtorrent-devel
-
- If you use portupgrade:
-
- portupgrade -o net-p2p/libtorrent-rasterbar-14 net-p2p/rblibtorrent-devel
-
-20100216:
- AFFECTS: users of sysutils/bacula-server, sysutils/bacula-client
- AUTHOR: dvl@FreeBSD.org
-
- Bacula 5.x uses new shared objects which conflict with the shared objects
- from previous versions. You should delete all existing Bacula packages
- from your system before compiling Bacula 5.x, otherwise you'll encounter
- compilation errors.
-
- /usr/local/etc/rc.d/bacula-dir stop
- /usr/local/etc/rc.d/bacula-sd stop
- /usr/local/etc/rc.d/bacula-fd stop
- pkg_delete 'bacula-*'
-
- After upgrading, remember to run the database upgrade script supplied
- with the port.
-
-20100214:
- AFFECTS: users of japanese/roundcube
- AUTHOR: nork@FreeBSD.org
-
- If you switch mail/roundcube to japanese/roundcube, please re-check
- configuration files like ${PREFIX}/www/roundcube/config/main.inc.php.
- At least, please add following settings:
-
- $rcmail_config['message_charset_languages'] = array('en_US' => 'ISO-8859-1', ...
- $rcmail_config['transfer_encoding_languages'] = array('en_US' => 'quoted-printable', ...
-
- See also: ${PREFIX}/www/roundcube/config/main.inc.php.dist
-
-20100207:
- AFFECTS: users of www/firefox
- AUTHORS: beat@FreeBSD.org, mandree@FreeBSD.org (Java plugin)
-
- The www/firefox port has been updated to 3.6. From now on www/firefox
- will contain the most recent version of Firefox. Older but still
- supported releases will be available in www/firefox3 and www/firefox35.
-
- In order to update to Firefox 3.6 please delete your older installed
- version of Firefox first and install www/firefox afterwards. Please
- make sure all your addons are compatible with Firefox 3.6 and backup
- your ~/.mozilla directory prior to the first launch of Firefox 3.6.
-
- Note that in order to use Java with Firefox 3.6, you need to install
- java/openjdk6, build it with the "WEB" option enabled and use the Iced
- Tea plugin. To achieve the latter, each user needs to create a
- symlink to the Icedtea plugin as described in the Browsers/Firefox and
- Java[tm] Plugin section in the handbook:
-
- ln -s /usr/local/openjdk6/jre/lib/IcedTeaPlugin.so \
- $HOME/.mozilla/plugins
-
-20100207:
- AFFECTS: users of Mesa3D libraries and x11-drivers/xf86-video-nouveau
- AUTHOR: nork@FreeBSD.org
-
- If you want to use Mesa3D 7.6.1 and libdrm 2.4.17 rather than 7.4.4
- and 2.4.12, you must define WITHOUT_NOUVEAU global macro, at least,
- enabled on graphics/libGL*, graphics/libglut, graphics/dri,
- graphics/mesa-demos, and graphics/libdrm. And please give up using
- x11-drivers/xf86-video-nouveau.
-
- At this time, I cannot enable latest Mesa3D and libdrm, because they
- break xf86-video-nouveau. But old (current?) Mesa3D and libdrm do not
- break any drivers.
-
- AMD Radeon HD 2xxx/3xxx/4xxx users: If you use AMD Radeon HD [234]xxx
- series, please define WITHOUT_NOUVEAU global macro. You can then use
- OpenGL Hardware Accelerator feature on these series.
-
-20100206:
- AFFECTS: users of net/samba4-devel
- AUTHOR: timur@FreeBSD.org
-
- Default configuration file was moved to ${LOCALBASE}/etc/smb4.conf to
- avoid conflicts with the installed net/samba3?. Also, userland utils
- are not installed by default, which should also help with the parallel
- setup of Samba3 and Samba4.
-
-20100205:
- AFFECTS: users of Qt 3 and KDE 3
- AUTHOR: itetcu@FreeBSD.org
-
- When building qt33 and kdelibs3 (at least), while they are installed,
- because of -L/usr/local/lib being passed too soon, the currently installed
- libraries are used instead of the ones from the build. This makes the
- build fail if you updated any of the libraries these Qt/KDE libraries are
- linked against (e.g. libjpeg).
-
- For the moment the workaround, when you get to this, is to move the old lib
- out of the way, e.g.:
-
- mv /usr/local/lib/libqt-mt.so /usr/local/lib/libqt-mt.so.old && \
- cd /usr/ports/x11-toolkits/qt33/ && make && \
- mv /usr/local/lib/libqt-mt.so.old /usr/local/lib/libqt-mt.so && \
- portmaster -C x11-toolkits/qt33 (or portupgrade -w qt-33\*) ...
-
-20100205:
- AFFECTS: users of lang/perl*
- AUTHOR: skv@FreeBSD.org
-
- Default version of Perl was bumped to 5.10.
-
- If you already have lang/perl5.8 installed, and want to switch to
- lang/perl5.10 please follow instructions in the entry 20090328 in this
- file.
-
-20100205:
- AFFECTS: users of net/samba34
- AUTHOR: timur@FreeBSD.org
-
- This port was developed with the generous help of Florent Brodin.
-
- The default passdb backend has been changed to `tdbsam'! That breaks
- existing setups using the `smbpasswd' backend without explicit
- declaration! Please use `passdb backend = smbpasswd' if you would like
- to stick to the `smbpasswd' backend or convert your smbpasswd entries
- using e.g. `pdbedit -i smbpasswd -e tdbsam'.
-
- The `tdbsam' backend is much more flexible concerning per user
- settings like `profile path' or `home directory' and there are some
- commands which do not work with the `smbpasswd' backend at all.
-
-20100130:
- AFFECTS: users of audio/sdl_mixer and graphics/sdl_image
- AUTHOR: mva@FreeBSD.org
-
- The SDL_mixer and SDL_image libraries have new shared library versions.
- Please rebuild all ports that depend on them.
-
- If you use portmaster:
-
- portmaster -r sdl_mixer-
- portmaster -r sdl_image-
-
- If you use portupgrade:
-
- portupgrade -fr audio/sdl_mixer
- portupgrade -fr graphics/sdl_image
-
-20100125:
- AFFECTS: users of audio/openal and graphics/openal-soft
- AUTHOR: mva@FreeBSD.org
-
- The default OpenAL implementation was switched to audio/openal-soft.
- To update all ports correctly, the following steps have to be performed.
-
- pkg_delete -f openal-\*
-
- If you use portmaster:
-
- portmaster -o audio/openal-soft audio/openal
- portmaster -r audio/openal-soft
-
- If you use portupgrade:
-
- portupgrade -ro audio/openal audio/openal-soft
-
- If you want to stick with audio/openal, please specify the following ports
- make flag within /etc/make.conf (or an appropriate configuration file for
- your ports):
-
- WANT_OPENAL=si
-
-20100122:
- AFFECTS: users of sysutils/policykit and sysutils/polkit
- AUTHOR: gnome@FreeBSD.org
-
- Due to a recent change in sysutils/policykit, both sysutils/policykit,
- and sysutils/polkit need to be rebuilt, but in a certain order. First,
- upgrade sysutils/policykit to 0.9_6. Then, force rebuild and reinstall
- of sysutils/polkit. If you do not do this, applications which depend
- on polkitd will fail.
-
-20100113:
- AFFECTS: users of emulators/virtualbox
- AUTHOR: beat@FreeBSD.org
-
- Port has been renamed to emulators/virtualbox-ose to reflect that we are
- using the OSE version. A separate port for the kernel modules has been
- created: emulators/virtualbox-ose-kmod.
-
- Please see http://wiki.freebsd.org/VirtualBox for update instructions.
-
-20100107:
- AFFECTS: users of security/openvpn*
- AUTHOR: mandree@FreeBSD.org
-
- security/openvpn has been moved to security/openvpn20 and upgraded to 2.0.9.
- security/openvpn has been upgraded to 2.1.1, and security/openvpn-devel has
- been removed.
-
- Regular upgrades of the security/openvpn port should succeed without
- manual intervention, but if you want to stick to openvpn 2.0 or if you
- had been using openvpn-devel, manual intervention is needed, as
- follows:
-
- If you'd been using the security/openvpn-devel port, please use one of
- these commands for upgrading:
-
- portmaster -m-DDISABLE_CONFLICTS -o security/openvpn security/openvpn-devel
-
- portupgrade -m-DDISABLE_CONFLICTS -o security/openvpn security/openvpn-devel
-
- If you want to stick to openvpn 2.0, please use one of these two
- upgrade commands:
-
- portmaster -m-DDISABLE_CONFLICTS -o security/openvpn20 security/openvpn
-
- portupgrade -m-DDISABLE_CONFLICTS -o security/openvpn20 security/openvpn
-
-20100106:
- AFFECTS: users of devel/websvn
- AUTHOR: miwi@FreeBSD.org
-
- The default install directory for websvn has changed from
- ${PREFIX}/www/data/websvn to ${PREFIX}/www/websvn.
-
- If you are updating from a previous version, to preserve your settings
- and data, please do the following:
-
- mv /usr/local/www/data/websvn /usr/local/www
-
- Then update as usual.
-
-20091227:
- AFFECTS: users of sysutils/grok
- AUTHOR: Wesley Shields <wxs@FreeBSD.org>
-
- The sysutils/grok port has been completely re-written. Configuration files
- will need to be reviewed. Also, the RC script has been removed until it can
- be made to work with the new version.
-
-20091226:
- AFFECTS: users of net-mgmt/ndoutils
- AUTHOR: pgollucci@FreeBSD.org
-
- When upgrading you'll need to run ./upgradedb; see UPGRADING file.
-
-20091214:
- AFFECTS: users of net/grdc
- AUTHOR: avl@FreeBSD.org
-
- Grdc has been renamed to Remmina upstream, and the port was also renamed
- to reflect this. After installing remmina port you will need to download
- the ``grdc2remmina.sh'' script and run it as your normal user(s) that
- have ~/.grdc. The script will only create ~/.remmina directory and move
- grdc config files to the new path; it does not affect anything else.
-
- $ fetch http://people.freebsd.org/~avl/script/grdc2remmina.sh
- $ sh grdc2remmina.sh
-
-20091213:
- AFFECTS: users of net-mgmt/zabbix, net-mgmt/zabbix-agent
- AUTHOR: Jim Riggs <ports@christianserving.org>
-
- In order to simplify configuration and better separate the different
- components of Zabbix, the former zabbix port has been split into three:
- zabbix-server, zabbix-proxy, and zabbix-frontend. Each component has
- distinct functionality and may be installed independently on separate
- systems. The existing zabbix-agent port remains.
-
- Additionally, the new zabbix-frontend port now (correctly) installs the
- PHP frontend in PREFIX/www/zabbix. The old zabbix port installed the
- files in PREFIX/share/zabbix/php. Web server configurations must be
- updated accordingly.
-
- Finally, Zabbix has been updated to version 1.8. Not everyone may be
- able to upgrade from version 1.6 immediately, though, so 1.6.8 versions
- of the ports are also available as zabbix16-server, zabbix16-proxy,
- zabbix16-agent, and zabbix16-frontend.
-
-20091206:
- AFFECTS: users of emulators/qemu
- AUTHOR: nox@FreeBSD.org
-
- The port has been updated to 0.11.1, which no longer enables kqemu by
- default (if built with KQEMU knob on), now you also have to explicitly
- pass -enable-kqemu (or -kernel-kqemu as with the previous versions)
- if you want to use it. Also note the 0.11 stable branch is the last
- qemu branch that still supports kqemu, so if you depend on reasonably
- fast emulation on FreeBSD you should start looking for alternatives
- some time soon. (VirtualBox?)
-
-20091120:
- AFFECTS: users of mail/postfixadmin
- AUTHOR: Terry Sposato <tabmow@freenode.net>
-
- Due to a bug in the previous postfixadmin port, existing users need to
- backup their config.inc.php before they upgrade to postfixadmin-2.3 or
- later and put it in place after the upgrade is complete.
-
-20091120:
- AFFECTS: users of security/f-prot
- AUTHOR: Tim Bishop <tdb@FreeBSD.org>
-
- The main f-prot command is now named fpscan. Virus definitions are
- updated using the fpupdate command. fpupdate will automatically run
- from periodic every day. To disable set the following option in
- /etc/periodic.conf:
-
- fpupdate_enable="NO"
-
- The f-prot port now only works on i386.
-
-20091118:
- AFFECTS: users of java/jboss5
- AUTHOR: Jonathan Chen <jonc@chen.org.nz>
-
- The JBoss directory structure has been reorganised to follow hier(7)
- guidelines more closely; in particular, transient and deployment files
- were moved to /var/jboss5, thus allowing /usr to be read-only.
-
-20091118:
- AFFECTS: users of www/redmine
- AUTHOR: Bernhard Froehlich <decke@bluelife.at>
-
- After the upgrade you need to generate a session secret before restarting
- the application. This is to protect you from cross-site request forgery.
- From your Redmine directory, simply run the following command once:
-
- # rake config/initializers/session_store.rb
-
- then upgrade as usual:
-
- # rake db:migrate RAILS_ENV=production
-
-20091114:
- AFFECTS: users of emulators/win4bsd
- AUTHOR: Mario S F Ferreira <lioux@FreeBSD.org>
-
- The new port now depends on emulators/kqemu-kmod instead of installing
- its own version. Therefore, you should make sure that no other kqemu.ko
- modules are installed:
-
- # pkg_delete -f win4bsd\*
- # rm -f /boot/kernel/kqemu.ko
- # pkg_delete -f kqemu-kmod\*
- # portinstall emulators/win4bsd
-
- Do not forget to enable kqemu on rc.conf since win4bsd will not work
- without it.
-
-20091018:
- AFFECTS: users of databases/mysql54-server
- AUTHOR: Alex Dupre <ale@FreeBSD.org>
-
- After the upgrade the server may fail to start due to changes in the
- default values of innodb_log_files_in_group and innodb_log_file_size,
- which differ from those in earlier 5.4 releases.
-
- You should discard the old InnoDB log files and let MySQL 5.4.3 create
- new ones. It is necessary to shut down your current server cleanly so
- that no outstanding transaction information remains in the log.
-
- See here: http://dev.mysql.com/doc/refman/5.4/en/news-5-4-3.html
-
-20091014:
- AFFECTS: users of mail/heirloom-mailx
- AUTHOR: Alexander Logvinov <avl@FreeBSD.org>
-
- Since SourceForge switched to the new File Release System,
- mail/heirloom-mailx has wrong package name. All users who have
- mail/heirloom-mailx installed after 22 August 2009 should run the
- following commands:
-
- # pkg_delete "\-mailx-12.4_1"
- or
- # rm -r /var/db/pkg/-mailx-12.4_1
-
- # rm -r /var/db/ports/-mailx
- # cd /usr/ports/mail/heirloom-mailx && make install clean
-
-20090921:
- AFFECTS: users of archivers/lzmautils, archivers/lzmautils-devel
- AUTHOR: Christian Weisgerber <naddy@FreeBSD.org>
-
- The XZ Utils distribution has superseded LZMA Utils, so the xz port has
- been added and the lzmautils ports have been removed. To perform the
- move, run one of the following commands:
-
- If using portupgrade:
-
- # portupgrade -o archivers/xz lzmautils\*
-
- If using portmaster:
-
- # portmaster -o archivers/xz archivers/lzmautils
- or
- # portmaster -o archivers/xz archivers/lzmautils-devel
-
- as applicable.
-
-20090919:
- AFFECTS: users of mail/postfix-postfwd
- AUTHOR: Sahil Tandon <sahil@tandon.net>
-
- The recipient rate-limiting feature is now called via rcpt() command
- instead of with mrcpt() as in previous versions. Make sure to update
- your postfwd.conf if you use this feature.
-
-20090917:
- AFFECTS: users of www/epiphany, x11/yelp, graphics/librsvg2,
- x11/toolkits/py-gnome-extras, and www/epiphany-extensions
- AUTHOR: gnome@FreeBSD.org
-
- The default Gecko provider has been changed from www/firefox to
- www/libxul. Firefox 2.x is now marked FORBIDDEN for security reasons,
- and libxul is new, stable, and preferred Gecko provider. Libxul uses
- the same Gecko engine as Firefox 3.0.x.
-
- Some ports may fail to upgrade or run when both www/firefox and libxul
- are installed on the same system. To make sure everything runs smoothly,
- uninstall www/firefox, then install libxul, then upgrade the affected
- ports.