aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-05-21 12:40:13 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-05-21 12:41:04 +0000
commitb2cf151291b6075a960575f0fa2d6f5565e6ce55 (patch)
tree18f33b29223a9dfbd7f91ba6db30cdea378463ba
parentb3981f5cf79b980f52b146634945e4e97b31caa9 (diff)
downloadports-b2cf151291b6075a960575f0fa2d6f5565e6ce55.tar.gz
ports-b2cf151291b6075a960575f0fa2d6f5565e6ce55.zip
deskutils/calibre: Update to 5.18
- Remove upstreamed patch - Since upstream targets python 3.8 which is the default for the ports tree, declare that as minimum version - Remove patch which was needed to make it work with python <= 3.7
-rw-r--r--deskutils/calibre/Makefile5
-rw-r--r--deskutils/calibre/distinfo6
-rw-r--r--deskutils/calibre/files/patch-src_calibre_utils_cpp__binding.h20
-rw-r--r--deskutils/calibre/files/patch-src_calibre_utils_formatter.py12
-rw-r--r--deskutils/calibre/pkg-plist1
5 files changed, 5 insertions, 39 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index 52c644605725..8b909ac9c776 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -1,8 +1,7 @@
# Created by: stas
PORTNAME= calibre
-PORTVERSION= 5.17.0
-PORTREVISION= 2
+PORTVERSION= 5.18.0
CATEGORIES= deskutils python
MASTER_SITES= http://download.calibre-ebook.com/${PORTVERSION}/
@@ -57,7 +56,7 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils \
${PYTHON_PKGNAMEPREFIX}zeroconf>0:net/py-zeroconf
USES= desktop-file-utils gettext-runtime gl gnome localbase:ldflags \
- pkgconfig pyqt:5 python:3.5+ qt:5 shared-mime-info shebangfix \
+ pkgconfig pyqt:5 python:3.8+ qt:5 shared-mime-info shebangfix \
ssl tar:xz xorg
USE_RC_SUBR= calibre
SUB_LIST+= PYTHON_VERSION=${PYTHON_VERSION}
diff --git a/deskutils/calibre/distinfo b/deskutils/calibre/distinfo
index 80dc9733296a..c3b143635755 100644
--- a/deskutils/calibre/distinfo
+++ b/deskutils/calibre/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1619768640
-SHA256 (calibre-5.17.0.tar.xz) = add8812f7637abfd3015f5861388c69166a4815f2103d1e30dc297b28ead56bb
-SIZE (calibre-5.17.0.tar.xz) = 36784632
+TIMESTAMP = 1621582558
+SHA256 (calibre-5.18.0.tar.xz) = 0353120a3354d19ed59f13e05ac6b0bc25ee92f67b2e8f65876fd07e21a7c235
+SIZE (calibre-5.18.0.tar.xz) = 36686328
diff --git a/deskutils/calibre/files/patch-src_calibre_utils_cpp__binding.h b/deskutils/calibre/files/patch-src_calibre_utils_cpp__binding.h
deleted file mode 100644
index 7367743aac8b..000000000000
--- a/deskutils/calibre/files/patch-src_calibre_utils_cpp__binding.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/calibre/utils/cpp_binding.h.orig 2021-04-30 02:00:12 UTC
-+++ src/calibre/utils/cpp_binding.h
-@@ -14,7 +14,7 @@
-
- #define arraysz(x) (sizeof(x)/sizeof(x[0]))
-
--template<typename T, void free_T(void*), T null=reinterpret_cast<T>(NULL)>
-+template<typename T, void free_T(void*), T null=static_cast<T>(NULL)>
- class generic_raii {
- private:
- generic_raii( const generic_raii & ) noexcept;
-@@ -45,7 +45,7 @@ typedef generic_raii<wchar_t*, PyMem_Free> wchar_raii;
- static inline void python_object_destructor(void *p) { PyObject *x = reinterpret_cast<PyObject*>(p); Py_XDECREF(x); }
- typedef generic_raii<PyObject*, python_object_destructor> pyobject_raii;
-
--template<typename T, void free_T(void*), size_t sz, T null=reinterpret_cast<T>(NULL)>
-+template<typename T, void free_T(void*), size_t sz, T null=static_cast<T>(NULL)>
- class generic_raii_array {
- private:
- generic_raii_array( const generic_raii_array & ) noexcept;
diff --git a/deskutils/calibre/files/patch-src_calibre_utils_formatter.py b/deskutils/calibre/files/patch-src_calibre_utils_formatter.py
deleted file mode 100644
index 64e1c737f4ba..000000000000
--- a/deskutils/calibre/files/patch-src_calibre_utils_formatter.py
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/calibre/utils/formatter.py.orig 2021-04-16 02:20:00 UTC
-+++ src/calibre/utils/formatter.py
-@@ -888,7 +888,8 @@ class _Interpreter(object):
-
- def do_node_first_non_empty(self, prog):
- for expr in prog.expression_list:
-- if v := self.expr(expr):
-+ v = self.expr(expr)
-+ if v:
- if (self.break_reporter):
- self.break_reporter(prog.node_name, v, prog.line_number)
- return v
diff --git a/deskutils/calibre/pkg-plist b/deskutils/calibre/pkg-plist
index f4f190c8a151..700ee9667536 100644
--- a/deskutils/calibre/pkg-plist
+++ b/deskutils/calibre/pkg-plist
@@ -365,7 +365,6 @@ lib/calibre/calibre/ebooks/metadata/sources/google.py
lib/calibre/calibre/ebooks/metadata/sources/google_images.py
lib/calibre/calibre/ebooks/metadata/sources/identify.py
lib/calibre/calibre/ebooks/metadata/sources/openlibrary.py
-lib/calibre/calibre/ebooks/metadata/sources/overdrive.py
lib/calibre/calibre/ebooks/metadata/sources/prefs.py
lib/calibre/calibre/ebooks/metadata/sources/search_engines.py
lib/calibre/calibre/ebooks/metadata/sources/test.py