aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-10 04:56:25 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-10 04:56:25 +0000
commitb3608f79c1a24b43e6f65283ea603dac052a8406 (patch)
treea89f7c51468c9ed2d953a99e16f1904df43883c5
parent7c9c12e559e10f61ce54d437c9c8a2a0e33ac3f1 (diff)
devel/py-unidep: Add py-unidep 0.59.0
UniDep streamlines Python project dependency management by unifying Conda and Pip packages in a single system. Handling dependencies in Python projects can be challenging, especially when juggling Python and non-Python packages. This often leads to confusion and inefficiency, as developers juggle between multiple dependency files.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-unidep/Makefile25
-rw-r--r--devel/py-unidep/distinfo3
-rw-r--r--devel/py-unidep/pkg-descr6
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0299ae5ecd70..5b00893b2f07 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5917,6 +5917,7 @@
SUBDIR += py-unearth
SUBDIR += py-unicodecsv
SUBDIR += py-unicodedata2
+ SUBDIR += py-unidep
SUBDIR += py-unidiff
SUBDIR += py-unipath
SUBDIR += py-unittest2
diff --git a/devel/py-unidep/Makefile b/devel/py-unidep/Makefile
new file mode 100644
index 000000000000..df42452903c4
--- /dev/null
+++ b/devel/py-unidep/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= unidep
+PORTVERSION= 0.59.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Unified Conda and Pip requirements management
+WWW= https://unidep.readthedocs.io/en/latest/ \
+ https://github.com/basnijholt/unidep
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=42:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ruamel.yaml>=0:devel/py-ruamel.yaml@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-unidep/distinfo b/devel/py-unidep/distinfo
new file mode 100644
index 000000000000..821260094db3
--- /dev/null
+++ b/devel/py-unidep/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1720536466
+SHA256 (unidep-0.59.0.tar.gz) = d8aabadf85ba1c5be285179dfda0b806ea8026dc07a6cb882b11031aea48689d
+SIZE (unidep-0.59.0.tar.gz) = 93847
diff --git a/devel/py-unidep/pkg-descr b/devel/py-unidep/pkg-descr
new file mode 100644
index 000000000000..5aca94de70a0
--- /dev/null
+++ b/devel/py-unidep/pkg-descr
@@ -0,0 +1,6 @@
+UniDep streamlines Python project dependency management by unifying Conda and
+Pip packages in a single system.
+
+Handling dependencies in Python projects can be challenging, especially when
+juggling Python and non-Python packages. This often leads to confusion and
+inefficiency, as developers juggle between multiple dependency files.