aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2025-02-03 15:39:48 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2025-02-03 15:54:29 +0000
commitb390108e14c458d264910f688228983e5199ebaf (patch)
treed5d679299a72813a585aff38d8a5b03f04e95063
parente9f9830bd993eeadd51d02ad67404d55de1eb963 (diff)
net-im/py-matrix-synapse: Allow build with py-poetry-core 2.0.1
- Bump PORTREVISION for package change Approved by: portmgr (blanket) With hat: python
-rw-r--r--net-im/py-matrix-synapse/Makefile4
-rw-r--r--net-im/py-matrix-synapse/files/patch-pyproject.toml6
2 files changed, 5 insertions, 5 deletions
diff --git a/net-im/py-matrix-synapse/Makefile b/net-im/py-matrix-synapse/Makefile
index 89ab43673867..284b90355b0b 100644
--- a/net-im/py-matrix-synapse/Makefile
+++ b/net-im/py-matrix-synapse/Makefile
@@ -1,6 +1,6 @@
PORTNAME= matrix-synapse
DISTVERSION= 1.120.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,7 @@ WWW= https://element-hq.github.io/synapse
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.1.0<1.9.1_99:devel/py-poetry-core@${PY_FLAVOR} \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.1.0<2.0.1_99:devel/py-poetry-core@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools-rust>=1.3<1.10.2_99:devel/py-setuptools-rust@${PY_FLAVOR}
# Keep the RUN_DEPENDS layout similar to the pyproject.toml file
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.0:devel/py-jsonschema@${PY_FLAVOR} \
diff --git a/net-im/py-matrix-synapse/files/patch-pyproject.toml b/net-im/py-matrix-synapse/files/patch-pyproject.toml
index e8b13f8d7b35..60bb6796fffe 100644
--- a/net-im/py-matrix-synapse/files/patch-pyproject.toml
+++ b/net-im/py-matrix-synapse/files/patch-pyproject.toml
@@ -1,4 +1,4 @@
---- pyproject.toml.orig 2024-07-16 11:51:30 UTC
+--- pyproject.toml.orig 2024-12-03 16:00:50 UTC
+++ pyproject.toml
@@ -215,16 +215,6 @@ pydantic = ">=1.7.4, <3"
# See https://github.com/matrix-org/synapse/issues/15858
@@ -17,12 +17,12 @@
# This is used for parsing multipart responses
python-multipart = ">=0.0.9"
-@@ -372,7 +362,7 @@ tomli = ">=1.2.3"
+@@ -370,7 +360,7 @@ tomli = ">=1.2.3"
# runtime errors caused by build system changes.
# We are happy to raise these upper bounds upon request,
# provided we check that it's safe to do so (i.e. that CI passes).
-requires = ["poetry-core>=1.1.0,<=1.9.1", "setuptools_rust>=1.3,<=1.8.1"]
-+requires = ["poetry-core>=1.1.0,<=1.9.1", "setuptools_rust>=1.3,<=1.10.2"]
++requires = ["poetry-core>=1.1.0,<=2.0.1", "setuptools_rust>=1.3,<=1.10.2"]
build-backend = "poetry.core.masonry.api"