aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroo Ono <hiroo.ono+freebsd@gmail.com>2022-11-23 07:11:03 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-11-24 16:02:19 +0000
commitb390a914547a65cf5863f50b623834c5af0aee1a (patch)
tree96db85fe2509f47610586c226c120ae5ed2d0d6a
parentaf6f8724c22e6ef942490cfd2417e31e1ab16ccc (diff)
downloadports-b390a914547a65cf5863f50b623834c5af0aee1a.tar.gz
ports-b390a914547a65cf5863f50b623834c5af0aee1a.zip
net/onedrive: Update to 2.4.21
ChangeLog: https://github.com/abraunegg/onedrive/blob/v2.4.21/CHANGELOG.md PR: 267831 Reported by: hiroo.ono+freebsd@gmail.com (maintainer)
-rw-r--r--net/onedrive/Makefile17
-rw-r--r--net/onedrive/distinfo6
-rw-r--r--net/onedrive/files/patch-Makefile.in37
3 files changed, 25 insertions, 35 deletions
diff --git a/net/onedrive/Makefile b/net/onedrive/Makefile
index 1cc34ae93f89..3b33e199ec3f 100644
--- a/net/onedrive/Makefile
+++ b/net/onedrive/Makefile
@@ -1,7 +1,6 @@
PORTNAME= onedrive
DISTVERSIONPREFIX= v
-DISTVERSION= 2.4.18
-PORTREVISION= 1
+DISTVERSION= 2.4.21
CATEGORIES= net
MAINTAINER= hiroo.ono+freebsd@gmail.com
@@ -22,7 +21,7 @@ USE_GITHUB= yes
GH_ACCOUNT= abraunegg
GNU_CONFIGURE= yes
-PKGCONFIG= pkgconf
+PKGCONFIG= pkgconf
PORTDOCS= *
@@ -30,15 +29,15 @@ OPTIONS_DEFINE= DOCS NOTIFY COMPLETION
OPTIONS_DEFAULT= NOTIFY COMPLETION
OPTIONS_SUB= yes
-NOTIFY_CONFIGURE_ENABLE= notifications
-NOTIFY_USES= gnome
-NOTIFY_USE= GNOME=glib20,gdkpixbuf2
-NOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
-
COMPLETION_DESC= Install completion for BASH, FISH and ZSH
-COMPLETION_CONFIGURE_ENABLE= completions
COMPLETION_BUILD_DEPENDS= bash-completion>0:shells/bash-completion
COMPLETION_RUN_DEPENDS= bash-completion>0:shells/bash-completion
+COMPLETION_CONFIGURE_ENABLE= completions
+
+NOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
+NOTIFY_USES= gnome
+NOTIFY_USE= GNOME=glib20,gdkpixbuf2
+NOTIFY_CONFIGURE_ENABLE= notifications
ONEDRIVE_LOGDIR= /var/log/${PORTNAME}
diff --git a/net/onedrive/distinfo b/net/onedrive/distinfo
index 0e3aa90e2292..47497a98b16f 100644
--- a/net/onedrive/distinfo
+++ b/net/onedrive/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1654264483
-SHA256 (abraunegg-onedrive-v2.4.18_GH0.tar.gz) = e6dfd1644395c03bebfc5e68e3d0037644c0bcad5d732326df5cec00fbd05f3d
-SIZE (abraunegg-onedrive-v2.4.18_GH0.tar.gz) = 1147175
+TIMESTAMP = 1668554606
+SHA256 (abraunegg-onedrive-v2.4.21_GH0.tar.gz) = c9991970cbb108368d16a4e6aefe66f0d61d66791ab3bbc526bff2237b926c51
+SIZE (abraunegg-onedrive-v2.4.21_GH0.tar.gz) = 1223054
diff --git a/net/onedrive/files/patch-Makefile.in b/net/onedrive/files/patch-Makefile.in
index 1ce5e5a3878e..6051b8bce38f 100644
--- a/net/onedrive/files/patch-Makefile.in
+++ b/net/onedrive/files/patch-Makefile.in
@@ -1,4 +1,4 @@
---- Makefile.in.orig 2022-06-02 08:24:26 UTC
+--- Makefile.in.orig 2022-09-26 19:30:30 UTC
+++ Makefile.in
@@ -25,6 +25,7 @@ systemdsystemunitdir = @systemdsystemunitdir@
curl_LIBS = @curl_LIBS@
@@ -8,15 +8,6 @@
COMPLETIONS = @COMPLETIONS@
BASH_COMPLETION_DIR = @BASH_COMPLETION_DIR@
ZSH_COMPLETION_DIR = @ZSH_COMPLETION_DIR@
-@@ -55,7 +56,7 @@ endif
- system_unit_files = contrib/systemd/onedrive@.service
- user_unit_files = contrib/systemd/onedrive.service
-
--DOCFILES = README.md config LICENSE CHANGELOG.md docs/Docker.md docs/INSTALL.md docs/SharePoint-Shared-Libraries.md docs/USAGE.md docs/BusinessSharedFolders.md docs/advanced-usage.md
-+DOCFILES = README.md config CHANGELOG.md docs/Docker.md docs/SharePoint-Shared-Libraries.md docs/USAGE.md docs/BusinessSharedFolders.md docs/advanced-usage.md
-
- ifneq ("$(wildcard /etc/redhat-release)","")
- RHEL = $(shell cat /etc/redhat-release | grep -E "(Red Hat Enterprise Linux Server|CentOS)" | wc -l)
@@ -67,6 +68,7 @@ endif
SOURCES = \
@@ -30,19 +21,19 @@
echo $(version) > version ; \
fi
- $(DC) $(DCFLAGS) $(addprefix -L,$(curl_LIBS)) $(addprefix -L,$(sqlite_LIBS)) $(addprefix -L,$(notify_LIBS)) -L-ldl $(SOURCES) -of$@
-+ $(DC) $(DCFLAGS) $(addprefix -L,$(curl_LIBS)) $(addprefix -L,$(sqlite_LIBS)) $(addprefix -L,$(notify_LIBS)) $(addprefix -L,$(inotify_LIBS)) -L-ldl $(SOURCES) -of$@
++ $(DC) $(DCFLAGS) $(addprefix -L,$(curl_LIBS)) $(addprefix -L,$(sqlite_LIBS)) $(addprefix -L,$(notify_LIBS)) -$(addprefix -L,$(inotify_LIBS)) -L-ldl $(SOURCES) -of$@
install: all
- $(INSTALL) -D onedrive $(DESTDIR)$(bindir)/onedrive
-- $(INSTALL) -D -m 644 onedrive.1 $(DESTDIR)$(mandir)/man1/onedrive.1
-- $(INSTALL) -D -m 644 contrib/logrotate/onedrive.logrotate $(DESTDIR)$(sysconfdir)/logrotate.d/onedrive
+- $(INSTALL) -D -m 0644 onedrive.1 $(DESTDIR)$(mandir)/man1/onedrive.1
+- $(INSTALL) -D -m 0644 contrib/logrotate/onedrive.logrotate $(DESTDIR)$(sysconfdir)/logrotate.d/onedrive
+ $(INSTALL) -s onedrive $(DESTDIR)$(bindir)/onedrive
-+ $(INSTALL) -m 644 onedrive.1 $(DESTDIR)$(mandir)/man1/onedrive.1
++ $(INSTALL) -m 0644 onedrive.1 $(DESTDIR)$(mandir)/man1/onedrive.1
+ mkdir -p $(DESTDIR)$(sysconfdir)/logrotate.d
-+ $(INSTALL) -m 644 contrib/logrotate/onedrive.logrotate $(DESTDIR)$(sysconfdir)/logrotate.d/onedrive
++ $(INSTALL) -m 0644 contrib/logrotate/onedrive.logrotate $(DESTDIR)$(sysconfdir)/logrotate.d/onedrive
mkdir -p $(DESTDIR)$(docdir)
-- $(INSTALL) -D -m 644 $(DOCFILES) $(DESTDIR)$(docdir)
-+ $(INSTALL) -m 644 $(DOCFILES) $(DESTDIR)$(docdir)
+- $(INSTALL) -D -m 0644 $(DOCFILES) $(DESTDIR)$(docdir)
++ $(INSTALL) -m 0644 $(DOCFILES) $(DESTDIR)$(docdir)
ifeq ($(HAVE_SYSTEMD),yes)
$(INSTALL) -d -m 0755 $(DESTDIR)$(systemduserunitdir) $(DESTDIR)$(systemdsystemunitdir)
ifeq ($(RHEL),1)
@@ -50,15 +41,15 @@
endif
endif
ifeq ($(COMPLETIONS),yes)
-- $(INSTALL) -D -m 644 contrib/completions/complete.zsh $(DESTDIR)$(ZSH_COMPLETION_DIR)/_onedrive
-- $(INSTALL) -D -m 644 contrib/completions/complete.bash $(DESTDIR)$(BASH_COMPLETION_DIR)/onedrive
-- $(INSTALL) -D -m 644 contrib/completions/complete.fish $(DESTDIR)$(FISH_COMPLETION_DIR)/onedrive.fish
+- $(INSTALL) -D -m 0644 contrib/completions/complete.zsh $(DESTDIR)$(ZSH_COMPLETION_DIR)/_onedrive
+- $(INSTALL) -D -m 0644 contrib/completions/complete.bash $(DESTDIR)$(BASH_COMPLETION_DIR)/onedrive
+- $(INSTALL) -D -m 0644 contrib/completions/complete.fish $(DESTDIR)$(FISH_COMPLETION_DIR)/onedrive.fish
+ mkdir -p $(DESTDIR)$(ZSH_COMPLETION_DIR)
-+ $(INSTALL) -m 644 contrib/completions/complete.zsh $(DESTDIR)$(ZSH_COMPLETION_DIR)/_onedrive
++ $(INSTALL) -m 0644 contrib/completions/complete.zsh $(DESTDIR)$(ZSH_COMPLETION_DIR)/_onedrive
+ mkdir -p $(DESTDIR)$(BASH_COMPLETION_DIR)
-+ $(INSTALL) -m 644 contrib/completions/complete.bash $(DESTDIR)$(BASH_COMPLETION_DIR)/onedrive
++ $(INSTALL) -m 0644 contrib/completions/complete.bash $(DESTDIR)$(BASH_COMPLETION_DIR)/onedrive
+ mkdir -p $(DESTDIR)$(FISH_COMPLETION_DIR)
-+ $(INSTALL) -m 644 contrib/completions/complete.fish $(DESTDIR)$(FISH_COMPLETION_DIR)/onedrive.fish
++ $(INSTALL) -m 0644 contrib/completions/complete.fish $(DESTDIR)$(FISH_COMPLETION_DIR)/onedrive.fish
endif