aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:28:24 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:59:09 +0000
commitb4446105b121c843ed05483a6f60593186c7f82d (patch)
tree388185cbc875669541f980eacddd713a200e1591
parent630b8c5c4038fee5c6094baa83290e9e100b742e (diff)
downloadports-b4446105b121c843ed05483a6f60593186c7f82d.tar.gz
ports-b4446105b121c843ed05483a6f60593186c7f82d.zip
sysutils/pciutils: Update to 3.9.0
-rw-r--r--sysutils/pciutils/Makefile2
-rw-r--r--sysutils/pciutils/distinfo6
-rw-r--r--sysutils/pciutils/files/patch-Makefile26
3 files changed, 17 insertions, 17 deletions
diff --git a/sysutils/pciutils/Makefile b/sysutils/pciutils/Makefile
index 8600a361420e..d091a566796e 100644
--- a/sysutils/pciutils/Makefile
+++ b/sysutils/pciutils/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pciutils
-PORTVERSION= 3.8.0
+PORTVERSION= 3.9.0
CATEGORIES= sysutils
MASTER_SITES= KERNEL_ORG/software/utils/pciutils \
LOCAL/sunpoet
diff --git a/sysutils/pciutils/distinfo b/sysutils/pciutils/distinfo
index 91c3c3582872..fbbdbeb2adbd 100644
--- a/sysutils/pciutils/distinfo
+++ b/sysutils/pciutils/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1650970055
-SHA256 (pciutils-3.8.0.tar.xz) = 91edbd0429a84705c9ad156d4ff38ccc724d41ea54c4c5b88e38e996f8a34f05
-SIZE (pciutils-3.8.0.tar.xz) = 410144
+TIMESTAMP = 1674589548
+SHA256 (pciutils-3.9.0.tar.xz) = cdea7ae97239dee23249a09c68a19a287a3f109fbeb2c232ebb616cb38599012
+SIZE (pciutils-3.9.0.tar.xz) = 431624
diff --git a/sysutils/pciutils/files/patch-Makefile b/sysutils/pciutils/files/patch-Makefile
index f79f116c98cf..d6c4eaff5e3b 100644
--- a/sysutils/pciutils/files/patch-Makefile
+++ b/sysutils/pciutils/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig 2022-04-18 16:47:28 UTC
+--- Makefile.orig 2022-11-20 11:58:03 UTC
+++ Makefile
@@ -1,8 +1,8 @@
# Makefile for The PCI Utilities
@@ -9,10 +9,10 @@
+#OPT=-O2
+CFLAGS+=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
- VERSION=3.8.0
- DATE=2022-04-18
+ VERSION=3.9.0
+ DATE=2022-11-20
@@ -32,11 +32,11 @@ HWDB=
- ABI_VERSION=.3
+ ABI_VERSION=3
# Installation directories
-PREFIX=/usr/local
@@ -41,32 +41,32 @@
+#endif
AR=$(CROSS_COMPILE)ar
RANLIB=$(CROSS_COMPILE)ranlib
-
-@@ -64,7 +64,7 @@ PCIINC_INS=lib/config.h lib/header.h lib/pci.h lib/typ
+ DLLTOOL=$(CROSS_COMPILE)dlltool
+@@ -66,7 +66,7 @@ PCIINC_INS=lib/config.h lib/header.h lib/pci.h lib/typ
export
--all: lib/$(PCILIB) lspci$(EXEEXT) setpci$(EXEEXT) example$(EXEEXT) lspci.8 setpci.8 pcilib.7 pci.ids.5 update-pciids update-pciids.8 $(PCI_IDS)
+-all: lib/$(PCIIMPLIB) lspci$(EXEEXT) setpci$(EXEEXT) example$(EXEEXT) lspci.8 setpci.8 pcilib.7 pci.ids.5 update-pciids update-pciids.8 $(PCI_IDS)
+all: lspci$(EXEEXT) setpci$(EXEEXT) example$(EXEEXT) lspci.8 setpci.8 pcilib.7 pci.ids.5 update-pciids update-pciids.8 $(PCI_IDS)
- lib/$(PCILIB): $(PCIINC) force
+ lib/$(PCIIMPLIB): $(PCIINC) force
$(MAKE) -C lib all
-@@ -80,8 +80,8 @@ PCIINC+=compat/getopt.h
+@@ -82,8 +82,8 @@ PCIINC+=compat/getopt.h
COMMON+=compat/getopt.o
endif
--lspci$(EXEEXT): lspci.o ls-vpd.o ls-caps.o ls-caps-vendor.o ls-ecaps.o ls-kernel.o ls-tree.o ls-map.o $(COMMON) lib/$(PCILIB)
--setpci$(EXEEXT): setpci.o $(COMMON) lib/$(PCILIB)
+-lspci$(EXEEXT): lspci.o ls-vpd.o ls-caps.o ls-caps-vendor.o ls-ecaps.o ls-kernel.o ls-tree.o ls-map.o $(COMMON) lib/$(PCIIMPLIB)
+-setpci$(EXEEXT): setpci.o $(COMMON) lib/$(PCIIMPLIB)
+lspci$(EXEEXT): lspci.o ls-vpd.o ls-caps.o ls-caps-vendor.o ls-ecaps.o ls-kernel.o ls-tree.o ls-map.o $(COMMON)
+setpci$(EXEEXT): setpci.o $(COMMON)
LSPCIINC=lspci.h pciutils.h $(PCIINC)
lspci.o: lspci.c $(LSPCIINC)
-@@ -104,7 +104,7 @@ update-pciids: update-pciids.sh
+@@ -106,7 +106,7 @@ update-pciids: update-pciids.sh
chmod +x $@
# The example of use of libpci
--example$(EXEEXT): example.o lib/$(PCILIB)
+-example$(EXEEXT): example.o lib/$(PCIIMPLIB)
+example$(EXEEXT): example.o
example.o: example.c $(PCIINC)