aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel M. Dutra <0xdutra@gmail.com>2022-10-25 12:44:35 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2022-10-25 12:44:35 +0000
commitb51ff9a37129553bb88941cdad4d6ac532157e0d (patch)
tree7493c2f1dd57722a05e8ef23f289f678b30500dc
parent2bceb891dc80c66b69d3a2a5a51ba8819bf04d2c (diff)
downloadports-b51ff9a37129553bb88941cdad4d6ac532157e0d.tar.gz
ports-b51ff9a37129553bb88941cdad4d6ac532157e0d.zip
Add dns/dnsx: Fast and multi-purpose DNS toolkit
PR: 266560
-rw-r--r--dns/Makefile1
-rw-r--r--dns/dnsx/Makefile19
-rw-r--r--dns/dnsx/distinfo5
-rw-r--r--dns/dnsx/pkg-descr12
4 files changed, 37 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 12275ac3f517..02ebdd61c6df 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -60,6 +60,7 @@
SUBDIR += dnsviz
SUBDIR += dnswalk
SUBDIR += dnswall
+ SUBDIR += dnsx
SUBDIR += doc
SUBDIR += dog
SUBDIR += doggo
diff --git a/dns/dnsx/Makefile b/dns/dnsx/Makefile
new file mode 100644
index 000000000000..3db9acb1993b
--- /dev/null
+++ b/dns/dnsx/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= dnsx
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.0
+CATEGORIES= dns
+
+MAINTAINER= 0xdutra@gmail.com
+COMMENT= DNS toolkit allow to run multiple DNS queries
+WWW= https://github.com/projectdiscovery/dnsx
+
+LICENSE= MIT
+
+USES= go:modules
+
+GO_MODULE= github.com/projectdiscovery/dnsx
+GO_TARGET= ./cmd/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/dns/dnsx/distinfo b/dns/dnsx/distinfo
new file mode 100644
index 000000000000..56f9e4626055
--- /dev/null
+++ b/dns/dnsx/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1663905508
+SHA256 (go/dns_dnsx/dnsx-v1.1.0/v1.1.0.mod) = 4f1059d6bdbb1de8606b1c902b858bf193cdfbe43c02da48848cb207f5736856
+SIZE (go/dns_dnsx/dnsx-v1.1.0/v1.1.0.mod) = 3335
+SHA256 (go/dns_dnsx/dnsx-v1.1.0/v1.1.0.zip) = 9df02f336c1ab9ff5d316c6cd41808000382ca55c5638bd03834e814b73d329d
+SIZE (go/dns_dnsx/dnsx-v1.1.0/v1.1.0.zip) = 320085
diff --git a/dns/dnsx/pkg-descr b/dns/dnsx/pkg-descr
new file mode 100644
index 000000000000..fa809152b30d
--- /dev/null
+++ b/dns/dnsx/pkg-descr
@@ -0,0 +1,12 @@
+Fast and multi-purpose DNS toolkit allow to run multiple DNS queries.
+
+Features
+ - Query DNS records
+ - Brute force
+ - Custom resolver
+ - Multiple resolver format
+ - TCP
+ - UDP
+ - DOH
+ - DOT
+ - Automatic wildcard handling