aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-10 05:09:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-10 05:09:49 +0000
commitb58dfa33fe113d78eb62c5da0046d77208828c72 (patch)
treed39b18ce42b1dc493b157d49aa3fb807f55ae947
parent78b9f6f5489c68124a10bd02083cfb74fd7c42c1 (diff)
downloadports-b58dfa33fe113d78eb62c5da0046d77208828c72.tar.gz
ports-b58dfa33fe113d78eb62c5da0046d77208828c72.zip
devel/py-ubelt: Fix tests
-rw-r--r--devel/py-ubelt/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/py-ubelt/Makefile b/devel/py-ubelt/Makefile
index 4824c16b2352..7e41c3fbdf5d 100644
--- a/devel/py-ubelt/Makefile
+++ b/devel/py-ubelt/Makefile
@@ -16,14 +16,17 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}codecov>=2.0.15:devel/py-codecov@${PY_FLAVO
${PYTHON_PKGNAMEPREFIX}coverage>0:devel/py-coverage@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.25.1:www/py-requests@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}xdoctest>=0.14.0:devel/py-xdoctest@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}xdoctest>=0.14.0:devel/py-xdoctest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xxhash>0:devel/py-xxhash@${PY_FLAVOR}
USES= python:3.6+
-USE_PYTHON= distutils autoplist pytest # 23 errors in tests, see https://github.com/Erotemic/ubelt/issues/127
+USE_PYTHON= distutils autoplist pytest
USE_GITHUB= yes
GH_ACCOUNT= Erotemic
NO_ARCH= yes
+BINARY_ALIAS= python=${PYTHON_CMD}
+
.include <bsd.port.mk>