aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2023-02-01 19:03:51 +0000
committerDiane Bruce <db@FreeBSD.org>2023-02-01 19:11:59 +0000
commitb5b05cceac3ee4022d4dc84db5e7ad6ad82354d9 (patch)
tree523e94fef66c5dab0833cdf727b8fd5e08c27c75
parent17e9a151d83c0b278657d275de34bfc7a780289d (diff)
downloadports-b5b05cceac3ee4022d4dc84db5e7ad6ad82354d9.tar.gz
ports-b5b05cceac3ee4022d4dc84db5e7ad6ad82354d9.zip
comms/xnec2c: Updated to the v4. series (latest)
- Moved distribution site to documented dedicated server - added LICENSE_FILE - Petted portlint Change log is very extensive since this is a major update. Check xnec2c.html for more .. on 4.4.12: This release has been pending for a while, there are quite a few changes. I thought about making this 4.5 but not yet since these are mostly maintenance items, with a few new features as well: * UI Features: + Added "File->Save-as CSV" in the Frequency Plots window + Added optimizer output config checkboxes for csv, s1p, and/or s2p. Now you can auto-generate .csv, .s1p, or .s2p files when the input .NEC file is modified by an external program. + Pre-processed CSV data for each example .NEC file and placed them in examples/data/. You can view these with any spreadsheet program and graph columns as you like; the data is useful for regression testing, too. + Updated optimization documentation. * Console Features: + Refactored console output based on output priority levels. Console output is now color coded and output level can be controlled with -v and -d options. See --help for details. + Add batch mode (-b) commandline flag. + Added commandline options --write-csv, --write-s1p, --write-s2p-max-gain, and --write-s2p-viewer-gain for use with --batch and the optimizer. ... See xnec2c.html s Please enter the commit message for your changes. Lines starting
-rw-r--r--comms/xnec2c/Makefile38
-rw-r--r--comms/xnec2c/distinfo5
-rw-r--r--comms/xnec2c/files/clog.c46
-rw-r--r--comms/xnec2c/files/patch-src_common.h10
-rw-r--r--comms/xnec2c/files/patch-src_somnec.c12
-rw-r--r--comms/xnec2c/pkg-plist178
6 files changed, 183 insertions, 106 deletions
diff --git a/comms/xnec2c/Makefile b/comms/xnec2c/Makefile
index 02a9ac5b8bca..db344c13d7a0 100644
--- a/comms/xnec2c/Makefile
+++ b/comms/xnec2c/Makefile
@@ -1,41 +1,23 @@
PORTNAME= xnec2c
-PORTVERSION= 3.4
+PORTVERSION= 4.4.12
+DISTVERSIONPREFIX= v
CATEGORIES= comms hamradio
-MASTER_SITES= http://www.qsl.net/5b4az/pkg/nec2/xnec2c/ \
- LOCAL/shurd
+MASTER_SITES= https://www.xnec2c.org/releases/ \
+ LOCAL/db
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Used to calculate antenna patterns useful to ham radio
WWW= https://www.qsl.net/5b4az/
-LICENSE= GPLv2
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libccm.so:math/ccmath
+USES= autoreconf desktop-file-utils gettext gmake gnome pkgconfig shared-mime-info
GNU_CONFIGURE= yes
-USES= gettext gmake gnome pkgconfig tar:bzip2
-USE_GNOME= gtk20 intltool
+CONFIGURE_ENV+= LIBS=-lexecinfo
+CONFIGURE_ENV+= LDFLAGS="-L/${LOCALBASE}/lib ${LDFLAGS}"
-OPTIONS_DEFINE= DOCS
-OPTIONS_SUB= yes
-
-BROKEN_sparc64= Fails to link: relocation truncated to fit: R_SPARC_GOT13 against symbol input_fp
-
-post-extract:
- ${CP} ${PATCHDIR}/clog.c ${WRKSRC}/src
- ${TOUCH} ${WRKSRC}/src/cexp.c
- ${TOUCH} ${WRKSRC}/src/cexp.h
-
-post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/xnec2c.html ${STAGEDIR}${DOCSDIR}/xnec2c.html
- ${MKDIR} ${STAGEDIR}${DOCSDIR}/images
- ${INSTALL_DATA} ${WRKSRC}/doc/images/charges.png ${STAGEDIR}${DOCSDIR}/images/charges.png
- ${INSTALL_DATA} ${WRKSRC}/doc/images/currents.png ${STAGEDIR}${DOCSDIR}/images/currents.png
- ${INSTALL_DATA} ${WRKSRC}/doc/images/excitation.png ${STAGEDIR}${DOCSDIR}/images/excitation.png
- ${INSTALL_DATA} ${WRKSRC}/doc/images/freq_plots.png ${STAGEDIR}${DOCSDIR}/images/freq_plots.png
- ${INSTALL_DATA} ${WRKSRC}/doc/images/nec2_edit.png ${STAGEDIR}${DOCSDIR}/images/nec2_edit.png
- ${INSTALL_DATA} ${WRKSRC}/doc/images/radiation.png ${STAGEDIR}${DOCSDIR}/images/radiation.png
- ${INSTALL_DATA} ${WRKSRC}/doc/images/wire.png ${STAGEDIR}${DOCSDIR}/images/wire.png
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 intltool
.include <bsd.port.mk>
diff --git a/comms/xnec2c/distinfo b/comms/xnec2c/distinfo
index 7ba5660f8781..c79d25de4ec9 100644
--- a/comms/xnec2c/distinfo
+++ b/comms/xnec2c/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xnec2c-3.4.tar.bz2) = 92f25ee844d58109f99839854afacc14c37f4fdbc79f9d00c3a6c5f56248e537
-SIZE (xnec2c-3.4.tar.bz2) = 922548
+TIMESTAMP = 1675124025
+SHA256 (xnec2c-v4.4.12.tar.gz) = e98af1e8b9098df9cc03f90950358b846cc6a2965e79c0114ab711fbe51272c5
+SIZE (xnec2c-v4.4.12.tar.gz) = 1496988
diff --git a/comms/xnec2c/files/clog.c b/comms/xnec2c/files/clog.c
deleted file mode 100644
index c097ca1b8a4f..000000000000
--- a/comms/xnec2c/files/clog.c
+++ /dev/null
@@ -1,46 +0,0 @@
-/* $NetBSD: clog.c,v 1.1 2007/08/20 16:01:35 drochner Exp $ */
-
-/*-
- * Copyright (c) 2007 The NetBSD Foundation, Inc.
- * All rights reserved.
- *
- * This code is derived from software written by Stephen L. Moshier.
- * It is redistributed by the NetBSD Foundation by permission of the author.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- *
- * THIS SOFTWARE IS PROVIDED BY THE NETBSD FOUNDATION, INC. AND CONTRIBUTORS
- * ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
- * TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE FOUNDATION OR CONTRIBUTORS
- * BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
- * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
- * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
- * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
- * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
- * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
-#include <complex.h>
-#include <math.h>
-
-double complex
-clog(double complex z)
-{
- double complex w;
- double p, rr;
-
- rr = cabs(z);
- p = log(rr);
- rr = atan2(cimag(z), creal(z));
- w = p + rr * I;
- return w;
-}
diff --git a/comms/xnec2c/files/patch-src_common.h b/comms/xnec2c/files/patch-src_common.h
deleted file mode 100644
index 51c74d4a2ed6..000000000000
--- a/comms/xnec2c/files/patch-src_common.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/common.h.orig 2015-04-10 07:22:25 UTC
-+++ src/common.h
-@@ -37,6 +37,7 @@
- #include <sys/types.h>
- #include <sys/times.h>
- #include <gtk/gtk.h>
-+#include "cexp.h"
-
- /* commonly used complex constants */
- #define CPLX_00 (0.0+I*0.0)
diff --git a/comms/xnec2c/files/patch-src_somnec.c b/comms/xnec2c/files/patch-src_somnec.c
deleted file mode 100644
index 5e85079daa7c..000000000000
--- a/comms/xnec2c/files/patch-src_somnec.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/somnec.c.orig 2015-02-18 05:31:10 UTC
-+++ src/somnec.c
-@@ -38,6 +38,9 @@
- #include "somnec.h"
- #include "shared.h"
-
-+#include "clog.c"
-+#include "cexp.c"
-+
- /* common /evlcom/ */
- static int jh;
- static double ck2, ck2sq, tkmag, tsmag, ck1r, zph, rho;
diff --git a/comms/xnec2c/pkg-plist b/comms/xnec2c/pkg-plist
index 288ac4eb3e27..a7a9abdd0117 100644
--- a/comms/xnec2c/pkg-plist
+++ b/comms/xnec2c/pkg-plist
@@ -1,9 +1,171 @@
bin/xnec2c
-%%DOCS%%%%DOCSDIR%%/xnec2c.html
-%%DOCS%%%%DOCSDIR%%/images/charges.png
-%%DOCS%%%%DOCSDIR%%/images/currents.png
-%%DOCS%%%%DOCSDIR%%/images/excitation.png
-%%DOCS%%%%DOCSDIR%%/images/freq_plots.png
-%%DOCS%%%%DOCSDIR%%/images/nec2_edit.png
-%%DOCS%%%%DOCSDIR%%/images/radiation.png
-%%DOCS%%%%DOCSDIR%%/images/wire.png
+man/man1/xnec2c.1.gz
+share/applications/xnec2c.desktop
+%%DOCSDIR%%/NEC2-bug.txt
+%%DOCSDIR%%/NearFieldCalcs.txt
+%%DOCSDIR%%/images/currents.png
+%%DOCSDIR%%/images/excitation.png
+%%DOCSDIR%%/images/freq_plots.png
+%%DOCSDIR%%/images/nec2_edit.png
+%%DOCSDIR%%/images/radiation.png
+%%DOCSDIR%%/images/web-heading.png
+%%DOCSDIR%%/images/web-heading.xcf
+%%DOCSDIR%%/images/wire.png
+%%DOCSDIR%%/nec2c.txt
+%%DOCSDIR%%/xnec2c.html
+share/icons/hicolor/256x256/apps/xnec2c.png
+share/mime/packages/x-nec2.xml
+share/pixmaps/xnec2c.svg
+%%DATADIR%%/examples/10-20m-moxon.nec
+%%DATADIR%%/examples/10-30m-box.nec
+%%DATADIR%%/examples/10-30m_MultiBand_Vertical.nec
+%%DATADIR%%/examples/10-30m_bipyramid.nec
+%%DATADIR%%/examples/10-30m_inv_cone.nec
+%%DATADIR%%/examples/10-30m_sphere.nec
+%%DATADIR%%/examples/10-40m_windom.nec
+%%DATADIR%%/examples/10-80m_Classic_Windom-optimized.nec
+%%DATADIR%%/examples/10-80m_G5RV.nec
+%%DATADIR%%/examples/10-80m_Inverted-L.nec
+%%DATADIR%%/examples/10-80m_windom.nec
+%%DATADIR%%/examples/137MHz_broadside_Yagi.nec
+%%DATADIR%%/examples/137MHz_turnstile.nec
+%%DATADIR%%/examples/137MHz_turnstile_sloped.nec
+%%DATADIR%%/examples/137Mhz-QFHA1.nec
+%%DATADIR%%/examples/137Mhz-QFHA2.nec
+%%DATADIR%%/examples/137Mhz-QFHA3.nec
+%%DATADIR%%/examples/137Mhz_xpol_omni.nec
+%%DATADIR%%/examples/13cm_Yagi.nec
+%%DATADIR%%/examples/13cm_corner_reflector.nec
+%%DATADIR%%/examples/13cm_helix+screen.nec
+%%DATADIR%%/examples/15m_delta-loop.nec
+%%DATADIR%%/examples/1MHz_3x_helicone.nec
+%%DATADIR%%/examples/1MHz_3x_helisphere.nec
+%%DATADIR%%/examples/1MHz_4x_helisphere.nec
+%%DATADIR%%/examples/1MHz_helivert.nec
+%%DATADIR%%/examples/1MHz_tower.nec
+%%DATADIR%%/examples/20-40m_ground_plane.nec
+%%DATADIR%%/examples/20-40m_vert_circ_cliff.nec
+%%DATADIR%%/examples/20-40m_vert_linear_cliff.nec
+%%DATADIR%%/examples/20-40m_vert_sommerfeld_cliff.nec
+%%DATADIR%%/examples/20m_car_ant.nec
+%%DATADIR%%/examples/20m_quad.nec
+%%DATADIR%%/examples/23cm_helix+radials.nec
+%%DATADIR%%/examples/23cm_helix+screen.nec
+%%DATADIR%%/examples/2m_1to4l-gp_on_pole.nec
+%%DATADIR%%/examples/2m_1to4l-horiz_gp_on_pole.nec
+%%DATADIR%%/examples/2m_5to8l-gp_on_pole.nec
+%%DATADIR%%/examples/2m_EME_ant.nec
+%%DATADIR%%/examples/2m_Lindenblad.nec
+%%DATADIR%%/examples/2m_bigwheel.nec
+%%DATADIR%%/examples/2m_extended_Xpol_yagi-2-optimized.nec
+%%DATADIR%%/examples/2m_extended_Xpol_yagi-2.nec
+%%DATADIR%%/examples/2m_extended_Xpol_yagi.nec
+%%DATADIR%%/examples/2m_extended_yagi-optimized.nec
+%%DATADIR%%/examples/2m_extended_yagi.nec
+%%DATADIR%%/examples/2m_halo_stack.nec
+%%DATADIR%%/examples/2m_sqr_halo.nec
+%%DATADIR%%/examples/2m_sqr_halo_stack.nec
+%%DATADIR%%/examples/2m_xpol_omni.nec
+%%DATADIR%%/examples/2m_xpol_omni_stack.nec
+%%DATADIR%%/examples/2m_yagi.nec
+%%DATADIR%%/examples/2m_yagi_stack.nec
+%%DATADIR%%/examples/30-80m_inv_L.nec
+%%DATADIR%%/examples/35-55MHz_logper.nec
+%%DATADIR%%/examples/40-80m_Inv_L.nec
+%%DATADIR%%/examples/40m-moxon.nec
+%%DATADIR%%/examples/6-17m_bipyramid.nec
+%%DATADIR%%/examples/6-20m_fan.nec
+%%DATADIR%%/examples/6-20m_inv_cone.nec
+%%DATADIR%%/examples/6-40m_5B4AZ-optimized.nec
+%%DATADIR%%/examples/6-40m_Classic_Windom-optimized.nec
+%%DATADIR%%/examples/6m_big-square_stack.nec
+%%DATADIR%%/examples/6m_bigwheel-stack.nec
+%%DATADIR%%/examples/6m_horizomni.nec
+%%DATADIR%%/examples/70cm_collinear.nec
+%%DATADIR%%/examples/80m_zepp.nec
+%%DATADIR%%/examples/T12m-H24m.nec
+%%DATADIR%%/examples/T20m-H18m.nec
+%%DATADIR%%/examples/airplane.nec
+%%DATADIR%%/examples/buoy.nec
+%%DATADIR%%/examples/conductivity.txt
+%%DATADIR%%/examples/data/10-20m-moxon.csv
+%%DATADIR%%/examples/data/10-30m-box.csv
+%%DATADIR%%/examples/data/10-30m_MultiBand_Vertical.csv
+%%DATADIR%%/examples/data/10-30m_bipyramid.csv
+%%DATADIR%%/examples/data/10-30m_inv_cone.csv
+%%DATADIR%%/examples/data/10-30m_sphere.csv
+%%DATADIR%%/examples/data/10-40m_windom.csv
+%%DATADIR%%/examples/data/10-80m_Classic_Windom-optimized.csv
+%%DATADIR%%/examples/data/10-80m_G5RV.csv
+%%DATADIR%%/examples/data/10-80m_Inverted-L.csv
+%%DATADIR%%/examples/data/10-80m_windom.csv
+%%DATADIR%%/examples/data/137MHz_broadside_Yagi.csv
+%%DATADIR%%/examples/data/137MHz_turnstile.csv
+%%DATADIR%%/examples/data/137MHz_turnstile_sloped.csv
+%%DATADIR%%/examples/data/137Mhz-QFHA1.csv
+%%DATADIR%%/examples/data/137Mhz-QFHA2.csv
+%%DATADIR%%/examples/data/137Mhz-QFHA3.csv
+%%DATADIR%%/examples/data/137Mhz_xpol_omni.csv
+%%DATADIR%%/examples/data/13cm_Yagi.csv
+%%DATADIR%%/examples/data/13cm_corner_reflector.csv
+%%DATADIR%%/examples/data/13cm_helix+screen.csv
+%%DATADIR%%/examples/data/15m_delta-loop.csv
+%%DATADIR%%/examples/data/1MHz_3x_helicone.csv
+%%DATADIR%%/examples/data/1MHz_3x_helisphere.csv
+%%DATADIR%%/examples/data/1MHz_4x_helisphere.csv
+%%DATADIR%%/examples/data/1MHz_helivert.csv
+%%DATADIR%%/examples/data/1MHz_tower.csv
+%%DATADIR%%/examples/data/20-40m_ground_plane.csv
+%%DATADIR%%/examples/data/20-40m_vert_circ_cliff.csv
+%%DATADIR%%/examples/data/20-40m_vert_linear_cliff.csv
+%%DATADIR%%/examples/data/20-40m_vert_sommerfeld_cliff.csv
+%%DATADIR%%/examples/data/20m_car_ant.csv
+%%DATADIR%%/examples/data/20m_quad.csv
+%%DATADIR%%/examples/data/23cm_helix+radials.csv
+%%DATADIR%%/examples/data/23cm_helix+screen.csv
+%%DATADIR%%/examples/data/2m_1to4l-gp_on_pole.csv
+%%DATADIR%%/examples/data/2m_1to4l-horiz_gp_on_pole.csv
+%%DATADIR%%/examples/data/2m_5to8l-gp_on_pole.csv
+%%DATADIR%%/examples/data/2m_EME_ant.csv
+%%DATADIR%%/examples/data/2m_Lindenblad.csv
+%%DATADIR%%/examples/data/2m_bigwheel.csv
+%%DATADIR%%/examples/data/2m_extended_Xpol_yagi-2-optimized.csv
+%%DATADIR%%/examples/data/2m_extended_Xpol_yagi-2.csv
+%%DATADIR%%/examples/data/2m_extended_Xpol_yagi.csv
+%%DATADIR%%/examples/data/2m_extended_yagi-optimized.csv
+%%DATADIR%%/examples/data/2m_extended_yagi.csv
+%%DATADIR%%/examples/data/2m_halo_stack.csv
+%%DATADIR%%/examples/data/2m_sqr_halo.csv
+%%DATADIR%%/examples/data/2m_sqr_halo_stack.csv
+%%DATADIR%%/examples/data/2m_xpol_omni.csv
+%%DATADIR%%/examples/data/2m_xpol_omni_stack.csv
+%%DATADIR%%/examples/data/2m_yagi.csv
+%%DATADIR%%/examples/data/2m_yagi_stack.csv
+%%DATADIR%%/examples/data/30-80m_inv_L.csv
+%%DATADIR%%/examples/data/35-55MHz_logper.csv
+%%DATADIR%%/examples/data/40-80m_Inv_L.csv
+%%DATADIR%%/examples/data/40m-moxon.csv
+%%DATADIR%%/examples/data/6-17m_bipyramid.csv
+%%DATADIR%%/examples/data/6-20m_fan.csv
+%%DATADIR%%/examples/data/6-20m_inv_cone.csv
+%%DATADIR%%/examples/data/6-40m_5B4AZ-optimized.csv
+%%DATADIR%%/examples/data/6-40m_Classic_Windom-optimized.csv
+%%DATADIR%%/examples/data/6m_big-square_stack.csv
+%%DATADIR%%/examples/data/6m_bigwheel-stack.csv
+%%DATADIR%%/examples/data/6m_horizomni.csv
+%%DATADIR%%/examples/data/70cm_collinear.csv
+%%DATADIR%%/examples/data/80m_zepp.csv
+%%DATADIR%%/examples/data/README
+%%DATADIR%%/examples/data/T12m-H24m.csv
+%%DATADIR%%/examples/data/T20m-H18m.csv
+%%DATADIR%%/examples/data/airplane.csv
+%%DATADIR%%/examples/data/buoy.csv
+%%DATADIR%%/examples/data/gray_hoverman.csv
+%%DATADIR%%/examples/data/k9ay_5b4az.csv
+%%DATADIR%%/examples/data/k9ay_orig.csv
+%%DATADIR%%/examples/data/satellite.csv
+%%DATADIR%%/examples/gray_hoverman.nec
+%%DATADIR%%/examples/ground.txt
+%%DATADIR%%/examples/k9ay_5b4az.nec
+%%DATADIR%%/examples/k9ay_orig.nec
+%%DATADIR%%/examples/satellite.nec