aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-07 16:05:43 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-07 16:12:37 +0000
commitb5eca56f4857fa95f2fb5507e719cb2f5d199e94 (patch)
treea0592e7b7d50984b1fd895fb94d16b2a79bc7ad8
parenta8553376512c451b2be5b151e9fae10ad20d21ba (diff)
downloadports-b5eca56f4857fa95f2fb5507e719cb2f5d199e94.tar.gz
ports-b5eca56f4857fa95f2fb5507e719cb2f5d199e94.zip
net/linknx: Fix build with libesmtp 1.1.0
-rw-r--r--net/linknx/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/net/linknx/Makefile b/net/linknx/Makefile
index 904f955b11e5..df74aa5eeddc 100644
--- a/net/linknx/Makefile
+++ b/net/linknx/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libpthsem.so:devel/pthsem
BUILD_DEPENDS= ${LOCALBASE}/lib/libargp.a:devel/argp-standalone
USES= compiler gmake autoreconf pkgconfig
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=CFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-I${LOCALBASE}/include -L/${LOCALBASE}/lib"
@@ -32,6 +33,7 @@ LIBCURL_DESC= Install libcurl for Clickatell SMS support
LIBLUA_DESC= Install liblua for scripting
MYSQL_DESC= Install libmysql for logging & persist
+LIBESMTP_CFLAGS= -lesmtp
LIBESMTP_CONFIGURE_ENABLE= smtp
LIBESMTP_LIB_DEPENDS= libesmtp.so:mail/libesmtp
LIBCURL_CONFIGURE_WITH= libcurl