aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-03 19:56:28 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-03 19:59:25 +0000
commitb6810fa62f3973d253ad819c169421b26735319e (patch)
tree4360e089adc4e6d27dd79823be4747d72462306b
parent7dd87c3dc442b82c8b00277d384bceb671cb861a (diff)
downloadports-b6810fa62f3973d253ad819c169421b26735319e.tar.gz
ports-b6810fa62f3973d253ad819c169421b26735319e.zip
net/sniffit: Fix build with llvm15
- Pet portclippy - Adopt port
-rw-r--r--net/sniffit/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/net/sniffit/Makefile b/net/sniffit/Makefile
index 8cc42f587763..5c44a5560669 100644
--- a/net/sniffit/Makefile
+++ b/net/sniffit/Makefile
@@ -3,22 +3,27 @@ PORTVERSION= 0.5
DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= net security
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Packet sniffer program. For educational use
LICENSE= BSD4CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= autoreconf cpe
+CPE_VENDOR= sniffit_project
USE_GITHUB= yes
GH_ACCOUNT= resurrecting-open-source-projects
-CPE_VENDOR= sniffit_project
-
GNU_CONFIGURE= yes
OPTIONS_DEFINE= DOCS EXAMPLES
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/sniffit ${STAGEDIR}${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/man/sniffit.5 ${STAGEDIR}${MANPREFIX}/share/man/man5
@@ -35,4 +40,4 @@ do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/sample_config_file ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>