aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2023-02-03 19:12:49 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2023-02-04 09:10:55 +0000
commitb6a5871a0cf40dfc194217704e2dc03e2e91fb62 (patch)
tree0958b5fd915123345b05f53c6676049a13b10442
parent1e149b25f57d04feeb5dc05ef33bed2f251e12bf (diff)
downloadports-b6a5871a0cf40dfc194217704e2dc03e2e91fb62.tar.gz
ports-b6a5871a0cf40dfc194217704e2dc03e2e91fb62.zip
lang/gcc10: Mark PIE_UNSAFE
Building the port with WITH_PIE fails if the BOOTSTRAP option is enabled. Mark PIE_UNSAFE when this option is enabled until a better solution is found. PR: 268901 Reported by: netchild
-rw-r--r--lang/gcc10/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/gcc10/Makefile b/lang/gcc10/Makefile
index 19dbbea45882..7882aa8a0dc6 100644
--- a/lang/gcc10/Makefile
+++ b/lang/gcc10/Makefile
@@ -76,6 +76,7 @@ CONFIGURE_ARGS+=--disable-bootstrap
.else
CONFIGURE_ARGS+=--with-build-config=bootstrap-debug
ALL_TARGET= bootstrap-lean
+PIE_UNSAFE= yes
.endif
INSTALL_TARGET= install-strip
.if ${UID} != 0