aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-09-05 16:43:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-09-05 16:44:26 +0000
commitb6b86b72d51d37288fa3f2538d47235799caceaa (patch)
treeb30125201db04f5a370035aa7305a97154e49b51
parentf844a9c18223aecd744a5b9aac7de4f1f7950e8b (diff)
math/mfem: Add METIS option
-rw-r--r--math/mfem/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/math/mfem/Makefile b/math/mfem/Makefile
index 3a449d8f02e1..4cfc5261b956 100644
--- a/math/mfem/Makefile
+++ b/math/mfem/Makefile
@@ -1,7 +1,7 @@
PORTNAME= mfem
DISTVERSIONPREFIX= v
DISTVERSION= 4.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -17,10 +17,10 @@ USE_LDCONFIG= yes
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_TESTING_ON= MFEM_ENABLE_TESTING # tests are broken, see https://github.com/mfem/mfem/issues/3163
-OPTIONS_DEFINE= SUPERLU
+OPTIONS_DEFINE= METIS SUPERLU
OPTIONS_SINGLE= MPI
OPTIONS_SINGLE_MPI= NOMPI MPICH OPENMPI
-OPTIONS_DEFAULT= MPICH SUPERLU # should be the same MPI choice as in science/hypre
+OPTIONS_DEFAULT= METIS MPICH SUPERLU # should be the same MPI choice as in science/hypre
OPTIONS_SUB= yes
NOMPI_DESC= Build without parallel processing support
@@ -36,6 +36,10 @@ OPENMPI_CMAKE_ON= -DTPL_ENABLE_MPI=ON
OPENMPI_LIB_DEPENDS= libHYPRE.so:science/hypre \
libmetis.so:math/metis
+METIS_DESC= Build with metis
+METIS_CMAKE_BOOL= MFEM_USE_METIS
+METIS_LIB_DEPENDS= libmetis.so:math/metis
+
SUPERLU_DESC= Enable SuperLU use
SUPERLU_CMAKE_BOOL= MFEM_USE_SUPERLU
SUPERLU_CMAKE_ON= -DSuperLUDist_DIR=${LOCALBASE} -DSuperLUDist_INCLUDE_DIRS=${LOCALBASE}/include/superlu