aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-10 08:57:32 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-10 08:57:32 +0000
commitb70ef99d63bf2b11d93661f7dd993ac074613ec9 (patch)
tree29e0af12de6c17149f9bfe8fa50a861a753610d8
parentd7e77708f683490e407b555040d3f702e6fbe340 (diff)
downloadports-b70ef99d63bf2b11d93661f7dd993ac074613ec9.tar.gz
ports-b70ef99d63bf2b11d93661f7dd993ac074613ec9.zip
graphics/blender-lts28: fix build on non-x86
SSE is only available on amd64 and i386.
-rw-r--r--graphics/blender-lts28/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/graphics/blender-lts28/Makefile b/graphics/blender-lts28/Makefile
index 59707d181a42..ff05175dcb1b 100644
--- a/graphics/blender-lts28/Makefile
+++ b/graphics/blender-lts28/Makefile
@@ -160,6 +160,10 @@ CMAKE_ARGS+= -DWITH_GHOST_DEBUG:BOOL=ON
.include <bsd.port.options.mk>
+.if ${ARCH} != amd64 && ${ARCH} != i386
+CMAKE_ARGS+= -DWITH_CPU_SSE:BOOL=OFF
+.endif
+
.if ${LLVM_DEFAULT:M[678]0}
LLVM_VER= 90
.else