aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2024-09-30 15:56:09 +0000
committerBrooks Davis <brooks@FreeBSD.org>2024-09-30 22:11:21 +0000
commitb72e179346cd17b040878f629dc958d9cc8d893d (patch)
treea659baa1a188dac8f11e2db203f90813567388b9
parent62045188694fb84c5d59009ed2be1f5203654adb (diff)
downloadports-b72e179346cd17b040878f629dc958d9cc8d893d.tar.gz
ports-b72e179346cd17b040878f629dc958d9cc8d893d.zip
mail/fastforward: include errno.h for errno
errno must be accessed by a macro from errno.h.
-rw-r--r--mail/fastforward/Makefile2
-rw-r--r--mail/fastforward/files/patch-cdb__seek.c9
-rw-r--r--mail/fastforward/files/patch-error.h11
3 files changed, 21 insertions, 1 deletions
diff --git a/mail/fastforward/Makefile b/mail/fastforward/Makefile
index 337c28c266ef..c2e8842d3bbd 100644
--- a/mail/fastforward/Makefile
+++ b/mail/fastforward/Makefile
@@ -1,6 +1,6 @@
PORTNAME= fastforward
PORTVERSION= 0.51
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://cr.yp.to/software/
diff --git a/mail/fastforward/files/patch-cdb__seek.c b/mail/fastforward/files/patch-cdb__seek.c
new file mode 100644
index 000000000000..167a43dfcb3f
--- /dev/null
+++ b/mail/fastforward/files/patch-cdb__seek.c
@@ -0,0 +1,9 @@
+--- cdb_seek.c.orig
++++ cdb_seek.c
+@@ -1,6 +1,5 @@
+ #include <sys/types.h>
+ #include <errno.h>
+-extern int errno;
+ #include "cdb.h"
+
+ #ifndef SEEK_SET
diff --git a/mail/fastforward/files/patch-error.h b/mail/fastforward/files/patch-error.h
new file mode 100644
index 000000000000..e35ddb04802a
--- /dev/null
+++ b/mail/fastforward/files/patch-error.h
@@ -0,0 +1,11 @@
+--- error.h.orig
++++ error.h
+@@ -1,7 +1,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;