aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2022-08-11 12:57:35 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2022-08-11 12:57:35 +0000
commitb83466143ac2a78d6e28e4136aa54b631bf3b97d (patch)
treecff9f1806e1c3f6683fcd6164a8fbca5da8d2c0d
parentf515b0e657e7bd11d88725e9bc3cb1ccb3706baa (diff)
downloadports-b83466143ac2a78d6e28e4136aa54b631bf3b97d.tar.gz
ports-b83466143ac2a78d6e28e4136aa54b631bf3b97d.zip
lang/crystal: Update to 1.5.0
Changes: https://crystal-lang.org/2022/07/06/1.5.0-released.html PR: 265419 Approved by: greg@unrelenting.technology (maintaner)
-rw-r--r--lang/crystal/Makefile18
-rw-r--r--lang/crystal/distinfo6
-rw-r--r--lang/crystal/pkg-plist13
3 files changed, 28 insertions, 9 deletions
diff --git a/lang/crystal/Makefile b/lang/crystal/Makefile
index 09ce27b71d42..0c9150b137f0 100644
--- a/lang/crystal/Makefile
+++ b/lang/crystal/Makefile
@@ -1,5 +1,5 @@
PORTNAME= crystal
-DISTVERSION= 1.4.1
+DISTVERSION= 1.5.0
CATEGORIES= lang
MASTER_SITES= https://dl.unrelenting.technology/crystal/:bootstrap
DISTFILES= ${BOOTSTRAP_PATH}:bootstrap
@@ -39,6 +39,8 @@ MAKE_ARGS= SHELL=sh \
CRYSTAL_CACHE_DIR="${WRKDIR}/cache" \
CRYSTAL_CONFIG_VERSION="${DISTVERSION}"
+TEST_TARGET= spec
+
PORTDOCS= *
PORTEXAMPLES= *
@@ -70,7 +72,7 @@ post-extract:
post-patch:
.if ${SSL_DEFAULT} == "base" && ${OSREL:R} < 15
- @${REINPLACE_CMD} \
+ @${REINPLACE_CMD} -i '' \
-e 's|CRYSTAL_SSL_VERSION|1.1.1|g' \
-e 's|CRYSTAL_SSL_LDFLAGS|${OPENSSLLIB}|g' \
${WRKSRC}/src/openssl/lib_ssl.cr \
@@ -102,4 +104,16 @@ do-install-ZSH-on:
${INSTALL_DATA} ${INSTALL_WRKSRC}/etc/completion.zsh \
${STAGEDIR}${LOCALBASE}/share/zsh/site-functions/_crystal
+.if !defined(_CRYSTAL_MAKESUM_GUARD)
+makesum:
+ ${MAKE} -D_CRYSTAL_MAKESUM_GUARD makesum ARCH=${ONLY_FOR_ARCHS:O:[1]} DISTINFO_FILE=${DISTINFO_FILE}.tmp
+.for arch in ${ONLY_FOR_ARCHS:O:[2..-1]}
+ ${MAKE} -D_CRYSTAL_MAKESUM_GUARD makesum ARCH=${arch} DISTINFO_FILE=${DISTINFO_FILE}.${arch}
+ ${SED} 1d ${DISTINFO_FILE}.${arch} >> ${DISTINFO_FILE}.tmp
+ ${RM} ${DISTINFO_FILE}.${arch}
+.endfor
+ ${AWK} '!seen[$$0]++' ${DISTINFO_FILE}.tmp > ${DISTINFO_FILE}
+ ${RM} ${DISTINFO_FILE}.tmp
+.endif
+
.include <bsd.port.mk>
diff --git a/lang/crystal/distinfo b/lang/crystal/distinfo
index 18b7b9e190d5..fcc95891e7e3 100644
--- a/lang/crystal/distinfo
+++ b/lang/crystal/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1657281704
+TIMESTAMP = 1658681291
SHA256 (crystal/crystal-1.1.1-freebsd12-aarch64-llvm10) = 51433c9cff796da1423e2a6d77c87891cd7ba4cee37ef25322b2e801aba2b53b
SIZE (crystal/crystal-1.1.1-freebsd12-aarch64-llvm10) = 11093864
+SHA256 (crystal/crystal-lang-crystal-1.5.0_GH0.tar.gz) = f53e459ef6c7227df922a76fb62e350c90d52d30bfaa84b90feda9731bb98655
+SIZE (crystal/crystal-lang-crystal-1.5.0_GH0.tar.gz) = 2909586
SHA256 (crystal/crystal-1.1.1-freebsd12-amd64-llvm10) = bceb45f9d886cfbfac866761dcb954788156908d3a54e35f58c9e3f716cf91ed
SIZE (crystal/crystal-1.1.1-freebsd12-amd64-llvm10) = 11997032
-SHA256 (crystal/crystal-lang-crystal-1.4.1_GH0.tar.gz) = 97466656adede19943619e18af030c1d542c2c3dd1f36f3a422310bd8b53f5e0
-SIZE (crystal/crystal-lang-crystal-1.4.1_GH0.tar.gz) = 2880860
diff --git a/lang/crystal/pkg-plist b/lang/crystal/pkg-plist
index 495d726b5411..4b6db28dd2ef 100644
--- a/lang/crystal/pkg-plist
+++ b/lang/crystal/pkg-plist
@@ -80,6 +80,7 @@ lib/crystal/compiler/crystal/interpreter/c.cr
lib/crystal/compiler/crystal/interpreter/cast.cr
lib/crystal/compiler/crystal/interpreter/class_vars.cr
lib/crystal/compiler/crystal/interpreter/closure.cr
+lib/crystal/compiler/crystal/interpreter/closure_context.cr
lib/crystal/compiler/crystal/interpreter/compiled_block.cr
lib/crystal/compiler/crystal/interpreter/compiled_def.cr
lib/crystal/compiler/crystal/interpreter/compiled_instructions.cr
@@ -103,11 +104,13 @@ lib/crystal/compiler/crystal/interpreter/repl.cr
lib/crystal/compiler/crystal/interpreter/to_bool.cr
lib/crystal/compiler/crystal/interpreter/value.cr
lib/crystal/compiler/crystal/loader.cr
+lib/crystal/compiler/crystal/loader/msvc.cr
lib/crystal/compiler/crystal/loader/unix.cr
lib/crystal/compiler/crystal/macros.cr
lib/crystal/compiler/crystal/macros/interpreter.cr
lib/crystal/compiler/crystal/macros/macros.cr
lib/crystal/compiler/crystal/macros/methods.cr
+lib/crystal/compiler/crystal/macros/types.cr
lib/crystal/compiler/crystal/program.cr
lib/crystal/compiler/crystal/progress_tracker.cr
lib/crystal/compiler/crystal/semantic.cr
@@ -140,6 +143,7 @@ lib/crystal/compiler/crystal/semantic/normalizer.cr
lib/crystal/compiler/crystal/semantic/path_lookup.cr
lib/crystal/compiler/crystal/semantic/recursive_struct_checker.cr
lib/crystal/compiler/crystal/semantic/restrictions.cr
+lib/crystal/compiler/crystal/semantic/restrictions_augmenter.cr
lib/crystal/compiler/crystal/semantic/semantic_visitor.cr
lib/crystal/compiler/crystal/semantic/suggestions.cr
lib/crystal/compiler/crystal/semantic/to_s.cr
@@ -151,6 +155,7 @@ lib/crystal/compiler/crystal/semantic/type_guess_visitor.cr
lib/crystal/compiler/crystal/semantic/type_intersect.cr
lib/crystal/compiler/crystal/semantic/type_lookup.cr
lib/crystal/compiler/crystal/semantic/type_merge.cr
+lib/crystal/compiler/crystal/semantic/type_to_restriction.cr
lib/crystal/compiler/crystal/semantic/warnings.cr
lib/crystal/compiler/crystal/syntax.cr
lib/crystal/compiler/crystal/syntax/ast.cr
@@ -277,6 +282,7 @@ lib/crystal/crystal/compiler_rt/fixint.cr
lib/crystal/crystal/compiler_rt/float.cr
lib/crystal/crystal/compiler_rt/mul.cr
lib/crystal/crystal/compiler_rt/multi3.cr
+lib/crystal/crystal/compiler_rt/shift.cr
lib/crystal/crystal/datum.cr
lib/crystal/crystal/digest/md5.cr
lib/crystal/crystal/digest/sha1.cr
@@ -375,6 +381,7 @@ lib/crystal/crystal/system/win32/file.cr
lib/crystal/crystal/system/win32/file_descriptor.cr
lib/crystal/crystal/system/win32/file_info.cr
lib/crystal/crystal/system/win32/hostname.cr
+lib/crystal/crystal/system/win32/library_archive.cr
lib/crystal/crystal/system/win32/mime.cr
lib/crystal/crystal/system/win32/path.cr
lib/crystal/crystal/system/win32/process.cr
@@ -1089,6 +1096,7 @@ lib/crystal/llvm/builder.cr
lib/crystal/llvm/context.cr
lib/crystal/llvm/di_builder.cr
lib/crystal/llvm/enums.cr
+lib/crystal/llvm/enums/atomic.cr
lib/crystal/llvm/ext/find-llvm-config
lib/crystal/llvm/ext/llvm-versions.txt
lib/crystal/llvm/ext/llvm_ext.cc
@@ -1107,6 +1115,7 @@ lib/crystal/llvm/module.cr
lib/crystal/llvm/module_pass_manager.cr
lib/crystal/llvm/operand_bundle_def.cr
lib/crystal/llvm/parameter_collection.cr
+lib/crystal/llvm/pass_builder_options.cr
lib/crystal/llvm/pass_manager_builder.cr
lib/crystal/llvm/pass_registry.cr
lib/crystal/llvm/phi_table.cr
@@ -1171,11 +1180,7 @@ lib/crystal/openssl/digest.cr
lib/crystal/openssl/error.cr
lib/crystal/openssl/hmac.cr
lib/crystal/openssl/lib_crypto.cr
-lib/crystal/openssl/lib_crypto.cr.bak
-lib/crystal/openssl/lib_crypto.cr.orig
lib/crystal/openssl/lib_ssl.cr
-lib/crystal/openssl/lib_ssl.cr.bak
-lib/crystal/openssl/lib_ssl.cr.orig
lib/crystal/openssl/md5.cr
lib/crystal/openssl/pkcs5.cr
lib/crystal/openssl/sha1.cr