aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-11-18 15:56:11 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-11-18 19:08:14 +0000
commitb83bf6b6171c0083f646c6583489db8aa0a8ee4f (patch)
tree71a112e9eb843858ec542e3a84cb3dc33179a991
parent14fdc30e61ec01bd61743b19909e6b2db353f1fa (diff)
downloadports-b83bf6b6171c0083f646c6583489db8aa0a8ee4f.tar.gz
ports-b83bf6b6171c0083f646c6583489db8aa0a8ee4f.zip
graphics/py-openslide-python: New port: Python interface to OpenSlide library for reading virtual slide images
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-openslide-python/Makefile22
-rw-r--r--graphics/py-openslide-python/distinfo3
-rw-r--r--graphics/py-openslide-python/pkg-descr2
4 files changed, 28 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index f4519adf9ee2..f1ea55b13fbf 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -891,6 +891,7 @@
SUBDIR += py-opencolorio
SUBDIR += py-openimageio
SUBDIR += py-openshadinglanguage
+ SUBDIR += py-openslide-python
SUBDIR += py-optimize-images
SUBDIR += py-osmnet
SUBDIR += py-pandana
diff --git a/graphics/py-openslide-python/Makefile b/graphics/py-openslide-python/Makefile
new file mode 100644
index 000000000000..19e1b5a9e4c7
--- /dev/null
+++ b/graphics/py-openslide-python/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= openslide-python
+DISTVERSION= 1.2.0
+CATEGORIES= graphics
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python interface to OpenSlide library for reading virtual slide images
+WWW= https://openslide.org/
+
+LICENSE= LGPL21
+
+RUN_DEPENDS= openslide>0:graphics/openslide \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= distutils autoplist
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/openslide/_convert${PYTHON_EXT_SUFFIX}.so
+
+.include <bsd.port.mk>
diff --git a/graphics/py-openslide-python/distinfo b/graphics/py-openslide-python/distinfo
new file mode 100644
index 000000000000..03d365b363a4
--- /dev/null
+++ b/graphics/py-openslide-python/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1668796736
+SHA256 (openslide-python-1.2.0.tar.gz) = f484f833566dbe5788d03d6dbab6fafeadabefa9de8d497715527d2c0cbd986e
+SIZE (openslide-python-1.2.0.tar.gz) = 338720
diff --git a/graphics/py-openslide-python/pkg-descr b/graphics/py-openslide-python/pkg-descr
new file mode 100644
index 000000000000..664afa029e51
--- /dev/null
+++ b/graphics/py-openslide-python/pkg-descr
@@ -0,0 +1,2 @@
+OpenSlide is a C library that provides a simple interface to read whole-slide
+images (also known as virtual slides).