aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-05-18 03:44:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-05-18 03:44:42 +0000
commitb850064dedbb50ee64e4398ceae4dd089046132d (patch)
tree1a285ad8b84400a50a198ec9d9c39b54463f5627
parent811f291eae631044b2919c6f3aa3a59c50bde639 (diff)
downloadports-b850064dedbb50ee64e4398ceae4dd089046132d.tar.gz
ports-b850064dedbb50ee64e4398ceae4dd089046132d.zip
New port: audio/wavetral: Convert between single cycle waveforms and audio spectra
-rw-r--r--audio/Makefile1
-rw-r--r--audio/wavetral/Makefile25
-rw-r--r--audio/wavetral/distinfo3
-rw-r--r--audio/wavetral/pkg-descr5
4 files changed, 34 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 423ba518e352..4575fc20d69b 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -828,6 +828,7 @@
SUBDIR += wavbreaker
SUBDIR += wavegain
SUBDIR += waveplay
+ SUBDIR += wavetral
SUBDIR += wavpack
SUBDIR += wavplay
SUBDIR += webrtc-audio-processing
diff --git a/audio/wavetral/Makefile b/audio/wavetral/Makefile
new file mode 100644
index 000000000000..b32babe147d5
--- /dev/null
+++ b/audio/wavetral/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= wavetral
+DISTVERSION= g20210517
+CATEGORIES= audio
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Convert between single cycle waveforms and audio spectra
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libboost_system.so:devel/boost-libs \
+ libfftw3.so:math/fftw3 \
+ libsamplerate.so:audio/libsamplerate \
+ libsndfile.so:audio/libsndfile
+
+USES= cmake compiler:c++11-lang localbase:ldflags pkgconfig
+
+USE_GITHUB= yes
+GH_ACCOUNT= jeanette-c
+GH_TAGNAME= 8e4f205
+
+PLIST_FILES= bin/wavetral \
+ man/man1/wavetral.1.gz
+
+.include <bsd.port.mk>
diff --git a/audio/wavetral/distinfo b/audio/wavetral/distinfo
new file mode 100644
index 000000000000..cb8a38ae336c
--- /dev/null
+++ b/audio/wavetral/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1621308760
+SHA256 (jeanette-c-wavetral-g20210517-8e4f205_GH0.tar.gz) = 779cb67cd837328172b998cdc8db8a0668854207e92b2b00b5431e0ec4942b7f
+SIZE (jeanette-c-wavetral-g20210517-8e4f205_GH0.tar.gz) = 36063
diff --git a/audio/wavetral/pkg-descr b/audio/wavetral/pkg-descr
new file mode 100644
index 000000000000..645869ce6534
--- /dev/null
+++ b/audio/wavetral/pkg-descr
@@ -0,0 +1,5 @@
+wavetral is a small program to convert single cycle waveforms to spectra and
+vice versa. It supports different input and output formats to export
+your waveforms/spectra from one synthesizer to another.
+
+WWW: https://github.com/jeanette-c/wavetral