aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Bowling <kbowling@FreeBSD.org>2024-07-23 16:29:21 +0000
committerKevin Bowling <kbowling@FreeBSD.org>2024-07-23 16:31:07 +0000
commitb86336fa4d39af5eb0a1f228a649ca4389e628dc (patch)
tree3091fc227142fd603b2907b22b430bdd78577777
parent4dc5db1a710adfd3933015d6b23a4fedb22c1e1c (diff)
downloadports-b86336fa4d39af5eb0a1f228a649ca4389e628dc.tar.gz
ports-b86336fa4d39af5eb0a1f228a649ca4389e628dc.zip
Mk/bsd.default-versions.mk: Update to PostgreSQL 16
See UPDATING for upgrade advice PR: 278885 Exp-run by: antoine
-rw-r--r--Mk/bsd.default-versions.mk2
-rw-r--r--UPDATING53
2 files changed, 54 insertions, 1 deletions
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index c86a911f095b..3c62ece4b8ce 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -127,7 +127,7 @@ _EXPORTED_VARS+= _PERL5_FROM_BIN
PERL5_DEFAULT:= ${_PERL5_FROM_BIN:R}
. endif
# Possible values: 12, 13, 14, 15, 16
-PGSQL_DEFAULT?= 15
+PGSQL_DEFAULT?= 16
# Possible values: 8.1, 8.2, 8.3
PHP_DEFAULT?= 8.2
# Possible values: rust, legacy
diff --git a/UPDATING b/UPDATING
index 82535af1a623..1cf96e29c93e 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,59 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20240723:
+ AFFECTS: users of databases/postgresql* and other software using PostgreSQL to run
+ AUTHOR: kbowling@FreeBSD.org
+
+ The default version of PostgreSQL has been switched from 15 to 16.
+ The upgrade procedure can use up twice the space the databases
+ currently needs. If you have a big amount of stored data take a
+ closer look at the manpage of pg_upgrade for avoidance and/or
+ speedup of the upgrade.
+
+ The upgrade instructions consider a basic usage and do not match
+ complex scenarios like replication, sharding, or similar.
+
+ Upgrade instructions:
+
+ First stop your PostgreSQL, create PostgreSQL-binaries and backup your data.
+ If you have another Version of PostgreSQL installed, for example 15, your
+ files are named according to this.
+
+ # service postgresql stop
+ # pkg create postgresql15-server postgresql15-contrib
+ # mkdir /tmp/pg-upgrade
+ # tar xf postgresql15-server-15.7.pkg -C /tmp/pg-upgrade
+ # tar xf postgresql15-contrib-15.7.pkg -C /tmp/pg-upgrade
+ # pkg delete -f databases/postgresql15-server databases/postgresql15-contrib databases/postgresql15-client
+
+ Now update PostgreSQL:
+
+ pkg user:
+ # pkg install databases/postgresql16-server databases/postgresql16-contrib
+ # pkg upgrade
+
+ Portmaster users:
+ # portmaster databases/postgresql16-server databases/postgresql16-contrib
+ # portmaster -a
+
+ Portupgrade users:
+ # portinstall databases/postgresql16-server databases/postgresql16-contrib
+ # portupgrade -a
+
+ After installing the new PostgreSQL version you need to convert
+ all your databases to new version:
+
+ # su -l postgres -c "/usr/local/bin/initdb --encoding=utf-8 --lc-collate=C -D /var/db/postgres/data16 -U postgres"
+ # su -l postgres -c "pg_upgrade -b /tmp/pg-upgrade/usr/local/bin/ -d /var/db/postgres/data15/ -B /usr/local/bin/ -D /var/db/postgres/data16/ -U postgres "
+
+ Now the migration is finished. You can start PostgreSQL again with:
+
+ # service postgresql start
+
+ ATTENTION:
+ 1) If you use non-default initdb options, you have to adjust the initdb-command accordingly
+
20240715:
AFFECTS: net-mgmt/netbox
AUTHOR: kai@FreeBSD.org