aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2024-08-27 20:52:59 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2024-08-27 20:52:59 +0000
commitb8bcf488e0d0f8ea7957538be0dc4146d178237f (patch)
tree4495d5ef60d759945b880e61e7d63dabcfcd910d
parent81dbda4eb540e449839268a83380be37bb58240f (diff)
net/netatalk3: Use iconv:wchar_t to fix build when DBUS is disabled
This mirrors what glib20 uses for iconv, and will ensure that we bring in converters/libiconv in all cases. Not bumping PORTREVISION as the dependency list doesn't change in the default case. PR: 281096
-rw-r--r--net/netatalk3/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index 44f1fc58ea3f..93a35679fef8 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libevent.so:devel/libevent
-USES= bdb:18 cpe gettext iconv meson perl5 pkgconfig shebangfix ssl tar:xz
+USES= bdb:18 cpe gettext iconv:wchar_t meson perl5 pkgconfig shebangfix ssl tar:xz
USE_LDCONFIG= yes
USE_RC_SUBR= netatalk
#INSTALL_TARGET=install-strip