aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2024-08-02 19:44:40 +0000
committerDimitry Andric <dim@FreeBSD.org>2024-08-02 22:00:50 +0000
commitb8c038829f6bf89110528e33889ef43b01f23e79 (patch)
treeb55dbe0adc15a80c1ec6b664420efa01a49bd861
parent4c6d856c838f3e5edffd0d3ed01983d924907799 (diff)
downloadports-b8c038829f6bf89110528e33889ef43b01f23e79.tar.gz
ports-b8c038829f6bf89110528e33889ef43b01f23e79.zip
devel/llvm15: fix build with libc++ 19
As noted in the libc++ 19 release notes [1], std::char_traits<> is now only provided for char, char8_t, char16_t, char32_t and wchar_t, and any instantiation for other types will fail. This causes devel/llvm15 to fail to compile with clang 19 and libc++ 19, resulting in errors similar to: /usr/include/c++/v1/string:820:42: error: implicit instantiation of undefined template 'std::char_traits<unsigned char>' 820 | static_assert(is_same<_CharT, typename traits_type::char_type>::value, | ^ /wrkdirs/usr/ports/devel/llvm15/work-default/llvm-project-15.0.7.src/lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunicationServerLLGS.cpp:638:34: note: in instantiation of template class 'std::basic_string<unsigned char>' requested here 638 | std::basic_string<uint8_t> zeros(reg_info.byte_size, '\0'); | ^ /usr/include/c++/v1/__fwd/string.h:23:29: note: template is declared here 23 | struct _LIBCPP_TEMPLATE_VIS char_traits; | ^ Upstream llvm has fixed this in commit 68744ffbdd7d [2], so add this as a PATCHFILES entry in the Makefile. [1] https://libcxx.llvm.org/ReleaseNotes/19.html#deprecations-and-removals [2] https://github.com/llvm/llvm-project/commit/68744ffbdd7d PR: 280579 Approved by: brooks (maintainer) MFH: 2024Q3
-rw-r--r--devel/llvm15/Makefile1
-rw-r--r--devel/llvm15/distinfo4
2 files changed, 4 insertions, 1 deletions
diff --git a/devel/llvm15/Makefile b/devel/llvm15/Makefile
index 900606601e2a..b75f500f4fc8 100644
--- a/devel/llvm15/Makefile
+++ b/devel/llvm15/Makefile
@@ -9,6 +9,7 @@ DISTNAME= llvm-project-${DISTVERSION}.src
DISTFILES= llvm-project-${DISTVERSION}.src${EXTRACT_SUFX}
PATCH_SITES= https://github.com/llvm/llvm-project/commit/
+PATCHFILES+= llvmorg-18-init-1760-g68744ffbdd7d.patch:-p1 # https://reviews.llvm.org/D157589
PATCHFILES+= llvmorg-18-init-15199-gb9935bb02a50.patch:-p1 # https://github.com/llvm/llvm-project/pull/75748
PATCHFILES+= llvmorg-18-init-15680-g966d564e43e6.patch:-p1 # https://github.com/llvm/llvm-project/pull/76185
diff --git a/devel/llvm15/distinfo b/devel/llvm15/distinfo
index 7abec8c5f61f..31cb67814ddc 100644
--- a/devel/llvm15/distinfo
+++ b/devel/llvm15/distinfo
@@ -1,6 +1,8 @@
-TIMESTAMP = 1673554510
+TIMESTAMP = 1722603701
SHA256 (llvm-project-15.0.7.src.tar.xz) = 8b5fcb24b4128cf04df1b0b9410ce8b1a729cb3c544e6da885d234280dedeac6
SIZE (llvm-project-15.0.7.src.tar.xz) = 110936452
+SHA256 (llvmorg-18-init-1760-g68744ffbdd7d.patch) = ad9ad1613491f69b010dbbd6a9d90d5dd505e46d9537a6e533f36dacd552d0f7
+SIZE (llvmorg-18-init-1760-g68744ffbdd7d.patch) = 1491
SHA256 (llvmorg-18-init-15199-gb9935bb02a50.patch) = b0805cba765084c7bef426fa1235dd887c61ae0c1fd5e3fad5c8742cdd6ee8b0
SIZE (llvmorg-18-init-15199-gb9935bb02a50.patch) = 1893
SHA256 (llvmorg-18-init-15680-g966d564e43e6.patch) = 3abf92d4a788ff2f74fa9fc627a113f04d9fb72cd7e47344a8c4dce06140a163