aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2024-03-28 13:53:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2024-04-04 15:01:51 +0000
commitb8fca5e2b82a34ee3ffdf3188b3b8469f186ee57 (patch)
treeb2966e42f6ff3cb5208b24ca3e7e5741e1d50a65
parentd2b99e1559a296779203971637bfa64a2017e6a7 (diff)
downloadports-b8fca5e2b82a34ee3ffdf3188b3b8469f186ee57.tar.gz
ports-b8fca5e2b82a34ee3ffdf3188b3b8469f186ee57.zip
games/warzone2100: update to 4.4.2
-rw-r--r--games/warzone2100/Makefile6
-rw-r--r--games/warzone2100/distinfo6
-rw-r--r--games/warzone2100/files/patch-lib_ivis__opengl_gfx__api__vk.cpp67
-rw-r--r--games/warzone2100/pkg-plist2
4 files changed, 7 insertions, 74 deletions
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index 196eebaaf850..59fe7866a7b7 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -1,6 +1,5 @@
PORTNAME= warzone2100
-PORTVERSION= 4.3.5
-PORTREVISION= 1
+PORTVERSION= 4.4.2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/releases/${PORTVERSION}/
DISTNAME= ${PORTNAME}_src
@@ -39,7 +38,8 @@ CMAKE_ARGS= -DWZ_DISTRIBUTOR="FreeBSD ports" \
-DCMAKE_DISABLE_FIND_PACKAGE_Git=TRUE \
-DWZ_ENABLE_WARNINGS_AS_ERRORS=FALSE \
-DFETCHCONTENT_FULLY_DISCONNECTED=TRUE \
- -DWZ_FORCE_MINIMAL_OPUSFILE=FALSE
+ -DWZ_FORCE_MINIMAL_OPUSFILE=FALSE \
+ -DFMT_INSTALL=FALSE
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/games/warzone2100/distinfo b/games/warzone2100/distinfo
index 7dbaeda53f1a..ecf4080da796 100644
--- a/games/warzone2100/distinfo
+++ b/games/warzone2100/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1682348734
-SHA256 (warzone2100-4.3.5/warzone2100_src.tar.xz) = 01d608f6f9638e14d7c857df40ad339c1bfc207a05daafe7157ad8652a3405c3
-SIZE (warzone2100-4.3.5/warzone2100_src.tar.xz) = 320369492
+TIMESTAMP = 1709297464
+SHA256 (warzone2100-4.4.2/warzone2100_src.tar.xz) = 3b962ac6aa75bca62bf2ebc067549db08fe4a1c3b38342910a2ac2aaabcbacde
+SIZE (warzone2100-4.4.2/warzone2100_src.tar.xz) = 490182768
diff --git a/games/warzone2100/files/patch-lib_ivis__opengl_gfx__api__vk.cpp b/games/warzone2100/files/patch-lib_ivis__opengl_gfx__api__vk.cpp
deleted file mode 100644
index 66c1fc070497..000000000000
--- a/games/warzone2100/files/patch-lib_ivis__opengl_gfx__api__vk.cpp
+++ /dev/null
@@ -1,67 +0,0 @@
-lib/ivis_opengl/gfx_api_vk.cpp:524:3: error: no member named 'throwResultException' in namespace 'vk'; did you mean 'vk::detail::throwResultException'?
- vk::throwResultException( result, "vmaCreateBuffer" );
- ^~~~~~~~~~~~~~~~~~~~~~~~
- vk::detail::throwResultException
-/usr/local/include/vulkan/vulkan.hpp:6639:41: note: 'vk::detail::throwResultException' declared here
- [[noreturn]] VULKAN_HPP_INLINE void throwResultException( Result result, char const * message )
- ^
-lib/ivis_opengl/gfx_api_vk.cpp:1543:4: error: no member named 'throwResultException' in namespace 'vk'; did you mean 'vk::detail::throwResultException'?
- vk::throwResultException(result.result, "createGraphicsPipeline");
- ^~~~~~~~~~~~~~~~~~~~~~~~
- vk::detail::throwResultException
-/usr/local/include/vulkan/vulkan.hpp:6639:41: note: 'vk::detail::throwResultException' declared here
- [[noreturn]] VULKAN_HPP_INLINE void throwResultException( Result result, char const * message )
- ^
-lib/ivis_opengl/gfx_api_vk.cpp:1607:3: error: no member named 'throwResultException' in namespace 'vk'; did you mean 'vk::detail::throwResultException'?
- vk::throwResultException( result, "vmaCreateBuffer" );
- ^~~~~~~~~~~~~~~~~~~~~~~~
- vk::detail::throwResultException
-/usr/local/include/vulkan/vulkan.hpp:6639:41: note: 'vk::detail::throwResultException' declared here
- [[noreturn]] VULKAN_HPP_INLINE void throwResultException( Result result, char const * message )
- ^
-lib/ivis_opengl/gfx_api_vk.cpp:1740:3: error: no member named 'throwResultException' in namespace 'vk'; did you mean 'vk::detail::throwResultException'?
- vk::throwResultException( result, "vmaCreateImage" );
- ^~~~~~~~~~~~~~~~~~~~~~~~
- vk::detail::throwResultException
-/usr/local/include/vulkan/vulkan.hpp:6639:41: note: 'vk::detail::throwResultException' declared here
- [[noreturn]] VULKAN_HPP_INLINE void throwResultException( Result result, char const * message )
- ^
-
---- lib/ivis_opengl/gfx_api_vk.cpp.orig 2023-04-16 17:42:55 UTC
-+++ lib/ivis_opengl/gfx_api_vk.cpp
-@@ -521,7 +521,7 @@ void BlockBufferAllocator::allocateNewBlock(uint32_t m
- if (result != vk::Result::eSuccess)
- {
- // Failed to allocate memory!
-- vk::throwResultException( result, "vmaCreateBuffer" );
-+ vk::detail::throwResultException( result, "vmaCreateBuffer" );
- }
-
- if (autoMap)
-@@ -1540,7 +1540,7 @@ VkPSO::VkPSO(vk::Device _dev,
- object = std::move(result.value);
- break;
- default:
-- vk::throwResultException(result.result, "createGraphicsPipeline");
-+ vk::detail::throwResultException(result.result, "createGraphicsPipeline");
- }
- }
-
-@@ -1604,7 +1604,7 @@ void VkBuf::allocateBufferObject(const std::size_t& si
- if (result != vk::Result::eSuccess)
- {
- // Failed to allocate memory!
-- vk::throwResultException( result, "vmaCreateBuffer" );
-+ vk::detail::throwResultException( result, "vmaCreateBuffer" );
- }
-
- buffer_size = size;
-@@ -1737,7 +1737,7 @@ VkTexture::VkTexture(const VkRoot& root, const std::si
- if (result != vk::Result::eSuccess)
- {
- // Failed to allocate memory!
-- vk::throwResultException( result, "vmaCreateImage" );
-+ vk::detail::throwResultException( result, "vmaCreateImage" );
- }
-
- if (root.debugUtilsExtEnabled)
diff --git a/games/warzone2100/pkg-plist b/games/warzone2100/pkg-plist
index c7fdae80ca7d..56fa798c5cc6 100644
--- a/games/warzone2100/pkg-plist
+++ b/games/warzone2100/pkg-plist
@@ -44,4 +44,4 @@ share/icons/net.wz2100.warzone2100.png
%%NLS%%share/locale/uk_UA/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/warzone2100.mo
-share/metainfo/net.wz2100.warzone2100.appdata.xml
+share/metainfo/net.wz2100.warzone2100.metainfo.xml