aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2022-09-04 00:24:54 +0000
committerMatthias Andree <mandree@FreeBSD.org>2022-09-04 00:26:57 +0000
commitb8fd81efdd5021304bf957405a58490b7c105513 (patch)
treed6c0f20d038d5ec765a70ed2480651e750b13130
parent8d272748e51fb585073c625a31092a99daf05c15 (diff)
downloadports-b8fd81efdd5021304bf957405a58490b7c105513.tar.gz
ports-b8fd81efdd5021304bf957405a58490b7c105513.zip
news/newsstar: fix OpenSSL detection & cleanups
OpenSSL detection was broken because it looked for SSL_library_init(), which has been gone since OpenSSL 1.1.0 already. Patch to look for OPENSSL_init_ssl() instead. Replace @exec by @postexec. Add USES=ncurses. Rearrange Makefile to reduce complaints from portclippy and portlint.
-rw-r--r--news/newsstar/Makefile18
-rw-r--r--news/newsstar/pkg-plist6
2 files changed, 14 insertions, 10 deletions
diff --git a/news/newsstar/Makefile b/news/newsstar/Makefile
index 7b8617d84181..21c075cd3db7 100644
--- a/news/newsstar/Makefile
+++ b/news/newsstar/Makefile
@@ -1,6 +1,6 @@
PORTNAME= newsstar
PORTVERSION= 1.5.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= news
MASTER_SITES= SF
@@ -9,17 +9,17 @@ COMMENT= Transfer news between a local NNTP server (INN, sn, s-news)
LICENSE= GPLv3
-LIB_DEPENDS= libgdbm.so:databases/gdbm
BUILD_DEPENDS= xmlto:textproc/xmlto \
${LOCALBASE}/share/xml/docbook/4.5/docbookx.dtd:textproc/docbook-xml
+LIB_DEPENDS= libgdbm.so:databases/gdbm
-GNU_CONFIGURE= yes
-USES= iconv perl5 shebangfix
-SHEBANG_FILES= newsstar.in
+USES= iconv ncurses perl5 shebangfix
+IGNORE_SSL= libressl libressl-devel
+IGNORE_SSL_REASON=GPL linking exeption only provided for OpenSSL
-OPTIONS_DEFINE= SSL DOCS EXAMPLES
-OPTIONS_DEFAULT= SSL
+SHEBANG_FILES= newsstar.in
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--disable-chown \
--with-conf-dir=${PREFIX}/etc/newsstar \
--with-rc-dir=/var/spool/newsstar/lib \
@@ -28,6 +28,9 @@ CONFIGURE_ARGS+=--disable-chown \
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib ${ICONV_LIB}
+OPTIONS_DEFINE= DOCS EXAMPLES SSL
+OPTIONS_DEFAULT= SSL
+
.include <bsd.port.options.mk>
.if ! ${PORT_OPTIONS:MDOCS}
@@ -70,6 +73,7 @@ post-patch:
${REINPLACE_CMD} -e 's|/usr/share/sgml/docbook/dtd/xml|${LOCALBASE}/share/xml/docbook|' ${WRKSRC}/docs/manual.xml
${REINPLACE_CMD} -e 's|/usr/share/sgml/docbook/dtd/xml|${LOCALBASE}/share/xml/docbook|' ${WRKSRC}/docs/news.xml
${REINPLACE_CMD} -e 's|install-data-local: install-docs|install-data-local:|' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's|SSL_library_init|OPENSSL_init_ssl|' ${WRKSRC}/configure
post-install:
${MAKE} -C ${WRKSRC}/src install DESTDIR=${STAGEDIR}
diff --git a/news/newsstar/pkg-plist b/news/newsstar/pkg-plist
index 408b4bf4f666..e2a468caccbc 100644
--- a/news/newsstar/pkg-plist
+++ b/news/newsstar/pkg-plist
@@ -1,6 +1,6 @@
-@exec d=/var/spool/newsstar/incoming ; test -d "$d" || install -d -onews -gnews -m0750 "$d"
-@exec d=/var/spool/newsstar/lib ; test -d "$d" || install -d -onews -gnews -m0750 "$d"
-@exec d="%D/%%ETCDIR%%" ; test -d "$d" || install -d -o0 -g0 -m0755 "$d"
+@postexec d=/var/spool/newsstar/incoming ; test -d "$d" || install -d -onews -gnews -m0750 "$d"
+@postexec d=/var/spool/newsstar/lib ; test -d "$d" || install -d -onews -gnews -m0750 "$d"
+@postexec d="%D/%%ETCDIR%%" ; test -d "$d" || install -d -o0 -g0 -m0755 "$d"
bin/newsstar
man/man1/newsstar.1.gz
libexec/newsstar/newsstar.bin