aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-19 08:38:17 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-19 08:46:11 +0000
commitb95416f60aa11688281c2f10ee10a9f8a93ee714 (patch)
tree4d48ff4a81e1a1aa75285d2de4e10495c4915165
parentfadadd92e69dc54d23bc41f1386d40967b1372a9 (diff)
downloadports-b95416f60aa11688281c2f10ee10a9f8a93ee714.tar.gz
ports-b95416f60aa11688281c2f10ee10a9f8a93ee714.zip
cad/qcsxcad: New port: Qt-GUI for CSXCAD
-rw-r--r--cad/Makefile1
-rw-r--r--cad/qcsxcad/Makefile34
-rw-r--r--cad/qcsxcad/distinfo3
-rw-r--r--cad/qcsxcad/pkg-descr4
-rw-r--r--cad/qcsxcad/pkg-plist15
5 files changed, 57 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index 45c3f242fc77..31eade51e9f5 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -103,6 +103,7 @@
SUBDIR += py-pyfda
SUBDIR += python-gdsii
SUBDIR += qcad
+ SUBDIR += qcsxcad
SUBDIR += qelectrotech
SUBDIR += qflow
SUBDIR += qmls
diff --git a/cad/qcsxcad/Makefile b/cad/qcsxcad/Makefile
new file mode 100644
index 000000000000..484fb6d99add
--- /dev/null
+++ b/cad/qcsxcad/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= qcsxcad
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.6.2-5
+DISTVERSIONSUFFIX= -g0dabbaf
+CATEGORIES= cad
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Qt-GUI for CSXCAD
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+# many dependencies below are induced by vtk8, but not vtk9
+LIB_DEPENDS= \
+ libCSXCAD.so:cad/csxcad \
+ libexpat.so:textproc/expat2 \
+ libfreetype.so:print/freetype2 \
+ libpng16.so:graphics/png \
+ libtiff.so:graphics/tiff \
+ libtinyxml.so:textproc/tinyxml \
+ libvtkCommonCore-8.2.so:math/vtk8
+
+USES= cmake jpeg pkgconfig qt:5 xorg
+USE_QT= core gui sql widgets xml buildtools_build qmake_build
+USE_XORG= ice sm x11 xext xt
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= thliebig
+GH_PROJECT= ${PORTNAME:tu}
+
+CMAKE_ARGS= -DVTK_DIR=${LOCALBASE}/lib/vtk-8.2/cmake/vtk-8.2
+
+.include <bsd.port.mk>
diff --git a/cad/qcsxcad/distinfo b/cad/qcsxcad/distinfo
new file mode 100644
index 000000000000..5c3545e1456d
--- /dev/null
+++ b/cad/qcsxcad/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1629336266
+SHA256 (thliebig-QCSXCAD-v0.6.2-5-g0dabbaf_GH0.tar.gz) = 6372ac39b83af1f5f2d2327350b862dd2f9bce816939c4daa80479c2c26d68ab
+SIZE (thliebig-QCSXCAD-v0.6.2-5-g0dabbaf_GH0.tar.gz) = 627520
diff --git a/cad/qcsxcad/pkg-descr b/cad/qcsxcad/pkg-descr
new file mode 100644
index 000000000000..46d456de01e1
--- /dev/null
+++ b/cad/qcsxcad/pkg-descr
@@ -0,0 +1,4 @@
+QCSXCAD the Qt-GUI for CSXCAD, a C++ library to describe geometrical objects and
+their physical or non-physical properties.
+
+WWW: https://github.com/thliebig/QCSXCAD
diff --git a/cad/qcsxcad/pkg-plist b/cad/qcsxcad/pkg-plist
new file mode 100644
index 000000000000..b8e6ed133f3c
--- /dev/null
+++ b/cad/qcsxcad/pkg-plist
@@ -0,0 +1,15 @@
+include/QCSXCAD/QCSGridEditor.h
+include/QCSXCAD/QCSPrimEditor.h
+include/QCSXCAD/QCSPropEditor.h
+include/QCSXCAD/QCSTreeWidget.h
+include/QCSXCAD/QCSXCAD.h
+include/QCSXCAD/QCSXCAD_Global.h
+include/QCSXCAD/QParameterGui.h
+include/QCSXCAD/QVTKStructure.h
+include/QCSXCAD/VTKPrimitives.h
+include/QCSXCAD/export_pov.h
+include/QCSXCAD/export_x3d.h
+include/QCSXCAD/vtkInteractorStyleRubberBand2DPlane.h
+lib/libQCSXCAD.so
+lib/libQCSXCAD.so.0
+lib/libQCSXCAD.so.0.6.2