aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-08-11 16:12:33 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-20 18:10:46 +0000
commitb9cf35bb209a1a7e25aa39e8295e26c02af40971 (patch)
tree739e03ed31b2d48bf61798ad172350c9bc19a4cc
parent83ca5042280797b5622e1202df90c9c1d36356bd (diff)
downloadports-b9cf35bb209a1a7e25aa39e8295e26c02af40971.tar.gz
ports-b9cf35bb209a1a7e25aa39e8295e26c02af40971.zip
lang/intel-compute-runtime: update to 21.33.20678
-rw-r--r--lang/intel-compute-runtime/Makefile3
-rw-r--r--lang/intel-compute-runtime/distinfo6
-rw-r--r--lang/intel-compute-runtime/files/patch-no-rebar32
3 files changed, 28 insertions, 13 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index ed4b2dfe5be1..17ae4bcf6727 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -1,6 +1,5 @@
PORTNAME= compute-runtime
-DISTVERSION= 21.32.20609
-PORTREVISION= 1
+DISTVERSION= 21.33.20678
CATEGORIES= lang
PKGNAMEPREFIX= intel-
diff --git a/lang/intel-compute-runtime/distinfo b/lang/intel-compute-runtime/distinfo
index b4dae1fa6732..42867b20d58f 100644
--- a/lang/intel-compute-runtime/distinfo
+++ b/lang/intel-compute-runtime/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1628075862
-SHA256 (intel-compute-runtime-21.32.20609_GH0.tar.gz) = afe17b1f65bde7361f71cd051925ca382f8652b29549ed3527a95d801401ba67
-SIZE (intel-compute-runtime-21.32.20609_GH0.tar.gz) = 4462286
+TIMESTAMP = 1628698353
+SHA256 (intel-compute-runtime-21.33.20678_GH0.tar.gz) = 3569aceb3088b1c1674196097419e701b2070e80375c974f38706ceaacdae1db
+SIZE (intel-compute-runtime-21.33.20678_GH0.tar.gz) = 4534884
SHA256 (4a926516c3ea.patch) = 1a9c4694dbe892f01a7d3be5c5229b6b3bb34222848d61054f7bdf91134ca60f
SIZE (4a926516c3ea.patch) = 1691
diff --git a/lang/intel-compute-runtime/files/patch-no-rebar b/lang/intel-compute-runtime/files/patch-no-rebar
index 16b5ece68112..10941205ad28 100644
--- a/lang/intel-compute-runtime/files/patch-no-rebar
+++ b/lang/intel-compute-runtime/files/patch-no-rebar
@@ -34,7 +34,7 @@ level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp:204:55: error: use of un
this->preadFunction(fdConfig, configMemory.get(), PCI_CFG_SPACE_EXP_SIZE, 0);
^
---- level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp.orig 2021-07-27 12:47:48 UTC
+--- level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp.orig 2021-08-11 16:12:33 UTC
+++ level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp
@@ -12,7 +12,9 @@
@@ -46,23 +46,39 @@ level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp:204:55: error: use of un
namespace L0 {
-@@ -154,6 +156,7 @@ ze_result_t LinuxPciImp::initializeBarProperties(std::
+@@ -153,6 +155,7 @@ ze_result_t LinuxPciImp::initializeBarProperties(std::
+ }
- // Parse PCIe configuration space to see if resizable Bar is supported
- bool LinuxPciImp::resizableBarSupported() {
+ uint32_t LinuxPciImp::getRebarCapabilityPos() {
+#ifdef __linux__
uint32_t pos = PCI_CFG_SPACE_SIZE;
uint32_t header = 0;
-@@ -180,6 +183,7 @@ bool LinuxPciImp::resizableBarSupported() {
+@@ -179,6 +182,7 @@ uint32_t LinuxPciImp::getRebarCapabilityPos() {
}
header = getDwordFromConfig(pos);
}
+#endif
- return false;
+ return 0;
+ }
+
+@@ -197,6 +201,7 @@ bool LinuxPciImp::resizableBarEnabled(uint32_t barInde
+ if (!rebarCapabilityPos) {
+ return false;
+ }
++#ifdef __linux__
+
+ // As per PCI spec, resizable BAR's capability structure's 52 byte length could be represented as:
+ // --------------------------------------------------------------
+@@ -249,6 +254,7 @@ bool LinuxPciImp::resizableBarEnabled(uint32_t barInde
+
+ // If current size is equal to larget possible BAR size, it indicates resizable BAR is enabled.
+ return (currentSize == largestPossibleBarSize);
++#endif
}
-@@ -192,6 +196,7 @@ ze_result_t LinuxPciImp::getState(zes_pci_state_t *sta
+ ze_result_t LinuxPciImp::getState(zes_pci_state_t *state) {
+@@ -256,6 +262,7 @@ ze_result_t LinuxPciImp::getState(zes_pci_state_t *sta
}
void LinuxPciImp::pciExtendedConfigRead() {
@@ -70,7 +86,7 @@ level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp:204:55: error: use of un
std::string pciConfigNode;
pSysfsAccess->getRealPath("device/config", pciConfigNode);
int fdConfig = -1;
-@@ -203,6 +208,7 @@ void LinuxPciImp::pciExtendedConfigRead() {
+@@ -267,6 +274,7 @@ void LinuxPciImp::pciExtendedConfigRead() {
memset(configMemory.get(), 0, PCI_CFG_SPACE_EXP_SIZE);
this->preadFunction(fdConfig, configMemory.get(), PCI_CFG_SPACE_EXP_SIZE, 0);
this->closeFunction(fdConfig);