aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-02-10 00:06:24 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-02-10 00:06:24 +0000
commitba0ed97e072e550efdf29b3219dfd57d38457d59 (patch)
treee2df482bd1518d2c2456c440f0616f8e35d34a79
parentf292cfdbce2c443dab7a8f95ac841b09332e295b (diff)
downloadports-ba0ed97e072e550efdf29b3219dfd57d38457d59.tar.gz
ports-ba0ed97e072e550efdf29b3219dfd57d38457d59.zip
audio/jack: switch back to clang on powerpc*
Builds fine now.
-rw-r--r--audio/jack/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index c0cfe9ebb489..759b282f9fe0 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -1,6 +1,7 @@
PORTNAME= jackit
DISTVERSIONPREFIX= v
DISTVERSION= 1.9.20
+PORTREVISION= 1
CATEGORIES= audio
PATCH_SITES= https://github.com/jackaudio/jack2/commit/
@@ -15,7 +16,7 @@ LICENSE_COMB= multi
LIB_DEPENDS= libsamplerate.so:audio/libsamplerate \
libsysinfo.so:devel/libsysinfo
-USES= pkgconfig python:3.4+ shebangfix waf
+USES= compiler:c11 pkgconfig python:3.4+ shebangfix waf
USE_LDCONFIG= yes
USE_RC_SUBR= jackd
@@ -52,14 +53,6 @@ OPUS_CONFIGURE_OFF= --opus=no
PROFILING_DESC= Build with profiling information
PROFILING_CONFIGURE_ON= --profile
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == powerpc || ${ARCH} == powerpc64 || ${ARCH} == powerpc64le
-USES+= compiler:gcc-c++11-lib
-.else
-USES+= compiler:c11
-.endif
-
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MDBUS}