aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-04 12:19:57 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-04 13:23:25 +0000
commitba903e300598894004dd8776fc6ca4ea1139e32f (patch)
tree2f0b9af922cd5fc8479c6ea4ae614353d296ba22
parentd81a0d2d8b9e224a88a93bcaea3f352c4c65142c (diff)
downloadports-ba903e300598894004dd8776fc6ca4ea1139e32f.tar.gz
ports-ba903e300598894004dd8776fc6ca4ea1139e32f.zip
devel/directfb: Fix build with llvm15
- Pet portclippy - Adopt port
-rw-r--r--devel/directfb/Makefile51
1 files changed, 28 insertions, 23 deletions
diff --git a/devel/directfb/Makefile b/devel/directfb/Makefile
index 8400f03758cb..0e3f1f30d879 100644
--- a/devel/directfb/Makefile
+++ b/devel/directfb/Makefile
@@ -5,7 +5,7 @@ CATEGORIES= devel
MASTER_SITES= http://sources.buildroot.net/
DISTNAME= DirectFB-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Graphic development lightweight API
WWW= https://www.directfb.org/
@@ -13,27 +13,11 @@ LICENSE= LGPL21
LIB_DEPENDS= libpng.so:graphics/png
-OPTIONS_DEFINE= FREETYPE X11 SDL UNIQUE TEST DOCS
-UNIQUE_DESC= Unique (WM Module)
-
-OPTIONS_DEFAULT= FREETYPE X11 SDL
-OPTIONS_SUB= yes
-
-CPPFLAGS+= -I${LOCALBASE}/include
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USES= compiler cpe gmake jpeg libtool ncurses pathfix perl5 pkgconfig
+USES= compiler cpe gmake jpeg libtool localbase ncurses pathfix perl5 pkgconfig
USE_LDCONFIG= yes
USE_PERL5= build
-PORTDOCS= *
-
-DIRECTFB_SHLIB= 6.0.11 # LT_BINARY.LT_AGE.LT_REVISION
-DIRECTFB_BIN= ${DIRECTFB_SHLIB:R:R} # LT_BINARY
-PLIST_SUB+= DIRECTFB_VERSION="${PORTVERSION}" \
- DIRECTFB_RELEASE="${PORTVERSION:R}" \
- DIRECTFB_SHLIB="${DIRECTFB_SHLIB}" \
- DIRECTFB_BIN="${DIRECTFB_BIN}"
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-osx --disable-extra-warnings --disable-profiling \
--disable-debug --enable-debug-support --disable-trace \
--enable-text --enable-gettid --enable-network \
@@ -45,20 +29,41 @@ CONFIGURE_ARGS= --disable-osx --disable-extra-warnings --disable-profiling \
--with-inputdrivers=all --with-smooth-scaling \
--with-dither-rgb16=advanced
+INSTALL_TARGET= install-strip
+
+PLIST_SUB+= DIRECTFB_VERSION="${PORTVERSION}" \
+ DIRECTFB_RELEASE="${PORTVERSION:R}" \
+ DIRECTFB_SHLIB="${DIRECTFB_SHLIB}" \
+ DIRECTFB_BIN="${DIRECTFB_BIN}"
+PORTDOCS= *
+
+OPTIONS_DEFINE= FREETYPE X11 SDL UNIQUE TEST DOCS
+OPTIONS_DEFAULT= FREETYPE X11 SDL
+OPTIONS_SUB= yes
+
+UNIQUE_DESC= Unique (WM Module)
+
+DIRECTFB_SHLIB= 6.0.11 # LT_BINARY.LT_AGE.LT_REVISION
+DIRECTFB_BIN= ${DIRECTFB_SHLIB:R:R} # LT_BINARY
+
DOCS_BUILD_DEPENDS= man2html:textproc/man2html
FREETYPE_LIB_DEPENDS= libfreetype.so:print/freetype2
FREETYPE_CONFIGURE_ENABLE= freetype
-X11_USES= xorg
-X11_USE= XORG=x11,xext,xorgproto
-X11_CONFIGURE_ENABLE= x11
SDL_USES= sdl
SDL_USE= sdl=sdl
SDL_CONFIGURE_ENABLE= sdl
-UNIQUE_CONFIGURE_ENABLE= unique
TEST_CONFIGURE_WITH= tests
+UNIQUE_CONFIGURE_ENABLE= unique
+X11_USES= xorg
+X11_USE= XORG=x11,xext,xorgproto
+X11_CONFIGURE_ENABLE= x11
.include <bsd.port.pre.mk>
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
# assembly files use old split syntax which clang doesn't like
.if ${ARCH:Marmv?} && ${COMPILER_TYPE} == "clang"
BUILD_DEPENDS+= as:devel/binutils