aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-14 19:01:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-14 21:36:16 +0000
commitbaeb05cc505ed5d78e459cd64443ede767ec2744 (patch)
tree2e63a00a6acc107ba8fde9e1a7d9033df7004922
parenta9f173e1a3fc977613b4315a128714e851106cc7 (diff)
downloadports-baeb05cc505ed5d78e459cd64443ede767ec2744.tar.gz
ports-baeb05cc505ed5d78e459cd64443ede767ec2744.zip
math/py-minorminer: New port: Heuristic tool for minor embedding of graphs
-rw-r--r--math/Makefile1
-rw-r--r--math/py-minorminer/Makefile33
-rw-r--r--math/py-minorminer/distinfo3
-rw-r--r--math/py-minorminer/pkg-descr4
4 files changed, 41 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 5e5bd2db07e7..e6950328b9f2 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -899,6 +899,7 @@
SUBDIR += py-matplotlib-inline
SUBDIR += py-matplotlib-scalebar
SUBDIR += py-matplotlib2
+ SUBDIR += py-minorminer
SUBDIR += py-mip
SUBDIR += py-mixsimulator
SUBDIR += py-moarchiving
diff --git a/math/py-minorminer/Makefile b/math/py-minorminer/Makefile
new file mode 100644
index 000000000000..c23231fd7a1b
--- /dev/null
+++ b/math/py-minorminer/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= minorminer
+DISTVERSION= 0.2.9
+CATEGORIES= math python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Heuristic tool for minor embedding of graphs
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fasteners>=0.15:devel/py-fasteners@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}homebase>=1.0.1:devel/py-homebase@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}networkx>=2.4:math/py-networkx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dwave-networkx>=0.8.11:science/py-dwave-networkx@${PY_FLAVOR} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}rectangle-packer>=2.0.1:math/py-rectangle-packer@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=1.8.0:science/py-scipy@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python:3.6+
+USE_PYTHON= distutils cython autoplist
+
+USE_GITHUB= yes
+GH_ACCOUNT= dwavesystems
+
+post-install:
+ @${STRIP_CMD} \
+ ${STAGEDIR}${PYTHON_SITELIBDIR}/minorminer/_minorminer${PYTHON_EXT_SUFFIX}.so \
+ ${STAGEDIR}${PYTHON_SITELIBDIR}/minorminer/busclique${PYTHON_EXT_SUFFIX}.so
+
+.include <bsd.port.mk>
diff --git a/math/py-minorminer/distinfo b/math/py-minorminer/distinfo
new file mode 100644
index 000000000000..65658dac5590
--- /dev/null
+++ b/math/py-minorminer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1660502687
+SHA256 (dwavesystems-minorminer-0.2.9_GH0.tar.gz) = d74e9c8345094c9dae4c1c6421557e4fdb81b3efce00c0b8b0459e3db09f5083
+SIZE (dwavesystems-minorminer-0.2.9_GH0.tar.gz) = 1262651
diff --git a/math/py-minorminer/pkg-descr b/math/py-minorminer/pkg-descr
new file mode 100644
index 000000000000..6abe6c8a6214
--- /dev/null
+++ b/math/py-minorminer/pkg-descr
@@ -0,0 +1,4 @@
+minorminer is a heuristic tool for minor embedding: given a minor and target
+graph, it tries to find a mapping that embeds the minor into the target.
+
+WWW: https://docs.ocean.dwavesys.com/projects/minorminer/en/latest/