aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2024-09-30 15:56:09 +0000
committerBrooks Davis <brooks@FreeBSD.org>2024-09-30 22:13:43 +0000
commitbb1a2c2c421e75da9725c273c68126ef7eb99305 (patch)
tree15a277f0d220832fa0d3ccc8e8c061f5f6706b70
parentc115a19758196af4a8eac7e831169e840797b3ae (diff)
downloadports-bb1a2c2c421e75da9725c273c68126ef7eb99305.tar.gz
ports-bb1a2c2c421e75da9725c273c68126ef7eb99305.zip
math/xspread: include errno.h for errno
errno must be accessed by a macro from errno.h.
-rw-r--r--math/xspread/Makefile2
-rw-r--r--math/xspread/files/patch-interp.c13
2 files changed, 12 insertions, 3 deletions
diff --git a/math/xspread/Makefile b/math/xspread/Makefile
index e59edda7b823..8025c603540e 100644
--- a/math/xspread/Makefile
+++ b/math/xspread/Makefile
@@ -1,6 +1,6 @@
PORTNAME= xspread
PORTVERSION= 3.1.1c
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= math
MASTER_SITES= http://archive.debian.org/%SUBDIR%/ \
http://mirror.safehostnet.com/debian-archive/%SUBDIR%/ \
diff --git a/math/xspread/files/patch-interp.c b/math/xspread/files/patch-interp.c
index b3b52477548e..03306f8858f3 100644
--- a/math/xspread/files/patch-interp.c
+++ b/math/xspread/files/patch-interp.c
@@ -1,6 +1,15 @@
---- interp.c.orig 1995-11-07 02:17:26 UTC
+--- interp.c.orig
+++ interp.c
-@@ -516,7 +516,7 @@ int mo, day, yr;
+@@ -33,7 +33,7 @@
+ #include <setjmp.h>
+ #include <ctype.h>
+
+-extern int errno; /* set by math functions */
++#include <errno.h>
+
+ #include "sc.h"
+
+@@ -516,7 +516,7 @@
mdays[1] = 28 + (yr%4 == 0);
if (mo < 1 || mo > 12 || day < 1 || day > mdays[--mo] ||