aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-06-20 07:17:51 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-06-20 07:20:06 +0000
commitbc2e7b096225f8c3834f3ee6afe1a263048b6798 (patch)
treeeda9a9d387ae4ab2ed5d717d2883a50197b7138b
parent2b6a2dabd1c0ad6f6c475def3eb78c7e60df2e40 (diff)
downloadports-bc2e7b096225f8c3834f3ee6afe1a263048b6798.tar.gz
ports-bc2e7b096225f8c3834f3ee6afe1a263048b6798.zip
misc/edfbrowser: New port: Viewer, annotator, toolbox for timeseries files EEG, EMG, ECG, etc
-rw-r--r--misc/Makefile1
-rw-r--r--misc/edfbrowser/Makefile22
-rw-r--r--misc/edfbrowser/distinfo3
-rw-r--r--misc/edfbrowser/files/patch-edfbrowser.pro59
-rw-r--r--misc/edfbrowser/files/patch-edflib.c11
-rw-r--r--misc/edfbrowser/files/patch-global.h11
-rw-r--r--misc/edfbrowser/pkg-descr5
-rw-r--r--misc/edfbrowser/pkg-plist9
8 files changed, 121 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 91d6d72d2a04..a06dec444128 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -82,6 +82,7 @@
SUBDIR += dynomite
SUBDIR += e2fsprogs-libblkid
SUBDIR += e2fsprogs-libuuid
+ SUBDIR += edfbrowser
SUBDIR += edflib
SUBDIR += elixir-mime
SUBDIR += elixir-uuid
diff --git a/misc/edfbrowser/Makefile b/misc/edfbrowser/Makefile
new file mode 100644
index 000000000000..0c9b3085b9d8
--- /dev/null
+++ b/misc/edfbrowser/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= edfbrowser
+DISTVERSION= 1.94
+CATEGORIES= misc
+MASTER_SITES= https://www.teuniz.net/${PORTNAME}/
+DISTNAME= ${PORTNAME}_${DISTVERSION:S/.//}_source
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Viewer, annotator, toolbox for timeseries files EEG, EMG, ECG, etc
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= desktop-file-utils gl qmake qt:5 shared-mime-info
+USE_QT= core gui network printsupport widgets buildtools_build
+USE_GL= gl
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/edfbrowser
+
+.include <bsd.port.mk>
diff --git a/misc/edfbrowser/distinfo b/misc/edfbrowser/distinfo
new file mode 100644
index 000000000000..5e1d2d2e797d
--- /dev/null
+++ b/misc/edfbrowser/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1655707084
+SHA256 (edfbrowser_194_source.tar.gz) = f2aea90a761b73532ee96cd433a97d78d9080d44a9c0b25d3a81c4fe41f8fbe7
+SIZE (edfbrowser_194_source.tar.gz) = 677103
diff --git a/misc/edfbrowser/files/patch-edfbrowser.pro b/misc/edfbrowser/files/patch-edfbrowser.pro
new file mode 100644
index 000000000000..1cc7925c64f1
--- /dev/null
+++ b/misc/edfbrowser/files/patch-edfbrowser.pro
@@ -0,0 +1,59 @@
+--- edfbrowser.pro.orig 2022-06-20 06:49:59 UTC
++++ edfbrowser.pro
+@@ -284,35 +284,35 @@ win32 {
+ QMAKE_CXXFLAGS += -Wextra -Wshadow -Wformat -Wformat-nonliteral -Wformat-security -Wtype-limits -Wfatal-errors -Wdeprecated-declarations
+
+ unix {
+-target.path = /usr/bin
++target.path = $$PREFIX/bin/
+ target.files = edfbrowser
+ INSTALLS += target
+
+-documentation.path = /usr/share/doc/edfbrowser
++documentation.path = $$PREFIX/share/doc/edfbrowser
+ documentation.files = doc/*
+ INSTALLS += documentation
+
+-icon_a.path = /usr/share/icons
++icon_a.path = $$PREFIX/share/icons
+ icon_a.files = images/edf.png
+ INSTALLS += icon_a
+
+-icon_b.path += /usr/share/pixmaps
++icon_b.path += $$PREFIX/share/pixmaps
+ icon_b.files = images/edf.png
+ INSTALLS += icon_b
+
+-icon_c.path += /usr/share/icons/hicolor/48x48/apps
++icon_c.path += $$PREFIX/share/icons/hicolor/48x48/apps
+ icon_c.files = images/edf.png
+ INSTALLS += icon_c
+
+-icon_d.path += /usr/share/icons/hicolor/48x48/mimetypes
++icon_d.path += $$PREFIX/share/icons/hicolor/48x48/mimetypes
+ icon_d.files = images/edf.png
+ INSTALLS += icon_d
+
+-desktop_link.path += /usr/share/applications
++desktop_link.path += $$PREFIX/share/applications
+ desktop_link.files += install/edfbrowser.desktop
+ INSTALLS += desktop_link
+
+-mime.path += /usr/share/mime/packages
++mime.path += $$PREFIX/share/mime/packages
+ mime.files += install/edfbrowser.xml
+ INSTALLS += mime
+ }
+@@ -323,10 +323,10 @@ mac {
+ QMAKE_APPLICATION_BUNDLE_NAME = EDFbrowser
+ QMAKE_TARGET_BUNDLE_PREFIX = net.teuniz
+ icns.target = edf.icns
+- icns.commands = /usr/bin/env bash $$_PRO_FILE_PWD_/images/macos-icns-create.command "$$(PWD)"
++ icns.commands = $$PREFIX/bin/env bash $$_PRO_FILE_PWD_/images/macos-icns-create.command "$$(PWD)"
+ QMAKE_EXTRA_TARGETS += icns
+ ICON = $$(PWD)/edf.icns
+- QMAKE_POST_LINK = /usr/bin/env bash $$_PRO_FILE_PWD_/install/macos-dmg-create.command "$$(PWD)"
++ QMAKE_POST_LINK = $$PREFIX/bin/env bash $$_PRO_FILE_PWD_/install/macos-dmg-create.command "$$(PWD)"
+ QMAKE_CLEAN += edf.iconset EDFbrowser-*-temp.dmg
+ QMAKE_DISTCLEAN += edf.icns EDFbrowser-*.dmg
+ }
diff --git a/misc/edfbrowser/files/patch-edflib.c b/misc/edfbrowser/files/patch-edflib.c
new file mode 100644
index 000000000000..4412992a2639
--- /dev/null
+++ b/misc/edfbrowser/files/patch-edflib.c
@@ -0,0 +1,11 @@
+--- edflib.c.orig 2022-06-20 06:42:24 UTC
++++ edflib.c
+@@ -38,7 +38,7 @@
+ #define EDFLIB_VERSION (121)
+ #define EDFLIB_MAXFILES (64)
+
+-#if defined(__APPLE__) || defined(__MACH__) || defined(__APPLE_CC__) || defined(__HAIKU__)
++#if defined(__APPLE__) || defined(__MACH__) || defined(__APPLE_CC__) || defined(__HAIKU__) || defined(__FreeBSD__)
+
+ #define fopeno fopen
+
diff --git a/misc/edfbrowser/files/patch-global.h b/misc/edfbrowser/files/patch-global.h
new file mode 100644
index 000000000000..a6dd5007295f
--- /dev/null
+++ b/misc/edfbrowser/files/patch-global.h
@@ -0,0 +1,11 @@
+--- global.h.orig 2022-06-20 06:40:34 UTC
++++ global.h
+@@ -54,7 +54,7 @@
+
+ #include <stdio.h>
+
+-#if defined(__APPLE__) || defined(__MACH__) || defined(__APPLE_CC__) || defined(__HAIKU__)
++#if defined(__APPLE__) || defined(__MACH__) || defined(__APPLE_CC__) || defined(__HAIKU__) || defined(__FreeBSD__)
+
+ #define fopeno fopen
+
diff --git a/misc/edfbrowser/pkg-descr b/misc/edfbrowser/pkg-descr
new file mode 100644
index 000000000000..90e177c63285
--- /dev/null
+++ b/misc/edfbrowser/pkg-descr
@@ -0,0 +1,5 @@
+EDFbrowser is a free, opensource, multiplatform, universal viewer,
+annotator and toolbox intended for, but not limited to, timeseries
+storage files like EEG, EMG, ECG, BioImpedance, etc.
+
+WWW: https://www.teuniz.net/edfbrowser/
diff --git a/misc/edfbrowser/pkg-plist b/misc/edfbrowser/pkg-plist
new file mode 100644
index 000000000000..beefd650b80a
--- /dev/null
+++ b/misc/edfbrowser/pkg-plist
@@ -0,0 +1,9 @@
+bin/edfbrowser
+share/applications/edfbrowser.desktop
+%%PORTDOCS%%%%DOCSDIR%%/manual.html
+%%PORTDOCS%%%%DOCSDIR%%/montage_file_format.txt
+share/icons/edf.png
+share/icons/hicolor/48x48/apps/edf.png
+share/icons/hicolor/48x48/mimetypes/edf.png
+share/mime/packages/edfbrowser.xml
+share/pixmaps/edf.png