aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-08-14 09:28:59 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-15 00:16:56 +0000
commitbc57f4c6b38f40df11c039c52461d2292503e94d (patch)
tree56c734fa8cc67ace31cbbd1ab66875acd9cdef40
parentdce2c71d131f16139966347f87014611e03134ad (diff)
downloadports-bc57f4c6b38f40df11c039c52461d2292503e94d.tar.gz
ports-bc57f4c6b38f40df11c039c52461d2292503e94d.zip
emulators/yuzu: update to s20210814
-rw-r--r--emulators/yuzu/Makefile4
-rw-r--r--emulators/yuzu/distinfo6
-rw-r--r--emulators/yuzu/files/patch-CMakeLists.txt4
-rw-r--r--emulators/yuzu/files/patch-sdl245
4 files changed, 32 insertions, 27 deletions
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index 85d0823d95dc..0f73a496913d 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -1,5 +1,5 @@
PORTNAME= yuzu
-PORTVERSION= s20210811
+PORTVERSION= s20210814
PORTREVISION?= 0
CATEGORIES= emulators
@@ -33,7 +33,7 @@ LIB_DEPENDS= liblz4.so:archivers/liblz4 \
USE_GITHUB= yes
GH_ACCOUNT= yuzu-emu
-GH_TAGNAME= 756d76d97
+GH_TAGNAME= bdd617da0
GH_TUPLE= yuzu-emu:mbedtls:v2.16.9-115-g8c88150ca:mbedtls/externals/mbedtls \
KhronosGroup:SPIRV-Headers:1.5.4.raytracing.fixed-32-ga3fdfe8:SPIRV_Headers/externals/sirit/externals/SPIRV-Headers \
KhronosGroup:Vulkan-Headers:v1.2.180:Vulkan_Headers/externals/Vulkan-Headers \
diff --git a/emulators/yuzu/distinfo b/emulators/yuzu/distinfo
index d3f30b71d60f..2b844718c9e7 100644
--- a/emulators/yuzu/distinfo
+++ b/emulators/yuzu/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1628718789
-SHA256 (yuzu-emu-yuzu-s20210811-756d76d97_GH0.tar.gz) = 7778f099cdf2de3676480b5570a2814b1f1e1f311ebc7e02ad99be94ae23de10
-SIZE (yuzu-emu-yuzu-s20210811-756d76d97_GH0.tar.gz) = 3963710
+TIMESTAMP = 1628933339
+SHA256 (yuzu-emu-yuzu-s20210814-bdd617da0_GH0.tar.gz) = 2a3c57856ec5705d23551b6aafa573348a44fa68023d9b86ef344373e6427253
+SIZE (yuzu-emu-yuzu-s20210814-bdd617da0_GH0.tar.gz) = 3963648
SHA256 (yuzu-emu-mbedtls-v2.16.9-115-g8c88150ca_GH0.tar.gz) = 8cd6d075b4da0ad5fb995eb37390e2e6088be8d41ab1cdfc7e7e4256bd991450
SIZE (yuzu-emu-mbedtls-v2.16.9-115-g8c88150ca_GH0.tar.gz) = 2679189
SHA256 (KhronosGroup-SPIRV-Headers-1.5.4.raytracing.fixed-32-ga3fdfe8_GH0.tar.gz) = bd629d6296dd374eb2aeff923c75895ba0f3ce6448dad89763930e65b954e0cb
diff --git a/emulators/yuzu/files/patch-CMakeLists.txt b/emulators/yuzu/files/patch-CMakeLists.txt
index 0a4fdd397c1c..a96aa821af30 100644
--- a/emulators/yuzu/files/patch-CMakeLists.txt
+++ b/emulators/yuzu/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
yuzu (Qt) currently needs SDL for input
---- CMakeLists.txt.orig 2021-07-27 01:51:00 UTC
+--- CMakeLists.txt.orig 2021-08-14 09:28:59 UTC
+++ CMakeLists.txt
@@ -395,7 +395,10 @@ if (ENABLE_SDL2)
target_include_directories(SDL2 INTERFACE "${SDL2_INCLUDE_DIR}")
@@ -11,7 +11,7 @@ yuzu (Qt) currently needs SDL for input
+endif()
+
+if (NOT YUZU_USE_BUNDLED_SDL2 AND NOT YUZU_USE_EXTERNAL_SDL2)
- find_package(SDL2 2.0.15 REQUIRED)
+ find_package(SDL2 2.0.16 REQUIRED)
# Some installations don't set SDL2_LIBRARIES
@@ -407,7 +410,6 @@ if (ENABLE_SDL2)
diff --git a/emulators/yuzu/files/patch-sdl2 b/emulators/yuzu/files/patch-sdl2
index 0fb9b30ee992..a96a8f81de69 100644
--- a/emulators/yuzu/files/patch-sdl2
+++ b/emulators/yuzu/files/patch-sdl2
@@ -1,26 +1,25 @@
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=252371
--- SDL2 2.0.15 or newer not found, falling back to externals.
+CMake Error at CMakeLists.txt:397 (find_package):
+ Could not find a configuration file for package "SDL2" that is compatible
+ with requested version "2.0.16".
-CMake Error at externals/CMakeLists.txt:54 (add_subdirectory):
- The source directory
+ The following configuration files were considered but not accepted:
- externals/SDL
+ /usr/local/lib/cmake/SDL2/sdl2-config.cmake, version: 2.0.12
- does not contain a CMakeLists.txt file.
-
---- CMakeLists.txt.orig 2021-07-27 01:51:00 UTC
+--- CMakeLists.txt.orig 2021-08-14 09:28:59 UTC
+++ CMakeLists.txt
@@ -398,7 +398,7 @@ if (ENABLE_SDL2)
endif()
if (NOT YUZU_USE_BUNDLED_SDL2 AND NOT YUZU_USE_EXTERNAL_SDL2)
-- find_package(SDL2 2.0.15 REQUIRED)
+- find_package(SDL2 2.0.16 REQUIRED)
+ find_package(SDL2 2.0.12 REQUIRED)
# Some installations don't set SDL2_LIBRARIES
if("${SDL2_LIBRARIES}" STREQUAL "")
---- src/input_common/sdl/sdl_impl.cpp.orig 2021-06-02 22:29:09 UTC
+--- src/input_common/sdl/sdl_impl.cpp.orig 2021-08-14 09:28:59 UTC
+++ src/input_common/sdl/sdl_impl.cpp
@@ -64,6 +64,7 @@ class SDLJoystick { (public)
}
@@ -38,15 +37,15 @@ CMake Error at externals/CMakeLists.txt:54 (add_subdirectory):
}
void SetButton(int button, bool value) {
-@@ -82,6 +84,7 @@ class SDLJoystick { (public)
- state.buttons.insert_or_assign(button, value);
+@@ -88,6 +90,7 @@ class SDLJoystick { (public)
+ }
}
+#if SDL_VERSION_ATLEAST(2,0,14)
void SetMotion(SDL_ControllerSensorEvent event) {
constexpr float gravity_constant = 9.80665f;
std::lock_guard lock{mutex};
-@@ -109,6 +112,7 @@ class SDLJoystick { (public)
+@@ -115,6 +118,7 @@ class SDLJoystick { (public)
motion.UpdateRotation(time_difference * 1000);
motion.UpdateOrientation(time_difference * 1000);
}
@@ -54,7 +53,7 @@ CMake Error at externals/CMakeLists.txt:54 (add_subdirectory):
bool GetButton(int button) const {
std::lock_guard lock{mutex};
-@@ -378,12 +382,14 @@ void SDLState::HandleGameControllerEvent(const SDL_Eve
+@@ -429,12 +433,14 @@ void SDLState::HandleGameControllerEvent(const SDL_Eve
}
break;
}
@@ -69,17 +68,23 @@ CMake Error at externals/CMakeLists.txt:54 (add_subdirectory):
case SDL_JOYDEVICEREMOVED:
LOG_DEBUG(Input, "Controller removed with Instance_ID {}", event.jdevice.which);
CloseJoystick(SDL_JoystickFromInstanceID(event.jdevice.which));
-@@ -823,7 +829,9 @@ SDLState::SDLState() {
+@@ -890,11 +896,15 @@ SDLState::SDLState() {
+ RegisterFactory<MotionDevice>("sdl", motion_factory);
+
+ // Disable raw input. When enabled this setting causes SDL to die when a web applet opens
++#if SDL_VERSION_ATLEAST(2,0,14)
+ SDL_SetHint(SDL_HINT_JOYSTICK_RAWINPUT, "0");
++#endif
// Enable HIDAPI rumble. This prevents SDL from disabling motion on PS4 and PS5 controllers
SDL_SetHint(SDL_HINT_JOYSTICK_HIDAPI_PS4_RUMBLE, "1");
-+#if SDL_VERSION_ATLEAST(2,0,15)
++#if SDL_VERSION_ATLEAST(2,0,16)
SDL_SetHint(SDL_HINT_JOYSTICK_HIDAPI_PS5_RUMBLE, "1");
+#endif
// Tell SDL2 to use the hidapi driver. This will allow joycons to be detected as a
// GameController and not a generic one
-@@ -1037,6 +1045,7 @@ Common::ParamPackage SDLEventToMotionParamPackage(SDLS
+@@ -1108,6 +1118,7 @@ Common::ParamPackage SDLEventToMotionParamPackage(SDLS
}
break;
}
@@ -87,7 +92,7 @@ CMake Error at externals/CMakeLists.txt:54 (add_subdirectory):
case SDL_CONTROLLERSENSORUPDATE: {
bool is_motion_shaking = false;
constexpr float gyro_threshold = 5.0f;
-@@ -1066,6 +1075,7 @@ Common::ParamPackage SDLEventToMotionParamPackage(SDLS
+@@ -1137,6 +1148,7 @@ Common::ParamPackage SDLEventToMotionParamPackage(SDLS
}
break;
}
@@ -95,7 +100,7 @@ CMake Error at externals/CMakeLists.txt:54 (add_subdirectory):
}
return {};
}
-@@ -1169,6 +1179,7 @@ ButtonBindings SDLState::GetNintendoButtonBinding(
+@@ -1242,6 +1254,7 @@ ButtonBindings SDLState::GetNintendoButtonBinding(
auto sl_button = SDL_CONTROLLER_BUTTON_LEFTSHOULDER;
auto sr_button = SDL_CONTROLLER_BUTTON_RIGHTSHOULDER;
@@ -103,7 +108,7 @@ CMake Error at externals/CMakeLists.txt:54 (add_subdirectory):
if (joystick->IsJoyconLeft()) {
sl_button = SDL_CONTROLLER_BUTTON_PADDLE2;
sr_button = SDL_CONTROLLER_BUTTON_PADDLE4;
-@@ -1177,6 +1188,7 @@ ButtonBindings SDLState::GetNintendoButtonBinding(
+@@ -1250,6 +1263,7 @@ ButtonBindings SDLState::GetNintendoButtonBinding(
sl_button = SDL_CONTROLLER_BUTTON_PADDLE3;
sr_button = SDL_CONTROLLER_BUTTON_PADDLE1;
}
@@ -111,7 +116,7 @@ CMake Error at externals/CMakeLists.txt:54 (add_subdirectory):
return {
std::pair{Settings::NativeButton::A, SDL_CONTROLLER_BUTTON_A},
-@@ -1462,7 +1474,9 @@ class SDLMotionPoller final : public SDLPoller { (publ
+@@ -1550,7 +1564,9 @@ class SDLMotionPoller final : public SDLPoller { (publ
[[fallthrough]];
case SDL_JOYBUTTONUP:
case SDL_JOYHATMOTION: