aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-08-25 07:47:05 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-08-25 08:17:29 +0000
commitbc7255b18f0b895686033ef55d5b7b2871b185fe (patch)
tree076987975e2b9f60c7297f4a2f5d1a802deeca48
parent84fff01c2bc85436abd72107fe9e62d7cbc2e6d5 (diff)
audio/moc: Remove Musepack library support
Remove support for Musepack audio library PR: 281025 Approved by: portmgr (blanket)
-rw-r--r--audio/moc/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/audio/moc/Makefile b/audio/moc/Makefile
index 61c6eda8d8b3..1177065b76bd 100644
--- a/audio/moc/Makefile
+++ b/audio/moc/Makefile
@@ -19,9 +19,10 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-CONFIGURE_ARGS= --disable-cache --without-ffmpeg --without-sidplay2
+CONFIGURE_ARGS= --disable-cache --without-ffmpeg --without-musepack \
+ --without-sidplay2
-OPTIONS_DEFINE= AAC CURL DEBUG FLAC JACK MODPLUG MP3 MUSEPACK RCC \
+OPTIONS_DEFINE= AAC CURL DEBUG FLAC JACK MODPLUG MP3 RCC \
SAMPLERATE SNDFILE SPEEX VORBIS WAVPACK
OPTIONS_DEFAULT=MP3 VORBIS FLAC CURL WAVPACK
CURL_DESC= curl support (Internet streams)
@@ -52,11 +53,6 @@ MP3_LIB_DEPENDS= libmad.so:audio/libmad \
MP3_PLIST_FILES= lib/moc/decoder_plugins/libmp3_decoder.so
MP3_CONFIGURE_OFF= --without-mp3
-MUSEPACK_LIB_DEPENDS= libmpcdec.so:audio/musepack \
- libtag_c.so:audio/taglib
-MUSEPACK_PLIST_FILES= lib/moc/decoder_plugins/libmusepack_decoder.so
-MUSEPACK_CONFIGURE_OFF= --without-musepack
-
RCC_LIB_DEPENDS= librcc.so:devel/librcc \
librcd.so:devel/librcd
RCC_CONFIGURE_OFF= --without-rcc