aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-02-03 13:39:42 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-02-03 13:39:42 +0000
commitbcbbfc1c1bcf7c548913f185bb11f21426981231 (patch)
tree030e6657e639952d2552949b77c08883dca16f73
parent6b33040ff8cf611794de1c652f1f3ef6dec03104 (diff)
downloadports-bcbbfc1c1bcf7c548913f185bb11f21426981231.tar.gz
ports-bcbbfc1c1bcf7c548913f185bb11f21426981231.zip
devel/godot: fix build on powerpc64*
Disable modules using x86 intrinsics.
-rw-r--r--devel/godot/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/devel/godot/Makefile b/devel/godot/Makefile
index e6d86c10221a..dcaaab5ded04 100644
--- a/devel/godot/Makefile
+++ b/devel/godot/Makefile
@@ -84,6 +84,14 @@ PLIST_FILES= bin/${GODOTFILE}
.MAKEFLAGS: WITH="${OPTIONS_DEFINE}" OPTIONS_EXCLUDE=
.endif
+.include <bsd.port.options.mk>
+
+.if ${ARCH:Mpowerpc*}
+MAKE_ARGS+= module_embree_enabled=no \
+ module_raycast_enabled=no \
+ module_webm_enabled=no
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|custom_build|${OPSYS}_Ports_build|' \
${WRKSRC}/methods.py