aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-08-08 09:16:02 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-08-08 11:16:45 +0000
commitbcd90622c73cdc090877a2f8173cf50a8e8e611f (patch)
tree83484aa86627b5fa6d61d92a6876bd0f7436d2b4
parent47a148ae6aa0a0940df0e3308560b1b5dc428eae (diff)
downloadports-bcd90622c73cdc090877a2f8173cf50a8e8e611f.tar.gz
ports-bcd90622c73cdc090877a2f8173cf50a8e8e611f.zip
lang/mono*: add compat symlink for devel/msbuild < 16
/usr/local/lib/mono/msbuild/15.0/bin/Microsoft.CSharp.CurrentVersion.targets(331,5): error MSB4019: The imported project "/usr/local/lib/mono/msbuild/15.0/bin/Roslyn/Microsoft.CSharp.Core.targets" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk. PR: 256342 Suggested by: Marcin Cieślak Regressed by: https://github.com/mono/mono/commit/1717687e16dd
-rw-r--r--emulators/mesen/Makefile4
-rw-r--r--games/openbve/Makefile4
-rw-r--r--games/openra/Makefile4
-rw-r--r--lang/fsharp/Makefile6
-rw-r--r--lang/mono5.20/Makefile6
-rw-r--r--lang/mono6.8/Makefile6
6 files changed, 17 insertions, 13 deletions
diff --git a/emulators/mesen/Makefile b/emulators/mesen/Makefile
index 714249ad2183..f21ec15999c8 100644
--- a/emulators/mesen/Makefile
+++ b/emulators/mesen/Makefile
@@ -50,8 +50,8 @@ LIBRETRO_ALL_TARGET= libretro
.include <bsd.port.pre.mk>
-.if defined(MONO_DEFAULT) && ${MONO_DEFAULT} > 5.10
-BROKEN= fails to build with Mono version ${MONO_DEFAULT}: The imported project "/usr/local/lib/mono/msbuild/15.0/bin/Roslyn/Microsoft.CSharp.Core.targets" was not found
+.if defined(MONO_DEFAULT) && ${MONO_DEFAULT} > 6
+BROKEN= fails to build with Mono version ${MONO_DEFAULT}: error MSB4184: The expression ""Program.cs".GetPathsOfAllDirectoriesAbove()" cannot be evaluated. Method 'System.String.GetPathsOfAllDirectoriesAbove' not found.
.endif
do-install: # empty to avoid default
diff --git a/games/openbve/Makefile b/games/openbve/Makefile
index 05ba72df83d9..975863c09f79 100644
--- a/games/openbve/Makefile
+++ b/games/openbve/Makefile
@@ -53,8 +53,8 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
-.if defined(MONO_DEFAULT) && ${MONO_DEFAULT} > 5.10
-BROKEN= fails to build with Mono version ${MONO_DEFAULT}: The imported project "/usr/local/lib/mono/msbuild/15.0/bin/Roslyn/Microsoft.CSharp.Core.targets" was not found
+.if defined(MONO_DEFAULT) && ${MONO_DEFAULT} > 6
+BROKEN= fails to build with Mono version ${MONO_DEFAULT}: error MSB4184: The expression ""Program.cs".GetPathsOfAllDirectoriesAbove()" cannot be evaluated. Method 'System.String.GetPathsOfAllDirectoriesAbove' not found.
.endif
post-patch:
diff --git a/games/openra/Makefile b/games/openra/Makefile
index e92c5382d049..7c2c0fdf8b27 100644
--- a/games/openra/Makefile
+++ b/games/openra/Makefile
@@ -57,8 +57,8 @@ PORTDATA= *
.include <bsd.port.pre.mk>
-.if defined(MONO_DEFAULT) && ${MONO_DEFAULT} > 5.10
-BROKEN= fails to build with Mono version ${MONO_DEFAULT}: The imported project "/usr/local/lib/mono/msbuild/15.0/bin/Roslyn/Microsoft.CSharp.Core.targets" was not found
+.if defined(MONO_DEFAULT) && ${MONO_DEFAULT} > 6
+BROKEN= fails to build with Mono version ${MONO_DEFAULT}: error MSB4184: The expression ""Program.cs".GetPathsOfAllDirectoriesAbove()" cannot be evaluated. Method 'System.String.GetPathsOfAllDirectoriesAbove' not found.
.endif
post-extract:
diff --git a/lang/fsharp/Makefile b/lang/fsharp/Makefile
index 7e1d2c4717b2..397f49249e98 100644
--- a/lang/fsharp/Makefile
+++ b/lang/fsharp/Makefile
@@ -32,12 +32,8 @@ do-test:
.include <bsd.port.pre.mk>
-.if defined(MONO_DEFAULT)
-.if ${MONO_DEFAULT} > 6
+.if defined(MONO_DEFAULT) && ${MONO_DEFAULT} > 6
BROKEN= fails to build with Mono version ${MONO_DEFAULT}: A unique overload for method 'GetFileNameWithoutExtension' could not be determined based on type information prior to this program point
-.elif ${MONO_DEFAULT} > 5.10
-BROKEN= fails to build with Mono version ${MONO_DEFAULT}: The type 'HashSet' is not defined
-.endif
.endif
.include <bsd.port.post.mk>
diff --git a/lang/mono5.20/Makefile b/lang/mono5.20/Makefile
index b8cc60124a80..0d6815f6130c 100644
--- a/lang/mono5.20/Makefile
+++ b/lang/mono5.20/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mono
PORTVERSION= 5.20.1.34
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= https://download.mono-project.com/sources/mono/
PKGNAMESUFFIX= 5.20
@@ -108,5 +108,9 @@ post-configure:
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/mono
+# XXX Drop after devel/msbuild >= 16.0 per https://github.com/mono/msbuild/commit/48f3571f4036
+ ${RLN} ${STAGEDIR}${PREFIX}/lib/mono/msbuild/Current \
+ ${STAGEDIR}${PREFIX}/lib/mono/msbuild/15.0
+ ${ECHO_CMD} lib/mono/msbuild/15.0 >>${TMPPLIST}
.include <bsd.port.post.mk>
diff --git a/lang/mono6.8/Makefile b/lang/mono6.8/Makefile
index d477f74f20f4..59bd251c8a67 100644
--- a/lang/mono6.8/Makefile
+++ b/lang/mono6.8/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mono
PORTVERSION= 6.8.0.123
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= https://download.mono-project.com/sources/mono/
PKGNAMESUFFIX= 6.8
@@ -118,5 +118,9 @@ post-patch:
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/mono
+# XXX Drop after devel/msbuild >= 16.0 per https://github.com/mono/msbuild/commit/48f3571f4036
+ ${RLN} ${STAGEDIR}${PREFIX}/lib/mono/msbuild/Current \
+ ${STAGEDIR}${PREFIX}/lib/mono/msbuild/15.0
+ ${ECHO_CMD} lib/mono/msbuild/15.0 >>${TMPPLIST}
.include <bsd.port.post.mk>