aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-12-11 08:12:47 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-12-11 08:15:48 +0000
commitbd285c2e4c71e7942af806715782e7b2cae51951 (patch)
treeb273c7ea3a402acc8b4b326f42f69054b784c1a0
parentce6625b9a2736b14f2cd9519ef808487b288fb0a (diff)
downloadports-bd285c2e4c71e7942af806715782e7b2cae51951.tar.gz
ports-bd285c2e4c71e7942af806715782e7b2cae51951.zip
graphics/opencolorio-tools: prepare for cmake-3.22
PR: 260123
-rw-r--r--graphics/opencolorio/files/patch-src_apps_ociodisplay_CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/graphics/opencolorio/files/patch-src_apps_ociodisplay_CMakeLists.txt b/graphics/opencolorio/files/patch-src_apps_ociodisplay_CMakeLists.txt
new file mode 100644
index 000000000000..8fe811eb1290
--- /dev/null
+++ b/graphics/opencolorio/files/patch-src_apps_ociodisplay_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/apps/ociodisplay/CMakeLists.txt.orig 2019-03-28 05:12:57 UTC
++++ src/apps/ociodisplay/CMakeLists.txt
+@@ -13,7 +13,7 @@ if (OIIO_FOUND)
+
+ # set_target_properties(ociodisplay PROPERTIES INSTALL_RPATH ${OIIO_LIBRARIES} )
+ set_target_properties(ociodisplay PROPERTIES COMPILE_FLAGS -DCMAKE_BUILD_TYPE=${CMAKE_BUILD_TYPE})
+- target_link_libraries(ociodisplay ${GLEW_LIBRARIES} ${GLUT_LIBRARY} ${OPENGL_LIBRARY} ${OIIO_LIBRARIES})
++ target_link_libraries(ociodisplay ${GLEW_LIBRARIES} ${GLUT_LIBRARY} ${GLUT_LIBRARIES} ${OPENGL_LIBRARY} ${OIIO_LIBRARIES})
+ target_link_OCIO(ociodisplay)
+
+ install(TARGETS ociodisplay EXPORT OpenColorIO DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/bin)