aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2024-09-30 15:56:09 +0000
committerBrooks Davis <brooks@FreeBSD.org>2024-09-30 22:13:43 +0000
commitbd7c71cdedc36ed8e3e993f93fa400207f01240c (patch)
tree1251abd7fac5791904938776742ccb1ef9a5e1a3
parent2a45473e53f94660515ac45ed75f7ca6ff3b3367 (diff)
downloadports-bd7c71cdedc36ed8e3e993f93fa400207f01240c.tar.gz
ports-bd7c71cdedc36ed8e3e993f93fa400207f01240c.zip
mail/queue-fix: include errno.h for errno
errno must be accessed by a macro from errno.h.
-rw-r--r--mail/queue-fix/Makefile2
-rw-r--r--mail/queue-fix/files/patch-error.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/mail/queue-fix/Makefile b/mail/queue-fix/Makefile
index 0641f07f85aa..021a567060cc 100644
--- a/mail/queue-fix/Makefile
+++ b/mail/queue-fix/Makefile
@@ -1,6 +1,6 @@
PORTNAME= queue-fix
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://www.netmeridian.com/e-huss/ \
GENTOO
diff --git a/mail/queue-fix/files/patch-error.h b/mail/queue-fix/files/patch-error.h
new file mode 100644
index 000000000000..e35ddb04802a
--- /dev/null
+++ b/mail/queue-fix/files/patch-error.h
@@ -0,0 +1,11 @@
+--- error.h.orig
++++ error.h
+@@ -1,7 +1,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;