aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2022-06-29 19:35:54 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2022-06-30 09:01:15 +0000
commitbd97b63d8b5d81d2520c6a3b248b63e2d69be59e (patch)
tree55efda51790e87dd7451f03c658c8a671e9554fd
parent65b9346db98e69dce2b51feb65f9d2e55e84f252 (diff)
downloadports-bd97b63d8b5d81d2520c6a3b248b63e2d69be59e.tar.gz
ports-bd97b63d8b5d81d2520c6a3b248b63e2d69be59e.zip
www/node: Fix patch on armv6 and armv7
PR: 263590 Reported by: Robert Clausecker <fuz@fuz.su> Sponsored by: The FreeBSD Foundation
-rw-r--r--www/node/Makefile4
-rw-r--r--www/node/files/patch-tools_v8__gypfiles_v8.gyp (renamed from www/node/files/extra-patch-tools_v8__gypfiles_v8.gyp)8
2 files changed, 4 insertions, 8 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index af0e0319b3c8..902c57b1dea8 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -83,10 +83,6 @@ LIB_DEPENDS+= libbrotlidec.so:archivers/brotli \
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-common.gypi
.endif
-.if ${ARCH} == armv6 || ${ARCH} == armv7
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-tools_v8__gypfiles_v8.gyp
-.endif
-
.if ${PORT_OPTIONS:MBUNDLED_SSL} && ${ARCH} != amd64
CONFIGURE_ARGS+=--openssl-no-asm
.endif
diff --git a/www/node/files/extra-patch-tools_v8__gypfiles_v8.gyp b/www/node/files/patch-tools_v8__gypfiles_v8.gyp
index 9749a96d68e5..374f77039af4 100644
--- a/www/node/files/extra-patch-tools_v8__gypfiles_v8.gyp
+++ b/www/node/files/patch-tools_v8__gypfiles_v8.gyp
@@ -1,11 +1,11 @@
---- tools/v8_gypfiles/v8.gyp.orig 2021-04-20 11:30:16 UTC
+--- tools/v8_gypfiles/v8.gyp.orig 2022-05-17 11:37:47 UTC
+++ tools/v8_gypfiles/v8.gyp
-@@ -774,7 +774,7 @@
+@@ -977,7 +977,7 @@
}],
# Platforms that don't have Compare-And-Swap (CAS) support need to link atomic library
# to implement atomic memory access
-- ['v8_current_cpu in ["mips", "mipsel", "mips64", "mips64el", "ppc", "arm", "riscv64"]', {
-+ ['v8_current_cpu in ["mips", "mipsel", "mips64", "mips64el", "ppc", "riscv64"]', {
+- ['v8_current_cpu in ["mips", "mipsel", "mips64", "mips64el", "ppc", "arm", "riscv64", "loong64"]', {
++ ['v8_current_cpu in ["mips", "mipsel", "mips64", "mips64el", "ppc", "riscv64", "loong64"]', {
'link_settings': {
'libraries': ['-latomic', ],
},