aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2023-05-02 06:34:24 +0000
committerKai Knoblich <kai@FreeBSD.org>2023-05-02 06:34:24 +0000
commitbdcfffd8573e09ef4c838b3dd1444fa15e508c4e (patch)
tree0a2bdaa7e04a4b8a96a0ab157f65f0dc736f4e42
parent51e83a9b9ffcdaf52e5871f35d28c86a66fc1830 (diff)
downloadports-bdcfffd8573e09ef4c838b3dd1444fa15e508c4e.tar.gz
ports-bdcfffd8573e09ef4c838b3dd1444fa15e508c4e.zip
games/anki: Fix crashes with nVidia drivers
* Prevent Anki from explicitly loading "libGL.so.1", which leads to segfaults in environments that have nVidia drivers in use. * Bump PORTREVISION due package change. PR: 270778 Reported by: bitbucket63-it@yahoo.com MFH: 2023Q2
-rw-r--r--games/anki/Makefile2
-rw-r--r--games/anki/files/patch-qt_aqt_____init____.py13
2 files changed, 14 insertions, 1 deletions
diff --git a/games/anki/Makefile b/games/anki/Makefile
index b28c09a8a824..153ea7eee848 100644
--- a/games/anki/Makefile
+++ b/games/anki/Makefile
@@ -1,6 +1,6 @@
PORTNAME= anki
DISTVERSION= 2.1.54
-PORTREVISION= 16
+PORTREVISION= 17
# Don't forget to update ${_MY_BUILDHASH} if DISTVERSION changes
CATEGORIES= games education python
MASTER_SITES= LOCAL/kai/:yarncache \
diff --git a/games/anki/files/patch-qt_aqt_____init____.py b/games/anki/files/patch-qt_aqt_____init____.py
new file mode 100644
index 000000000000..6428c77633ba
--- /dev/null
+++ b/games/anki/files/patch-qt_aqt_____init____.py
@@ -0,0 +1,13 @@
+Prevents runtime issues with nVidia drivers
+
+--- qt/aqt/__init__.py.orig 2023-04-15 12:54:44 UTC
++++ qt/aqt/__init__.py
+@@ -369,7 +369,7 @@ def setupGL(pm: aqt.profiles.ProfileManager) -> None:
+ driver = pm.video_driver()
+
+ # work around pyqt loading wrong GL library
+- if is_lin:
++ if is_lin and not sys.platform.startswith("freebsd"):
+ import ctypes
+
+ ctypes.CDLL("libGL.so.1", ctypes.RTLD_GLOBAL)