aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-30 00:24:38 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-30 00:52:53 +0000
commitbe4e3c38c81d23c7e66c841292bd463568943c94 (patch)
treeefd0d7156520bbd1b176a6ef36c54ffa8c61b1d4
parent1d7527c07a19e92e689d956f4f7b0afcf79562ff (diff)
downloadports-be4e3c38c81d23c7e66c841292bd463568943c94.tar.gz
ports-be4e3c38c81d23c7e66c841292bd463568943c94.zip
lang/squeak: Fix build with llvm16
- Add missing DEPENDS reported by poudriere testport Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--lang/squeak/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/lang/squeak/Makefile b/lang/squeak/Makefile
index 4c1e8c001062..8e39aeeb579c 100644
--- a/lang/squeak/Makefile
+++ b/lang/squeak/Makefile
@@ -27,11 +27,12 @@ LIB_DEPENDS= libaudio.so:audio/nas \
libdbus-1.so:devel/dbus \
libffi.so:devel/libffi \
libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz \
libasound.so:audio/alsa-lib \
libpulse-simple.so:audio/pulseaudio \
libv4l2.so:multimedia/libv4l
-USES= gl gnome iconv pkgconfig xorg
+USES= gl gnome iconv:wchar_t pkgconfig xorg
USE_GL= gl
USE_GNOME= cairo pango
USE_XORG= ice sm x11 xext xrender
@@ -62,12 +63,16 @@ IMAGES= Squeak${IMAGE_FULL_VERSION}.image \
Squeak${IMAGE_FULL_VERSION}.changes \
${SQUEAK_SRC}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=int-conversion
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,<utmp\.h>,<utmpx.h>,' \
${WRKSRC}/unix/plugins/PseudoTTYPlugin/openpty.h
@@ -87,4 +92,4 @@ post-install:
${INSTALL_DATA} ${IMAGES:S,^,${WRKDIR}/,} \
${STAGEDIR}${PREFIX}/lib/squeak
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>