aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2022-08-12 17:26:57 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2022-08-12 17:26:57 +0000
commitbf742277557cd64e9017df3844ca82173529c1ae (patch)
treeec7f683e62fb5af0c9ed4639a40568e1c45a264c
parent738c6f945d5c1951092d40f593bfac9a31eff32d (diff)
downloadports-bf742277557cd64e9017df3844ca82173529c1ae.tar.gz
ports-bf742277557cd64e9017df3844ca82173529c1ae.zip
devel/freebsd-gcc9: Bump to 9.5.0.
While here, switch the default ABI for powerpc64 to ELFv2. Reviewed by: lwhsu Differential Revision: https://reviews.freebsd.org/D35684
-rw-r--r--devel/freebsd-gcc9/Makefile8
-rw-r--r--devel/freebsd-gcc9/distinfo6
-rw-r--r--devel/freebsd-gcc9/files/patch-libcpp_lex.c25
3 files changed, 9 insertions, 30 deletions
diff --git a/devel/freebsd-gcc9/Makefile b/devel/freebsd-gcc9/Makefile
index 32a202748df3..ed873a1de38b 100644
--- a/devel/freebsd-gcc9/Makefile
+++ b/devel/freebsd-gcc9/Makefile
@@ -1,6 +1,5 @@
PORTNAME= gcc
-PORTVERSION= 9.3.0
-PORTREVISION= 1
+PORTVERSION= 9.5.0
CATEGORIES= devel
MASTER_SITES= GCC
PKGNAMEPREFIX= ${TARGETARCH}-
@@ -49,11 +48,16 @@ CONFIGURE_ARGS+=--target=${GCC_TARGET} --disable-nls --enable-languages=c,c++ \
--with-gmp=${LOCALBASE} \
--with-pkgversion="FreeBSD Ports Collection for ${PKGNAMEPREFIX:C/-//g}" \
--with-system-zlib \
+ --without-zstd \
--with-gxx-include-dir=/usr/include/c++/v1/ \
--with-sysroot="/" \
--with-as=${LOCALBASE}/bin/${BU_PREFIX}-as \
--with-ld=${LOCALBASE}/bin/${BU_PREFIX}-ld
+.if ${TARGETARCH:Mpowerpc64*}
+CONFIGURE_ARGS+=--with-abi=elfv2
+.endif
+
ALL_TARGET= all-gcc
INSTALL_TARGET= install-gcc
diff --git a/devel/freebsd-gcc9/distinfo b/devel/freebsd-gcc9/distinfo
index 4a1d0fcf4182..3495406ad131 100644
--- a/devel/freebsd-gcc9/distinfo
+++ b/devel/freebsd-gcc9/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1595179652
-SHA256 (gcc-9.3.0.tar.xz) = 71e197867611f6054aa1119b13a0c0abac12834765fe2d81f35ac57f84f742d1
-SIZE (gcc-9.3.0.tar.xz) = 70533868
+TIMESTAMP = 1654895134
+SHA256 (gcc-9.5.0.tar.xz) = 27769f64ef1d4cd5e2be8682c0c93f9887983e6cfd1a927ce5a0a2915a95cf8f
+SIZE (gcc-9.5.0.tar.xz) = 72462752
diff --git a/devel/freebsd-gcc9/files/patch-libcpp_lex.c b/devel/freebsd-gcc9/files/patch-libcpp_lex.c
deleted file mode 100644
index 05ad28872d11..000000000000
--- a/devel/freebsd-gcc9/files/patch-libcpp_lex.c
+++ /dev/null
@@ -1,25 +0,0 @@
-This is
-
- commit cd547f0ddcd3a54e5b73bcda5ac0f0c46808db8b
- Author: Jakub Jelinek <jakub@redhat.com>
- Date: Sat Sep 26 10:07:41 2020 +0200
-
-which is on the GCC 10 release branch and thus part of lang/gcc10-devel;
-we should automatically get it with GCC 10.3.
-
---- libcpp/lex.c.orig 2020-11-02 10:24:50 UTC
-+++ libcpp/lex.c
-@@ -531,11 +531,11 @@ init_vectorized_lexer (void)
- search_line_fast = impl;
- }
-
--#elif defined(_ARCH_PWR8) && defined(__ALTIVEC__)
-+#elif (GCC_VERSION >= 4005) && defined(_ARCH_PWR8) && defined(__ALTIVEC__)
-
- /* A vection of the fast scanner using AltiVec vectorized byte compares
- and VSX unaligned loads (when VSX is available). This is otherwise
-- the same as the pre-GCC 5 version. */
-+ the same as the AltiVec version. */
-
- ATTRIBUTE_NO_SANITIZE_UNDEFINED
- static const uchar *