aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2022-10-03 06:15:38 +0000
committerGleb Popov <arrowd@FreeBSD.org>2022-10-03 06:17:54 +0000
commitbf75375fa590e5ea8dfbfb4cee66c2f3aeadfa70 (patch)
tree0edab260a597644f8eb336ca2f12ec8f2a9c1867
parent7fea2bffc61514432cb0da504cef54f2fe8fe771 (diff)
downloadports-bf75375fa590e5ea8dfbfb4cee66c2f3aeadfa70.tar.gz
ports-bf75375fa590e5ea8dfbfb4cee66c2f3aeadfa70.zip
devel/hs-git-annex: Disable optimization on aarch64 to unbreak the build.
Reported by: pkg-fallout
-rw-r--r--devel/hs-git-annex/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/hs-git-annex/Makefile b/devel/hs-git-annex/Makefile
index 3c8aa842bc66..df3ae04ef7ff 100644
--- a/devel/hs-git-annex/Makefile
+++ b/devel/hs-git-annex/Makefile
@@ -300,6 +300,13 @@ MAN1PAGES= git-annex-add git-annex-expire git-annex-lookupkey \
git-remote-tor-annex git-annex-examinekey git-annex-log \
git-annex-rekey git-annex-undo
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == aarch64
+# compiler goes out of memory
+BUILD_ARGS+= --disable-optimization
+.endif
+
post-build:
.for man in ${MAN1PAGES}
${WRKSRC}/Build/mdwn2man ${man} 1 ${WRKSRC}/doc/${man}.mdwn > ${WRKSRC}/doc/${man}.1
@@ -314,4 +321,4 @@ post-stage:
${LN} -sf git-annex ${STAGEDIR}${PREFIX}/bin/git-annex-shell
${LN} -sf git-annex ${STAGEDIR}${PREFIX}/bin/git-remote-tor-annex
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>