aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2024-03-10 08:57:40 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-03-10 08:59:05 +0000
commitbf8a0031d97ff4c1fc019d7061085bdc38484365 (patch)
tree1f978f4119af5ee882e467601c6a2a709b34ad3f
parentd1d99c221ea7f17ab6d61fbdca3006e4208cf4c0 (diff)
*: Move manpages to share/man
Approved by: portmgr (blanket)
-rw-r--r--math/ndiff/Makefile4
-rw-r--r--math/ndiff/files/patch-Makefile.in21
-rw-r--r--sysutils/pstacku/Makefile4
-rw-r--r--x11/nvidia-driver/Makefile1
-rw-r--r--x11/nvidia-driver/pkg-plist2
5 files changed, 22 insertions, 10 deletions
diff --git a/math/ndiff/Makefile b/math/ndiff/Makefile
index bf16c2560793..4a021e59ef4e 100644
--- a/math/ndiff/Makefile
+++ b/math/ndiff/Makefile
@@ -1,6 +1,6 @@
PORTNAME= ndiff
PORTVERSION= 2.00
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math
MASTER_SITES= ftp://ftp.math.utah.edu/pub/misc/
@@ -14,7 +14,7 @@ USES= desthack
GNU_CONFIGURE= yes
PLIST_FILES= bin/${PORTNAME} \
- man/man1/${PORTNAME}.1.gz \
+ share/man/man1/${PORTNAME}.1.gz \
%%DATADIR%%/${PORTNAME}.awk
PORTDOCS= *.html *.pdf *.ps *.txt
diff --git a/math/ndiff/files/patch-Makefile.in b/math/ndiff/files/patch-Makefile.in
index dbfb54277387..1a8914fc9aed 100644
--- a/math/ndiff/files/patch-Makefile.in
+++ b/math/ndiff/files/patch-Makefile.in
@@ -1,6 +1,15 @@
---- Makefile.in.orig 2000-12-12 19:11:11.000000000 +0100
-+++ Makefile.in 2014-02-02 11:56:29.000000000 +0100
-@@ -191,9 +190,9 @@
+--- Makefile.in.orig 2000-12-12 18:11:11 UTC
++++ Makefile.in
+@@ -62,7 +62,7 @@ catdir = $(prefix)/man/cat$(manext)
+ prefix = @prefix@
+ bindir = $(prefix)/bin
+ catdir = $(prefix)/man/cat$(manext)
+-mandir = $(prefix)/man/man$(manext)
++mandir = $(prefix)/share/man/man$(manext)
+ manext = 1
+ shrlibdir = $(shrlibtop)/$(PROGNAME)-$(VERSION)
+ shrlibtop = $(prefix)/share/lib/$(PROGNAME)
+@@ -191,9 +191,9 @@ DEFINES = -DVERSION='"@VERSION@"' -DDATE='"@DATE@"' $
DEFINES = -DVERSION='"@VERSION@"' -DDATE='"@DATE@"' $(XDEFINES)
@@ -12,7 +21,7 @@
LIBS = @LIBS@ $(XLIBS)
-@@ -602,14 +601,12 @@
+@@ -602,14 +602,12 @@ install-exe: uninstall-exe
if test -f $(PROGNAME) ; \
then \
$(CP) $(PROGNAME) $(bindir)/$(PROGNAME) ; \
@@ -28,7 +37,7 @@
done ; \
fi
-@@ -635,7 +632,7 @@
+@@ -635,7 +633,7 @@ install-show:
install-show:
@echo ''
@echo Installed files...
@@ -37,7 +46,7 @@
@$(LS) -l $(mandir)/$(PROGNAME).$(manext)
@if test -d $(shrlibdir) ; then $(LS) -lR $(shrlibdir)/* ; fi
@echo ''
-@@ -703,7 +698,7 @@
+@@ -703,7 +701,7 @@ uninstall-exe:
uninstall-exe:
-for f in $(PROGRAMS) ; \
do \
diff --git a/sysutils/pstacku/Makefile b/sysutils/pstacku/Makefile
index c60ce63385de..ddedff369e3f 100644
--- a/sysutils/pstacku/Makefile
+++ b/sysutils/pstacku/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pstacku
PORTVERSION= 0.9.2
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://kib.kiev.ua/kib/${PORTNAME}/ \
http://kib.kiev.ua/kib/${PORTNAME}/
@@ -13,11 +14,12 @@ LICENSE= BSD2CLAUSE
LIB_DEPENDS= libunwind.so:devel/libunwind
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
CONFIGURE_ARGS+=--with-libunwind=${LOCALBASE}
LLD_UNSAFE= yes
ONLY_FOR_ARCHS= amd64 i386
CONFLICTS= pstack
-PLIST_FILES= bin/pstack man/man1/pstack.1.gz
+PLIST_FILES= bin/pstack share/man/man1/pstack.1.gz
.include <bsd.port.mk>
diff --git a/x11/nvidia-driver/Makefile b/x11/nvidia-driver/Makefile
index 1529bf3af8e4..db35190592e3 100644
--- a/x11/nvidia-driver/Makefile
+++ b/x11/nvidia-driver/Makefile
@@ -163,6 +163,7 @@ EXTRA_PATCHES+= ${WRKDIR}/${p}
.endfor
post-patch: .SILENT
+ ${REINPLACE_CMD} -e 's|/man/man1|/share/man/man1|' ${WRKSRC}/nvml/man/Makefile
# We should support -CURRENT: kill the check (first #if __FreeBSD_version)
linenum=$$(${SED} -ne '/^#if __FreeBSD_version/ { = ; q ; }' \
${WRKSRC}/src/${NVSRC}/nv-freebsd.h) ; ${REINPLACE_CMD} \
diff --git a/x11/nvidia-driver/pkg-plist b/x11/nvidia-driver/pkg-plist
index ade919f5371f..bc1ceb3e3eb7 100644
--- a/x11/nvidia-driver/pkg-plist
+++ b/x11/nvidia-driver/pkg-plist
@@ -94,7 +94,7 @@ lib32/libnvidia-gpucomp.so.1
lib32/libnvidia-tls.so
lib32/libnvidia-tls.so.1
lib32/vdpau/libvdpau_nvidia.so.1
-man/man1/nvidia-smi.1.gz
+share/man/man1/nvidia-smi.1.gz
@comment share/egl/egl_external_platform.d/10_nvidia_wayland.json
share/egl/egl_external_platform.d/15_nvidia_gbm.json
share/glvnd/egl_vendor.d/10_nvidia.json