aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLewis Cook <lcook@FreeBSD.org>2021-11-03 04:37:50 +0000
committerLewis Cook <lcook@FreeBSD.org>2021-11-03 04:37:50 +0000
commitbfa5897e68dcf2771f7ca9222406529fbd956871 (patch)
tree51b0bd36c33da91d89ecbb668b22446f0e1e06a7
parent7e297db40d539fc6c9eff8f0f88a0e5887eb9f4e (diff)
downloadports-bfa5897e68dcf2771f7ca9222406529fbd956871.tar.gz
ports-bfa5897e68dcf2771f7ca9222406529fbd956871.zip
textproc/vgrep: Add port: User-friendly pager for grep
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/vgrep/Makefile44
-rw-r--r--textproc/vgrep/distinfo27
-rw-r--r--textproc/vgrep/pkg-descr11
4 files changed, 83 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b6f301949eda..d4c4976b1139 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1930,6 +1930,7 @@
SUBDIR += uz-aspell
SUBDIR += vbindiff
SUBDIR += ve-hunspell
+ SUBDIR += vgrep
SUBDIR += wa-aspell
SUBDIR += wa-hunspell
SUBDIR += wbxml2
diff --git a/textproc/vgrep/Makefile b/textproc/vgrep/Makefile
new file mode 100644
index 000000000000..d0be173c2280
--- /dev/null
+++ b/textproc/vgrep/Makefile
@@ -0,0 +1,44 @@
+PORTNAME= vgrep
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.5.5
+CATEGORIES= textproc
+
+MAINTAINER= lcook@x230
+COMMENT= User-friendly pager for grep
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+USE_GITHUB= yes
+GH_ACCOUNT= vrothberg
+GH_TUPLE= golang:sys:0f9fa26af87c:golang_sys/vendor/golang.org/x/sys \
+ golang:term:6886f2dfbf5b:golang_term/vendor/golang.org/x/term \
+ jessevdk:go-flags:v1.5.0:jessevdk_go_flags/vendor/github.com/jessevdk/go-flags \
+ json-iterator:go:v1.1.12:json_iterator_go/vendor/github.com/json-iterator/go \
+ mattn:go-runewidth:v0.0.13:mattn_go_runewidth/vendor/github.com/mattn/go-runewidth \
+ mattn:go-shellwords:v1.0.12:mattn_go_shellwords/vendor/github.com/mattn/go-shellwords \
+ modern-go:concurrent:e0a39a4cb421:modern_go_concurrent/vendor/github.com/modern-go/concurrent \
+ modern-go:reflect2:v1.0.2:modern_go_reflect2/vendor/github.com/modern-go/reflect2 \
+ nightlyone:lockfile:v1.0.0:nightlyone_lockfile/vendor/github.com/nightlyone/lockfile \
+ peterh:liner:v1.2.1:peterh_liner/vendor/github.com/peterh/liner \
+ rivo:uniseg:v0.2.0:rivo_uniseg/vendor/github.com/rivo/uniseg \
+ sirupsen:logrus:v1.8.1:sirupsen_logrus/vendor/github.com/sirupsen/logrus
+
+_BUILD_VERSION= ${DISTVERSION}-5c56338
+
+GO_BUILDFLAGS= -ldflags "\
+ -s -w \
+ -X main.version=${_BUILD_VERSION}"
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} \
+ ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/vgrep/distinfo b/textproc/vgrep/distinfo
new file mode 100644
index 000000000000..deacf386ade5
--- /dev/null
+++ b/textproc/vgrep/distinfo
@@ -0,0 +1,27 @@
+TIMESTAMP = 1635913556
+SHA256 (vrothberg-vgrep-v2.5.5_GH0.tar.gz) = 6272ca460549813231bc046e6fde7e94baec03f66c4b8f88b197af7d70556013
+SIZE (vrothberg-vgrep-v2.5.5_GH0.tar.gz) = 1571944
+SHA256 (golang-sys-0f9fa26af87c_GH0.tar.gz) = 4a7725e85ddaba8f2efc9b799eb00f4b3d522ea8ed9ad0ce08783febe3ec97a1
+SIZE (golang-sys-0f9fa26af87c_GH0.tar.gz) = 1202044
+SHA256 (golang-term-6886f2dfbf5b_GH0.tar.gz) = e2e151fcf388487e6d70ce589408f9848a78843a790e3bae5409c86b10493bf9
+SIZE (golang-term-6886f2dfbf5b_GH0.tar.gz) = 14933
+SHA256 (jessevdk-go-flags-v1.5.0_GH0.tar.gz) = d4bf30f729cbc16d2aa0095ac10ca4fadc8f092b9a28990c0cfca2345c3e7ffd
+SIZE (jessevdk-go-flags-v1.5.0_GH0.tar.gz) = 59316
+SHA256 (json-iterator-go-v1.1.12_GH0.tar.gz) = ff70e539fd919da757a2f3a530a053e7577cb4d7e2824fc1058d3abbefbb523e
+SIZE (json-iterator-go-v1.1.12_GH0.tar.gz) = 84307
+SHA256 (mattn-go-runewidth-v0.0.13_GH0.tar.gz) = 9b2aeafa5d95a40b32067ba22accdf42cc83414ec5b433ea7de330791beaa196
+SIZE (mattn-go-runewidth-v0.0.13_GH0.tar.gz) = 17353
+SHA256 (mattn-go-shellwords-v1.0.12_GH0.tar.gz) = 9884291747f54aa51a946b0880854ec6ac6e1f4c06899ba9be5ae5a6364428db
+SIZE (mattn-go-shellwords-v1.0.12_GH0.tar.gz) = 6325
+SHA256 (modern-go-concurrent-e0a39a4cb421_GH0.tar.gz) = 19137c93c8d4bf8c3920716cca3b0f0112707604706cfa86fc61794594151b44
+SIZE (modern-go-concurrent-e0a39a4cb421_GH0.tar.gz) = 5482
+SHA256 (modern-go-reflect2-v1.0.2_GH0.tar.gz) = eab313f24c09d512f004d489aeed0d0a485f789abd07e7df411375035174341b
+SIZE (modern-go-reflect2-v1.0.2_GH0.tar.gz) = 14030
+SHA256 (nightlyone-lockfile-v1.0.0_GH0.tar.gz) = ab6ae9054edde30a2d1adfd757bcd1d4610742a826cdad8b6e8c85c673f5d525
+SIZE (nightlyone-lockfile-v1.0.0_GH0.tar.gz) = 6088
+SHA256 (peterh-liner-v1.2.1_GH0.tar.gz) = 0d19020c5b0e51033c11d218e5079704da79d35b4cc6efacf3a6f9e5958c7c82
+SIZE (peterh-liner-v1.2.1_GH0.tar.gz) = 21157
+SHA256 (rivo-uniseg-v0.2.0_GH0.tar.gz) = 3ad738b5c9162ede110d75b23564b6e40e52dd9150ebbced402f4f70be106197
+SIZE (rivo-uniseg-v0.2.0_GH0.tar.gz) = 44036
+SHA256 (sirupsen-logrus-v1.8.1_GH0.tar.gz) = e9492c08ac8f202b438ccfb992bf81b7860739cf8f2266958e0c574c7abfdd74
+SIZE (sirupsen-logrus-v1.8.1_GH0.tar.gz) = 47161
diff --git a/textproc/vgrep/pkg-descr b/textproc/vgrep/pkg-descr
new file mode 100644
index 000000000000..cc81e17c8fac
--- /dev/null
+++ b/textproc/vgrep/pkg-descr
@@ -0,0 +1,11 @@
+Pager for grep, git-grep, ripgrep and similar grep
+implementations, and allows for opening the indexed
+file locations in a user-specified editor such as vim
+or emacs.
+
+vgrep is inspired by the ancient cgvg scripts but
+extended to perform further operations such as listing
+statistics of files and directory trees or showing the
+context lines before and after the matches.
+
+WWW: https://github.com/vrothberg/vgrep