aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2025-03-12 13:19:35 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2025-03-12 13:19:35 +0000
commitc0407032f0cd9e6d1acb2c3afd874841310b07b1 (patch)
treeecb5bf6c2fa71ff27717c74707b0880c40ac4bc0
parent2f18602d69c813081dcd0338f5cadb1e65bb7b87 (diff)
deskutils/nextcloudclient: Update to 3.16.0
-rw-r--r--deskutils/nextcloudclient/Makefile5
-rw-r--r--deskutils/nextcloudclient/distinfo6
-rw-r--r--deskutils/nextcloudclient/files/patch-doc_CMakeLists.txt9
-rw-r--r--deskutils/nextcloudclient/files/patch-doc_building.rst8
-rw-r--r--deskutils/nextcloudclient/files/patch-src_csync_ConfigureChecks.cmake4
-rw-r--r--deskutils/nextcloudclient/files/patch-src_libsync_configfile.cpp4
-rw-r--r--deskutils/nextcloudclient/pkg-plist232
7 files changed, 244 insertions, 24 deletions
diff --git a/deskutils/nextcloudclient/Makefile b/deskutils/nextcloudclient/Makefile
index 13dd16f06ea3..321a1c426315 100644
--- a/deskutils/nextcloudclient/Makefile
+++ b/deskutils/nextcloudclient/Makefile
@@ -1,5 +1,5 @@
PORTNAME= nextcloudclient
-PORTVERSION= 3.15.3
+PORTVERSION= 3.16.0
DISTVERSIONPREFIX= v
CATEGORIES= deskutils
@@ -12,7 +12,8 @@ LICENSE= GPLv2
BUILD_DEPENDS= inkscape:graphics/inkscape
LIB_DEPENDS= libinotify.so:devel/libinotify \
libqt6keychain.so:security/qtkeychain@qt6 \
- libxkbcommon.so:x11/libxkbcommon
+ libxkbcommon.so:x11/libxkbcommon \
+ libp11.so:security/libp11
USES= cmake:noninja compiler:c++20-lang desktop-file-utils gl gmake \
gnome iconv kde:6 localbase:ldflags pkgconfig qt:6 shared-mime-info \
diff --git a/deskutils/nextcloudclient/distinfo b/deskutils/nextcloudclient/distinfo
index 1ffad2b90523..85a8ec39afd5 100644
--- a/deskutils/nextcloudclient/distinfo
+++ b/deskutils/nextcloudclient/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1736263720
-SHA256 (nextcloud-desktop-v3.15.3_GH0.tar.gz) = 5a4b12604c84b8986f2aee7462bb9683fb01f4ae28ee9d6882068cb9cac45773
-SIZE (nextcloud-desktop-v3.15.3_GH0.tar.gz) = 15683038
+TIMESTAMP = 1741768489
+SHA256 (nextcloud-desktop-v3.16.0_GH0.tar.gz) = 9935c63903105ad1d23d82a09af9d832b0cbc4a1b664b0d5f0846c49f695b398
+SIZE (nextcloud-desktop-v3.16.0_GH0.tar.gz) = 15566707
diff --git a/deskutils/nextcloudclient/files/patch-doc_CMakeLists.txt b/deskutils/nextcloudclient/files/patch-doc_CMakeLists.txt
index 9ae0b5e3c0cd..1fb6b60ed164 100644
--- a/deskutils/nextcloudclient/files/patch-doc_CMakeLists.txt
+++ b/deskutils/nextcloudclient/files/patch-doc_CMakeLists.txt
@@ -1,4 +1,4 @@
---- doc/CMakeLists.txt.orig 2023-12-11 17:50:46 UTC
+--- doc/CMakeLists.txt.orig 2025-03-12 08:49:45 UTC
+++ doc/CMakeLists.txt
@@ -11,7 +11,7 @@ if(SPHINX_FOUND)
# assets
@@ -9,3 +9,10 @@
install(DIRECTORY ${SPHINX_HTML_DIR} DESTINATION ${APPLICATION_DOC_DIR} OPTIONAL)
install(DIRECTORY ${SPHINX_PDF_DIR} DESTINATION ${APPLICATION_DOC_DIR} OPTIONAL)
install(DIRECTORY ${SPHINX_QCH_DIR} DESTINATION ${APPLICATION_DOC_DIR} OPTIONAL)
+@@ -90,4 +90,4 @@ if(SPHINX_FOUND)
+ ${SPHINX_HTMLHELP_DIR} )
+ add_custom_target( doc-chm pushd ${SPHINX_HTMLHELP_DIR}; ${MSHTML_COMPILER} *.hhp; popd
+ DEPENDS doc-chm-sphinx )
+-endif(SPHINX_FOUND)
+\ No newline at end of file
++endif(SPHINX_FOUND)
diff --git a/deskutils/nextcloudclient/files/patch-doc_building.rst b/deskutils/nextcloudclient/files/patch-doc_building.rst
index 1765379abd1d..66681bd145b4 100644
--- a/deskutils/nextcloudclient/files/patch-doc_building.rst
+++ b/deskutils/nextcloudclient/files/patch-doc_building.rst
@@ -1,15 +1,15 @@
---- doc/building.rst.orig 2024-09-14 08:21:08 UTC
+--- doc/building.rst.orig 2025-03-12 08:51:17 UTC
+++ doc/building.rst
@@ -220,13 +220,9 @@ ----------------------------------
1. Click on 'Modify' in the Visual Studio Installer:
-- .. image:: ./images/building/visual-studio-installer.png
+- .. image:: ./images/dev/visual-studio-installer.png
- :alt: Visual Studio Installer
2. Select 'Desktop development with C++'
-- .. image:: ./images/building/desktop-development-with-cpp.png
+- .. image:: ./images/dev/desktop-development-with-cpp.png
- :alt: Desktop development with C++
Handling the dependencies
@@ -18,7 +18,7 @@
4. To use the tools installed with Visual Studio, you need the following in your %PATH%:
-- .. image:: ./images/building/path.png
+- .. image:: ./images/dev/path.png
- :alt: Windows environment variables
5. Alternatively you can use the tools installed with KDE Craft by adding them to %PATH%:
diff --git a/deskutils/nextcloudclient/files/patch-src_csync_ConfigureChecks.cmake b/deskutils/nextcloudclient/files/patch-src_csync_ConfigureChecks.cmake
index 52cb079bdbc4..0d45a7facbde 100644
--- a/deskutils/nextcloudclient/files/patch-src_csync_ConfigureChecks.cmake
+++ b/deskutils/nextcloudclient/files/patch-src_csync_ConfigureChecks.cmake
@@ -1,6 +1,6 @@
---- src/csync/ConfigureChecks.cmake.orig 2021-09-03 09:40:46 UTC
+--- src/csync/ConfigureChecks.cmake.orig 2025-03-06 09:00:02 UTC
+++ src/csync/ConfigureChecks.cmake
-@@ -14,9 +14,6 @@ set(SYSCONFDIR ${SYSCONF_INSTALL_DIR})
+@@ -13,9 +13,6 @@ set(SOURCEDIR ${CMAKE_CURRENT_SOURCE_DIR})
set(BINARYDIR ${CMAKE_CURRENT_BINARY_DIR})
set(SOURCEDIR ${CMAKE_CURRENT_SOURCE_DIR})
diff --git a/deskutils/nextcloudclient/files/patch-src_libsync_configfile.cpp b/deskutils/nextcloudclient/files/patch-src_libsync_configfile.cpp
index 09f5dc7f7598..95097102e956 100644
--- a/deskutils/nextcloudclient/files/patch-src_libsync_configfile.cpp
+++ b/deskutils/nextcloudclient/files/patch-src_libsync_configfile.cpp
@@ -1,6 +1,6 @@
---- src/libsync/configfile.cpp.orig 2017-12-20 15:03:02 UTC
+--- src/libsync/configfile.cpp.orig 2025-03-06 09:00:02 UTC
+++ src/libsync/configfile.cpp
-@@ -448,11 +448,22 @@ bool ConfigFile::skipUpdateCheck(const QString &connec
+@@ -653,11 +653,22 @@ bool ConfigFile::skipUpdateCheck(const QString &connec
if (connection.isEmpty())
con = defaultConnection();
diff --git a/deskutils/nextcloudclient/pkg-plist b/deskutils/nextcloudclient/pkg-plist
index 392339975592..578e54e1cfdb 100644
--- a/deskutils/nextcloudclient/pkg-plist
+++ b/deskutils/nextcloudclient/pkg-plist
@@ -11,17 +11,229 @@ include/nextcloudsync/mirall/syncengine.h
include/nextcloudsync/mirall/syncfileitem.h
include/nextcloudsync/mirall/syncresult.h
lib/libnextcloud_csync.so
-lib/libnextcloud_csync.so.%%VERSION%%
lib/libnextcloud_csync.so.0
-%%KDE%%lib/libnextclouddolphinpluginhelper.so
+lib/libnextcloud_csync.so.%%VERSION%%
+lib/libnextclouddolphinpluginhelper.so
lib/libnextcloudsync.so
-lib/libnextcloudsync.so.%%VERSION%%
lib/libnextcloudsync.so.0
+lib/libnextcloudsync.so.%%VERSION%%
lib/nextcloudsync_vfs_suffix.so
-%%KDE%%%%QT_PLUGINDIR%%/kf6/kfileitemaction/nextclouddolphinactionplugin.so
-%%KDE%%%%QT_PLUGINDIR%%/kf6/overlayicon/nextclouddolphinoverlayplugin.so
+%%QT_PLUGINDIR%%/kf6/kfileitemaction/nextclouddolphinactionplugin.so
+%%QT_PLUGINDIR%%/kf6/overlayicon/nextclouddolphinoverlayplugin.so
share/applications/com.nextcloud.desktopclient.nextcloud.desktop
-%%GNOME%%share/caja-python/extensions/syncstate-Nextcloud.py
+share/caja-python/extensions/syncstate-Nextcloud.py
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/.buildinfo
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/confirm.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/create_debug_archive.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/folderwizard_local.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/folderwizard_remote.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/general_settings_folder_context_menu.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/icon-error.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/icon-information.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/icon-offline.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/icon-paused.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/icon-syncing.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/icon.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/ignored_files_editor.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/log_output_window.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/mac-share.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/macosvfs-file-locking.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/macosvfs-file-sharing.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/macosvfs-finder-sidebar.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/macosvfs-settings.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/macosvfs-sync-status-icons.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/main_dialog.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/open-share-dialog.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/remove.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/save_log_file.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/set-user-status-menu.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/set-user-status.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/settings_general.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/settings_network.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/settingsdialog.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/share-dialog-view-profile.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/share_context_menu.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/share_dialog.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/status_feature_example.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/sync-state-paused.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/sync-state-synced.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/sync-state-syncing.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/sync-state-warnings.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/traymenu.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/unified-search-events.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/unified-search-files.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/unified-search-talk.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/user-account-options.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/user_status-selector_dialog.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/user_status_selector_main_dialog.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/vfs_context_menu_options.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/vfs_hydration_progress_bar.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/wizard.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/wizard_advanced.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/wizard_flow2.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/wizard_setup.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/wizard_welcome.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/advancedusage.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/architecture.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/autoupdate.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/building.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/conffile.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/conflicts.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/envvars.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/faq.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/glossary.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/index.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/installing.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/introduction.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/lowdiskspace.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/macosvfs.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/massdeploymentcommandline.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/navigating.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/nextcloudcmd.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/options-cmd.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/options.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/troubleshooting.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/visualtour.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/wizardaccountsetupcommandline.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/_sphinx_javascript_frameworks_compat.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/basic.css
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/classic.css
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/default.css
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/doctools.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/documentation_options.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/file.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/jquery-3.6.0.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/jquery.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/language_data.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/minus.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/plus.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/pygments.css
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/searchtools.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/sidebar.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/sphinx_highlight.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/underscore-1.13.1.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/underscore.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/advancedusage.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/architecture.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/autoupdate.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/building.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/conffile.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/conflicts.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/envvars.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/genindex.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/glossary.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/installing.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/lowdiskspace.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/macosvfs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/massdeploymentcommandline.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/navigating.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/nextcloudcmd.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/objects.inv
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/options-cmd.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/options.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/search.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/searchindex.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/troubleshooting.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/visualtour.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/wizardaccountsetupcommandline.html
+%%PORTDOCS%%%%DOCSDIR%%/latex/LICRcyr2utf8.xdy
+%%PORTDOCS%%%%DOCSDIR%%/latex/LICRlatin2utf8.xdy
+%%PORTDOCS%%%%DOCSDIR%%/latex/LatinRules.xdy
+%%PORTDOCS%%%%DOCSDIR%%/latex/Makefile
+%%PORTDOCS%%%%DOCSDIR%%/latex/NextcloudClientManual.aux
+%%PORTDOCS%%%%DOCSDIR%%/latex/NextcloudClientManual.fdb_latexmk
+%%PORTDOCS%%%%DOCSDIR%%/latex/NextcloudClientManual.fls
+%%PORTDOCS%%%%DOCSDIR%%/latex/NextcloudClientManual.idx
+%%PORTDOCS%%%%DOCSDIR%%/latex/NextcloudClientManual.ilg
+%%PORTDOCS%%%%DOCSDIR%%/latex/NextcloudClientManual.ind
+%%PORTDOCS%%%%DOCSDIR%%/latex/NextcloudClientManual.log
+%%PORTDOCS%%%%DOCSDIR%%/latex/NextcloudClientManual.out
+%%PORTDOCS%%%%DOCSDIR%%/latex/NextcloudClientManual.pdf
+%%PORTDOCS%%%%DOCSDIR%%/latex/NextcloudClientManual.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/NextcloudClientManual.toc
+%%PORTDOCS%%%%DOCSDIR%%/latex/confirm.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/create_debug_archive.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/folderwizard_local.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/folderwizard_remote.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/general_settings_folder_context_menu.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/icon-error.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/icon-information.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/icon-offline.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/icon-paused.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/icon-syncing.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/icon.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/ignored_files_editor.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/latexmkjarc
+%%PORTDOCS%%%%DOCSDIR%%/latex/latexmkrc
+%%PORTDOCS%%%%DOCSDIR%%/latex/log_output_window.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/logo-blue.pdf
+%%PORTDOCS%%%%DOCSDIR%%/latex/mac-share.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/macosvfs-file-locking.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/macosvfs-file-sharing.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/macosvfs-finder-sidebar.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/macosvfs-settings.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/macosvfs-sync-status-icons.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/main_dialog.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/make.bat
+%%PORTDOCS%%%%DOCSDIR%%/latex/open-share-dialog.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/python.ist
+%%PORTDOCS%%%%DOCSDIR%%/latex/remove.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/save_log_file.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/set-user-status-menu.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/set-user-status.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/settings_general.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/settings_network.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/settingsdialog.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/share-dialog-view-profile.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/share_context_menu.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/share_dialog.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinx.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinx.xdy
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxhighlight.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxhowto.cls
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxlatexadmonitions.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxlatexcontainers.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxlatexgraphics.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxlatexindbibtoc.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxlatexlists.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxlatexliterals.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxlatexnumfig.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxlatexobjects.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxlatexshadowbox.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxlatexstyleheadings.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxlatexstylepage.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxlatexstyletext.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxlatextables.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxmanual.cls
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxmessages.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxoptionsgeometry.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxoptionshyperref.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxpackageboxes.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxpackagecyrillic.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxpackagefootnote.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/status_feature_example.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/sync-state-paused.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/sync-state-synced.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/sync-state-syncing.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/sync-state-warnings.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/traymenu.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/unified-search-events.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/unified-search-files.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/unified-search-talk.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/user-account-options.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/user_status-selector_dialog.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/user_status_selector_main_dialog.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/vfs_context_menu_options.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/vfs_hydration_progress_bar.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/wizard.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/wizard_advanced.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/wizard_flow2.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/wizard_setup.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/wizard_welcome.png
+%%EXAMPLESDIR%%/sync-exclude.lst
share/icons/hicolor/1024x1024/apps/Nextcloud.png
share/icons/hicolor/128x128/apps/Nextcloud.png
share/icons/hicolor/128x128/apps/Nextcloud_error.png
@@ -87,11 +299,11 @@ share/icons/hicolor/72x72/apps/Nextcloud_sync.png
share/icons/hicolor/72x72/apps/Nextcloud_sync_shared.png
share/icons/hicolor/72x72/apps/Nextcloud_warn.png
share/icons/hicolor/72x72/apps/Nextcloud_warn_shared.png
-%%DOCS%%share/man/man1/nextcloud.1.gz
-%%DOCS%%share/man/man1/nextcloudcmd.1.gz
+share/man/man1/nextcloud.1.gz
+share/man/man1/nextcloudcmd.1.gz
share/mime/packages/nextcloud.xml
-%%GNOME%%share/nautilus-python/extensions/syncstate-Nextcloud.py
-%%GNOME%%share/nemo-python/extensions/syncstate-Nextcloud.py
+share/nautilus-python/extensions/syncstate-Nextcloud.py
+share/nemo-python/extensions/syncstate-Nextcloud.py
share/nextcloud/i18n/client_TW.qm
share/nextcloud/i18n/client_af.qm
share/nextcloud/i18n/client_ar.qm