aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-06 15:59:24 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-06 15:59:24 +0000
commitc050e87b30c556a3326648367cac9dd44978d966 (patch)
tree27a6fb9f3bf725ce6a7f6c079544e218ec0c616e
parent0bd0aefe9a768e1db6fc58de24acd3131a7a7884 (diff)
devel/py-crick: Add py-crick 0.0.6
Crick is a fast library of approximate and streaming algorithms. It is still a work in progress, use at your own risk.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-crick/Makefile26
-rw-r--r--devel/py-crick/distinfo3
-rw-r--r--devel/py-crick/files/patch-pyproject.toml17
-rw-r--r--devel/py-crick/pkg-descr2
5 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4df140c1f68e..db740926caeb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4626,6 +4626,7 @@
SUBDIR += py-crashtest
SUBDIR += py-crc32c
SUBDIR += py-crcmod
+ SUBDIR += py-crick
SUBDIR += py-crontab
SUBDIR += py-cson
SUBDIR += py-csv23
diff --git a/devel/py-crick/Makefile b/devel/py-crick/Makefile
new file mode 100644
index 000000000000..af046f14c275
--- /dev/null
+++ b/devel/py-crick/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= crick
+PORTVERSION= 0.0.6
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= High performance approximate and streaming algorithms
+WWW= https://github.com/dask/crick
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.26.2,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=6.2:devel/py-setuptools-scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}versioneer>=0:devel/py-versioneer@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent cython pep517
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>
diff --git a/devel/py-crick/distinfo b/devel/py-crick/distinfo
new file mode 100644
index 000000000000..e64829b684c9
--- /dev/null
+++ b/devel/py-crick/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1720022666
+SHA256 (crick-0.0.6.tar.gz) = 851bc0802cd4dfb17f8fe99934b224dc355c84de0174ea5d9723b25c7feeb516
+SIZE (crick-0.0.6.tar.gz) = 434484
diff --git a/devel/py-crick/files/patch-pyproject.toml b/devel/py-crick/files/patch-pyproject.toml
new file mode 100644
index 000000000000..4299751b7583
--- /dev/null
+++ b/devel/py-crick/files/patch-pyproject.toml
@@ -0,0 +1,17 @@
+--- pyproject.toml.orig 2024-05-03 20:15:33 UTC
++++ pyproject.toml
+@@ -1,6 +1,6 @@ requires = [
+ [build-system]
+ requires = [
+- "setuptools>=68.2.2",
++ "setuptools>=61",
+ "setuptools-scm[toml]>=6.2",
+ "Cython",
+ "numpy>=1.26.2",
+@@ -33,4 +33,4 @@ tag_prefix = ""
+ versionfile_source = "crick/_version.py"
+ versionfile_build = "crick/_version.py"
+ tag_prefix = ""
+-parentdir_prefix = "crick-"
+\ No newline at end of file
++parentdir_prefix = "crick-"
diff --git a/devel/py-crick/pkg-descr b/devel/py-crick/pkg-descr
new file mode 100644
index 000000000000..195289c036f1
--- /dev/null
+++ b/devel/py-crick/pkg-descr
@@ -0,0 +1,2 @@
+Crick is a fast library of approximate and streaming algorithms. It is still a
+work in progress, use at your own risk.