aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2024-09-30 15:56:09 +0000
committerBrooks Davis <brooks@FreeBSD.org>2024-09-30 22:13:43 +0000
commitc115a19758196af4a8eac7e831169e840797b3ae (patch)
tree12c0832cca7cb09bc0576d6ccf2d03cf516250b0
parentbd7c71cdedc36ed8e3e993f93fa400207f01240c (diff)
downloadports-c115a19758196af4a8eac7e831169e840797b3ae.tar.gz
ports-c115a19758196af4a8eac7e831169e840797b3ae.zip
mail/serialmail: include errno.h for errno
errno must be accessed by a macro from errno.h.
-rw-r--r--mail/serialmail/Makefile2
-rw-r--r--mail/serialmail/files/patch-error.h11
-rw-r--r--mail/serialmail/files/patch-leapsecs__read.c10
3 files changed, 22 insertions, 1 deletions
diff --git a/mail/serialmail/Makefile b/mail/serialmail/Makefile
index 5d406d8f7f66..cab0a791cb96 100644
--- a/mail/serialmail/Makefile
+++ b/mail/serialmail/Makefile
@@ -1,6 +1,6 @@
PORTNAME= serialmail
PORTVERSION= 0.75
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= http://cr.yp.to/software/ \
ftp://ftp.gbnet.net/pub/qmail/ \
diff --git a/mail/serialmail/files/patch-error.h b/mail/serialmail/files/patch-error.h
new file mode 100644
index 000000000000..e35ddb04802a
--- /dev/null
+++ b/mail/serialmail/files/patch-error.h
@@ -0,0 +1,11 @@
+--- error.h.orig
++++ error.h
+@@ -1,7 +1,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;
diff --git a/mail/serialmail/files/patch-leapsecs__read.c b/mail/serialmail/files/patch-leapsecs__read.c
new file mode 100644
index 000000000000..60cacfbe6e32
--- /dev/null
+++ b/mail/serialmail/files/patch-leapsecs__read.c
@@ -0,0 +1,10 @@
+--- leapsecs_read.c.orig
++++ leapsecs_read.c
+@@ -2,7 +2,6 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <errno.h>
+-extern int errno;
+ #include "tai.h"
+ #include "leapsecs.h"
+